Results 1 to 6 of 6

Thread: Graphical Interface will not start

  1. #1

    Angry Graphical Interface will not start

    I've been wrestling with this problem for about a week now. When I boot from my hard disk, everything goes smoothly up until the point where X11 starts up (I see a black screen with a white cursor that I can move with the mouse). Then -- nothing. No green light bulb. No Plasma 5 desktop. Nothing.

    I thought I had resolved this problem by specifying "NOMODESET" in the GRUB2 parameters (there's a recent thread on that topic). But that medicine doesn't seem to be strong enough any longer.

    Any help would be appreciated. Thanks! dcb

    Oh -- I've been using OpenSuse Linux since 2002 (release 9.0, as I recall). I ran 13.1 without much trouble until about a week ago, when I decided to upgrade to Tumbleweed. Since then it's all been downhill. I'm beginning to regret my decision.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,726

    Default Re: Graphical Interface will not start

    All information about your graphics card is missing.
    Henk van Velden

  3. #3
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    457

    Default Re: Graphical Interface will not start

    Can you try to switch to a text console and back to GUI ?
    todo: press Ctrl-Alt-F1 and then Ctrl-Alt-F7

    Lately I have to do this sometimes to see the desktop after the login.

    Hendrik

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,726

    Default Re: Graphical Interface will not start

    Quote Originally Posted by hendwolt View Post
    Can you try to switch to a text console and back to GUI ?
    todo: press Ctrl-Alt-F1 and then Ctrl-Alt-F7

    Lately I have to do this sometimes to see the desktop after the login.

    Hendrik
    As I understand it, he does not even see a graphical login screen, thus there is still no desktop started. But the Ctrl-Alt-Fn works also when you are at the login screen.
    Henk van Velden

  5. #5

    Red face Re: Graphical Interface will not start

    Quote Originally Posted by hcvv View Post
    All information about your graphics card is missing.
    Oh -- I'm sorry. I'm new here. Is this what you need? It's from YAST2 Hardware module, and appears to describe my "graphics card".

    Code:
      P: /devices/pci0000:00/0000:00:02.0
      E: DEVPATH=/devices/pci0000:00/0000:00:02.0
      E: ID_MODEL_FROM_DATABASE=82865G Integrated Graphics Controller (Desktop Board D865GBF)
      E: ID_PCI_CLASS_FROM_DATABASE=Display controller
      E: ID_PCI_INTERFACE_FROM_DATABASE=VGA controller
      E: ID_PCI_SUBCLASS_FROM_DATABASE=VGA compatible controller
      E: ID_VENDOR_FROM_DATABASE=Intel Corporation
      E: MODALIAS=pci:v00008086d00002572sv00008086sd00004246bc03sc00i00
      E: PCI_CLASS=30000
      E: PCI_ID=8086:2572
      E: PCI_SLOT_NAME=0000:00:02.0
      E: PCI_SUBSYS_ID=8086:4246
      E: SUBSYSTEM=pci
      E: USEC_INITIALIZED=38293858
    FWIW, I went ahead and re-installed Tumbleweed (32-bit) using a "network" DVD. At the moment my system seems to be working OK. If it fails again, I'll be back!

  6. #6

    Talking Re: Graphical Interface will not start

    Quote Originally Posted by hendwolt View Post
    Can you try to switch to a text console and back to GUI ?
    todo: press Ctrl-Alt-F1 and then Ctrl-Alt-F7

    Lately I have to do this sometimes to see the desktop after the login.

    Hendrik
    OK, thanks for the tip, Hendrik. Right now my system is running OK (I re-installed it today, and the big bugs seem to be fixed, although some little ones remain.)

    I tried it just now and it worked like a champ. I'll remember this procedure the next time I have the problem. Oh yeah -- on a similar note, last week I had a problem where no GUI desktop would appear, but after 10 minutes or so a message would appear ("Loginctl is broken. Press alt + ctrl + f2 to switch to root prompt and enter LOGINCTL UNLOCK-SESSIONS, then press alt + ctrl + f7 to return to this screen.") I followed the instructions, but that never seemed to help. Eventually I stumbled across the "NOMODESET" parameter in GRUB2, which solved the problem for about one day.

    Never a dull moment!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •