Results 1 to 7 of 7

Thread: Problem with update after swiching from leap 42.2 to leap 42.3

  1. #1

    Default Problem with update after swiching from leap 42.2 to leap 42.3

    Last week I updated my computer from leap 42.2 to leap 42.3. Following the update assistance for the installed packages, I get the following error message

    Code:
     patch:openSUSE-2017-1100-1.noarch steht in Konflikt mit libvlc5.x86_64 < 2.2.6-3.1, das von libvlc5-2.2.4-32.4.2.x86_64 zur Verfügung gestellt wurde
    Thank you very much for your help to remove this conflict.

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,669

    Default Re: Problem with update after swiching from leap 42.2 to leap 42.3

    Hi, update libvlc5 from the official Leap 42.3 Update repo, or download the package from here: https://download.opensuse.org/reposi...3.1.x86_64.rpm
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,894

    Default Re: Problem with update after swiching from leap 42.2 to leap 42.3

    Quote Originally Posted by SUSEpasc View Post
    Last week I updated my computer from leap 42.2 to leap 42.3.
    You do not explain how you did it. It could be that such a problem is due to doing the update not correct.

    Better check which repos you have now
    Code:
    LANG=C zypper lr -d
    Henk van Velden

  4. #4

    Default Re: Problem with update after swiching from leap 42.2 to leap 42.3

    Quote Originally Posted by OrsoBruno View Post
    Hi, update libvlc5 from the official Leap 42.3 Update repo, or download the package from here: https://download.opensuse.org/reposi...3.1.x86_64.rpm
    Followed your link, and the update worked accepting the updates on all dependencies. The suggested update button disappeared, so basically my problem is solved. Thank you very much!

    Quote Originally Posted by hcvv View Post
    You do not explain how you did it. It could be that such a problem is due to doing the update not correct.

    Better check which repos you have now
    Code:
    LANG=C zypper lr -d
    I downloaded the installation file, created a bootable memory stick and selected "update" in the installation menu. After that I simply clicked trough the installation assistant accepting all the suggested steps. The repository list reads as follows:

    Code:
    #  | Alias                     | Name                                                | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
    ---+---------------------------+-----------------------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
     1 | openSUSE-Leap-42.3-0      | openSUSE-Leap-42.3-0                                | No      | ----      | ----    |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-058f_6387_13021912000002-0:0-part2     |        
     2 | ownbrander_polybox        | Desktop Client project polybox (openSUSE_Leap_42.2) | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://polybox.ethz.ch/repo/openSUSE_Leap_42.2                          |        
     3 | repo-debug                | openSUSE-Leap-42.3-Debug                            | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/      |        
     4 | repo-debug-non-oss        | openSUSE-Leap-42.3-Debug-Non-Oss                    | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/  |        
     5 | repo-debug-update         | openSUSE-Leap-42.3-Update-Debug                     | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                 |        
     6 | repo-debug-update-non-oss | openSUSE-Leap-42.3-Update-Debug-Non-Oss             | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/             |        
     7 | repo-non-oss              | openSUSE-Leap-42.3-Non-Oss                          | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/        |        
     8 | repo-oss                  | openSUSE-Leap-42.3-Oss                              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/            |        
     9 | repo-source               | openSUSE-Leap-42.3-Source                           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/     |        
    10 | repo-source-non-oss       | openSUSE-Leap-42.3-Source-Non-Oss                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/ |        
    11 | repo-update               | openSUSE-Leap-42.3-Update                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                       |        
    12 | repo-update-non-oss       | openSUSE-Leap-42.3-Update-Non-Oss                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/
    Any further suggestions on that?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,894

    Default Re: Problem with update after swiching from leap 42.2 to leap 42.3

    I see at least one 42.2 repo still in your list. Remove it or change it to it's 43.3 equivalent and do a zypper dup from that one.

    And again I notice that you did NOT include the prompts (before and after) nor the command. Is it really so difficult to increase your mouse copy sweep a little bit to include that information? It is not always crucial, but often it gives important information to your potential helpers.
    Henk van Velden

  6. #6

    Default Re: Problem with update after swiching from leap 42.2 to leap 42.3

    Quote Originally Posted by hcvv View Post
    I see at least one 42.2 repo still in your list. Remove it or change it to it's 43.3 equivalent and do a zypper dup from that one.
    As far as I saw on the webpage of the publisher, there no 42.3 version. Could that cause problems?

    Quote Originally Posted by hcvv View Post
    And again I notice that you did NOT include the prompts (before and after) nor the command. Is it really so difficult to increase your mouse copy sweep a little bit to include that information? It is not always crucial, but often it gives important information to your potential helpers.
    Of course, excuse me, I'll take care to include it in the future. Thank you very much for your help.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,894

    Default Re: Problem with update after swiching from leap 42.2 to leap 42.3

    Quote Originally Posted by SUSEpasc View Post
    As far as I saw on the webpage of the publisher, there no 42.3 version. Could that cause problems?
    It depends. The packages there may need older library packages, which they then either have (and then you don't have the current ones), or they haven't and then they will be broken.

    Thus the maintainers there saying there isn't a new one, bu not ensuring you that it will work with (and not break) your 42.3 are not complete with the information they should provide.

    Personally, I would ask myself if I really need a product that is not kept up-to-date by the maintainers.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •