Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Getting Clementine to work

  1. #1
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    415

    Default Getting Clementine to work

    Hello, I will first say that I am using KDE LEAP 42.2 and I've been wrestling to get my Clementine to work.

    I have so far:
    1. Installed codecs as guided here: http://opensuse-guide.org/codecs.php
    except I changed the version numbers
    2. I installed the gstreamer-0.1 plugins, all of them.
    https://forums.opensuse.org/showthre...entine-to-work
    and yes I've been doing a lot of reading


    https://www.reddit.com/r/openSUSE/co...ed_clementine/

    despite all of the effort, clementine cannot read any music file and returns this error:

    GStreamer could not create the element: audioconvert. Please make sure that you have installed all necessary GStreamer plugins (e.g. OGG and MP3)


    Could someone help me out here please. I did get Clementine to work on OpenSUSE 13.2 KDE 64 bit, and maybe I forgot a few steps.

    The following music players do NOT work:
    Clementine, Musique, Amarok
    following can play sound/music fine:
    VLC, Dragon Player, DeadBeef

    Thank you.
    -SJL

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Getting Clementine to work

    that's an old thread Clementine switched to gstreamer-1.0 some time ago
    https://raw.githubusercontent.com/cl...ster/Changelog
    gstreamer-0.10 has been depreciated I'd recommend removing it afaik nothing uses it any more
    Clementine works fine with gstreamer from packman for me, I'm thinking you didn't do a full vendor change what's your repo list
    Code:
    zypper lr -d
    for mp3 support you'd need gstreamer-plugins-ugly do you have it as it's not installed by default on plasma 5 systems only on Gnome
    Code:
    zypper se -si gstreamer-plugins-ugly
    if you don't have it install it

    ps what does this mean?
    1. Installed codecs as guided here: http://opensuse-guide.org/codecs.php
    except I changed the version numbers

  3. #3
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    415

    Default Re: Getting Clementine to work

    Code:
    sudo zypper lr -d |grep Yes                                                                                                                                                                                      1 | dvd                                 | dvd                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.2/                             |        
     2 | google-chrome                       | google-chrome                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                            |        
     3 | http-download.opensuse.org-286eb157 | multimedia:libs                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_Leap_42.2/ |        
     4 | http-download.opensuse.org-4d00356e | KDE:Extra                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_42.2/       |        
     5 | http-download.opensuse.org-9743b217 | multimedia:apps                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_Leap_42.2/ |        
     6 | openSUSE-42.2-0                     | openSUSE-42.2-0                         | Yes     | (r ) Yes  | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-MATSHITADVD-RAM_UJ8B0_YM39_364198           |        
     7 | packman                             | packman                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.2/                               |        
    12 | repo-non-oss                        | openSUSE-Leap-42.2-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/              |        
    13 | repo-oss                            | openSUSE-Leap-42.2-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/oss/                  |        
    16 | repo-update                         | openSUSE-Leap-42.2-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.2/oss/                             |        
    17 | repo-update-non-oss                 | openSUSE-Leap-42.2-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/

    Code:
    sudo zypper se -si gstreamer-plugins-ugly |grep ugly
    i+ | gstreamer-plugins-ugly            | package | 1.8.3-2.4.1 | x86_64 | packman    
    i+ | gstreamer-plugins-ugly-lang       | package | 1.8.3-2.4.1 | noarch | packman    
    i+ | gstreamer-plugins-ugly-orig-addon | package | 1.8.3-2.4.1 | x86_64 | packman
    
    As for:
    1. Installed codecs as guided here: http://opensuse-guide.org/codecs.php
    except I changed the version numbers
    by which I mean

    I ran (instead 42.3)

    zypper addrepo -f http://packman.inode.at/suse/openSUSE_Leap_42.2/ packman
    zypper addrepo -f http://opensuse-guide.org/repo/openSUSE_Leap_42.2/ dvd

    2) Then install the necessary packages:zypper install ffmpeg lame gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-libav libdvdcss2

    You will be asked if you want to allow vendor change for some packages - allow it.

    3) Make sure all your multimedia packages are coming from the Packman Repository:zypper dup --from http://packman.inode.at/suse/openSUSE_Leap_42.2/

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Getting Clementine to work

    you did right
    I can say is do another vendor change to packman
    Code:
    zypper dup --from 7
    and delete the gstreamer cache as it might be corrupt (both amarok and clementine use gstreamer as a backend)
    Code:
    rm -r ~/.cache/gstreamer-1.0/
    ps
    amarok actually uses phonon not gstreamer directly and by installing different phonon backend you can use a different media subsystem
    for example by installing phonon-backend-vlc and setting it as the default in systemsettings5 you can use libvlc for media decoding in amarok (this won't work in clementine as clementine uses gstreamer directly)
    Code:
    zypper in phonon-backend-vlc
    there are other phonon backends (mplayer and xine) but those have been abandoned

  5. #5
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    415

    Default Re: Getting Clementine to work

    Hello I_A,

    it seems that Amarok works from the phonon-backend-vlc installation, but Clementine and Musique seems to still want to not play anything for me. After re-checking the vendor change, I deleted the gstream-1.0 cache, and to no avail.

    I'm not quite sure what's going on.

    Clementine is my favorite player, but Tomahawk may take its place if I can't get it up and running.

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Getting Clementine to work

    I just checked both packman and OSS release of gstreamer-plugins-ugly for 42.2 are missing libgstmpg123.so
    ftp://packman.inode.at/suse/openSUSE...4.1.x86_64.rpm
    https://download.opensuse.org/reposi...1.2.x86_64.rpm
    libgstmpg123.so provides mp3 support
    libgstmpg123.so is present in the 42.3 release in both OpenSuse and the packman repo's
    https://download.opensuse.org/reposi...4.1.x86_64.rpm
    ftp://packman.inode.at/suse/openSUSE...7.1.x86_64.rpm
    this is a packaging bug you should report at
    https://bugzilla.opensuse.org
    in the mean time you can install Fluendo's mp3 decoder
    Code:
    zypper in gstreamer-fluendo-mp3
    ps libgstmpg123.so was missing for 42.3 and I remember a bug report about it, they seam to have fixed the 42.3 release but forgot 42.2, packman's build use to carry the proper rpm but things happen automated builds cause errors etc.

  7. #7
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    415

    Default Re: Getting Clementine to work

    Hello I_A

    Slight problem:
    Code:
    rpm -qa |grep fluendo
    pullin-fluendo-mp3-13.2-5.1.noarch
    gstreamer-fluendo-mp3-21-18.2.x86_64
    gstreamer-0_10-fluendo-mp3-21-2.1.x86_64
    
    I've already installed the fluendo packages while I was doing some readings. No Clementine yet.

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Getting Clementine to work

    Quote Originally Posted by SJLPHI View Post
    Hello I_A

    Slight problem:
    Code:
    rpm -qa |grep fluendo
    pullin-fluendo-mp3-13.2-5.1.noarch
    gstreamer-fluendo-mp3-21-18.2.x86_64
    gstreamer-0_10-fluendo-mp3-21-2.1.x86_64
    
    I've already installed the fluendo packages while I was doing some readings. No Clementine yet.
    I haven't used the fluendo package in ages all I can say is try and force installing the 42.3 package from packman or OSS
    Code:
    zypper in -f ftp://packman.inode.at/suse/openSUSE_Leap_42.3/Essentials/x86_64/gstreamer-plugins-ugly-1.8.3-7.1.x86_64.rpm
    as that one does have libgstmpg123.so
    or download the 42.3 rpm extract libgstmpg123.so with ark and copy it to /usr/lib64/gstreamer-1.0

  9. #9
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    415

    Default Re: Getting Clementine to work

    I'm sorry for keep on coming up new ways to show that it doesn't work, but before I tried working with your copying the rpm package, I checked, and apparently I have that already.
    Code:
    ls /usr/lib64/gstreamer-1.0|grep libgstmpg
    libgstmpg123.so
    

  10. #10
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    415

    Default Re: Getting Clementine to work

    Okay, with a bit more focus, now it's saying something else,

    Code:
    GStreamer could not create the element: queue2. Please make sure that you have installed all necessary GStreamer plugins (e.g. OGG and MP3)

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •