Results 1 to 7 of 7

Thread: running/compiling qoobar in leap 42.3

  1. #1

    Default running/compiling qoobar in leap 42.3

    After upgrading opensuse from 13.2 to 42.3
    one of my favorite applications qoobar (http://qoobar.sourceforge.net/en/index.htm)
    is no longer available on opensuse.
    I tried to contact the developer but didn't get an answer.

    trying to compile fails with:

    sh: lupdate-qt4: Kommando nicht gefunden.
    Project MESSAGE: Linux build
    Project ERROR: Package gstreamer-app-0.10 not found
    Makefile:37: recipe for target 'src/qoobar_app/Makefile' failed
    make: *** [src/qoobar_app/Makefile] Error 2

    maybe for someone who knows how to build qt apps it might not be that difficult to solve the problems...
    unfortunately it's beyond my skills.

    I know, that the windows version works in wine, but it would be nice to have linux version...

    Is there hope?

    Kind regards
    Franz Bakan

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,888

    Default AW: running/compiling qoobar in leap 42.3

    Ist eine qt4 Anwendung.

    Nimm Easy-Tag, damit kann man genau dasselbe machen.

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,888

    Default AW: running/compiling qoobar in leap 42.3

    Project ERROR: Package gstreamer-app-0.10 not found
    Aus dem /qoobar-1.6.9.1/rpm/qoobar.spec:
    %if 0%{?suse_version}
    BuildRequires: libqt4-devel >= 4.5, update-desktop-files, zlib-devel
    BuildRequires: glib2-devel, gstreamer-0_10-devel, gstreamer-0_10-plugins-base-devel
    Aber selbst danach gab es bei mir noch Fehler.......
    Und wenn der Entwickler schon nicht antwortet.......

  4. #4

    Default AW: running/compiling qoobar in leap 42.3

    Quote Originally Posted by Sauerland View Post
    Ist eine qt4 Anwendung.

    Nimm Easy-Tag, damit kann man genau dasselbe machen.
    Hab mir Easy-Tag angesehen, kann leider nicht dasselbe. Qoobar ist um einiges komfortabler.
    Keine Abfrage bei discogs oder musicbrainz...

    Aber Danke für den Tip.

    Franz

  5. #5

    Default AW: running/compiling qoobar in leap 42.3

    Bin etwas weiter gekommen...

    Nach

    sudo ln -s lupdate lupdate-qt4
    und
    sudo ln -s lrelease lrelease-qt4

    und der Installation von gstreamer-0_10-plugins-base-devel

    scheitere ich jetzt an

    ...
    In file included from main.cpp:27:0:
    application.h:252:40: error: ‘Qt::ApplicationState’ has not been declared

    Wenn ich nun

    in qoobar-1.6.9.1/src/qoobar_app/Makefile

    -I/usr/include/qt5

    händisch zum INCPATH hinzufüge scheitert der Build mit:

    ...
    /usr/include/QtCore/qvector.h:547:75: error: ‘qMemSet’ was not declared in this scope
    Makefile:893: recipe for target '../../release/build/main.o' failed
    make[1]: *** [../../release/build/main.o] Error 1

    Und hier weiss ich nun wirklich nicht mehr weiter.

    Hat jemand nen Tip?

  6. #6
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    377

    Default AW: running/compiling qoobar in leap 42.3

    Quote Originally Posted by fbakan View Post
    Hab mir Easy-Tag angesehen, kann leider nicht dasselbe. Qoobar ist um einiges komfortabler.
    Keine Abfrage bei discogs oder musicbrainz...
    Mit EasyTAG konnte ich mich auch nicht anfreunden und bin dann auf Puddletag, welches auch auf MusicBrainz zugreifen kann, umgestiegen. Meine aber jetzt bevorzugte Anwendung dafür macht auch Abfragen bei Discogs, MusicBrainz und weitere Quellen, dieses ist Kid3.

  7. #7

    Default AW: running/compiling qoobar in leap 42.3

    Quote Originally Posted by tomm_fa View Post
    Mit EasyTAG konnte ich mich auch nicht anfreunden und bin dann auf Puddletag, welches auch auf MusicBrainz zugreifen kann, umgestiegen. Meine aber jetzt bevorzugte Anwendung dafür macht auch Abfragen bei Discogs, MusicBrainz und weitere Quellen, dieses ist Kid3.
    Danke für den Tip! Sieht gut aus!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •