Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: Update - now IPv6 adress on interface

  1. #11
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,674
    Blog Entries
    15

    Default Re: Update - now IPv6 adress on interface

    Quote Originally Posted by suse_rasputin View Post
    What is the output of

    Code:
    ip addr
    ?

    Are you really still on 42.2?
    Hi
    On this machine, yup, have Tumbleweed on the MacBook and a RPI3, 43.3 on the HP 14 and a RPI3.....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  2. #12

    Default Re: Update - now IPv6 adress on interface

    ...so that is the output of

    Code:
    ip addr
    on your TW machines?

    How to disable the IPv6 address on TW?
    Kind regards

    raspu

  3. #13
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,674
    Blog Entries
    15

    Default Re: Update - now IPv6 adress on interface

    Quote Originally Posted by suse_rasputin View Post
    ...so that is the output of

    Code:
    ip addr
    on your TW machines?

    How to disable the IPv6 address on TW?
    Hi
    That is the command to run, do you see ipv6 in the output? In Network Manager in the connection profile (see my screenshot), must be similar in Plasma?
    Code:
    cat /etc/os-release 
    
    NAME="openSUSE Tumbleweed"
    # VERSION="20170927"
    ID=opensuse
    ID_LIKE="suse"
    VERSION_ID="20170927"
    PRETTY_NAME="openSUSE Tumbleweed"
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:opensuse:tumbleweed:20170927"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://www.opensuse.org/"
    
    ip addr
    
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
    2: ens5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 00:1e:c2:04:94:1d brd ff:ff:ff:ff:ff:ff
        inet 192.168.10.40/24 brd 192.168.10.255 scope global ens5
           valid_lft forever preferred_lft forever
    If no inet6, then it's coming from somewhere else, run wireshark.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #14

    Default Re: Update - now IPv6 adress on interface

    ...have you chosen wicked? If I choose Wicked, the IPv6 address is gone, switching back to NetworkManager, IPv6 address is back. On all machines. One of the machines is located a network with no other machines. Even there is the IPv6. Machines connected to different routers/firewalls. None has DHCPv6 active. All blocking any IPv6. What should Wireshark buy me here? Again: How to disable the IPv6 address for the active interface with NetworkManager since one of the recent updates. The post by TSU insinuates that recently something has changed.
    Kind regards

    raspu

  5. #15
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,674
    Blog Entries
    15

    Default Re: Update - now IPv6 adress on interface

    Quote Originally Posted by suse_rasputin View Post
    ...have you chosen wicked? If I choose Wicked, the IPv6 address is gone, switching back to NetworkManager, IPv6 address is back. On all machines. One of the machines is located a network with no other machines. Even there is the IPv6. Machines connected to different routers/firewalls. None has DHCPv6 active. All blocking any IPv6. What should Wireshark buy me here? Again: How to disable the IPv6 address for the active interface with NetworkManager since one of the recent updates. The post by TSU insinuates that recently something has changed.
    Hi
    I don't use Plasma, but GNOME and it's working fine and disabled. So look at the NetworkManager settings is there an option to disable ipv6? What is the output from the ip addr command with NetworkManager running?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #16

    Default Re: Update - now IPv6 adress on interface

    I activate Network Manager in YasT, IPv6 disabled, interface set to DHCPv4:

    Code:
    ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
    2: enp6s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether bc:30:5b:af:0c:87 brd ff:ff:ff:ff:ff:ff
        inet 10.10.10.129/28 brd 10.0.0.163 scope global dynamic enp6s0
           valid_lft 7194sec preferred_lft 7194sec
        inet6 fe80::b4a9:bXX6:YY46:ZZZ6/64 scope link 
           valid_lft forever preferred_lft forever
    I swich back to Wicked, without touching anything else:

    Code:
    ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
    2: enp6s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether bc:30:5b:af:0c:87 brd ff:ff:ff:ff:ff:ff
        inet 10.10.10.129/28 brd 10.0.0.163 scope global enp6s0
           valid_lft forever preferred_lft forever
    ...and the IPv6 address is gone. I can do this multiple times, back an forth, on all TW, same result everytime.

    Now. Please. How to have NetworkManager but no IPv6 address on my interfaces?
    Kind regards

    raspu

  7. #17
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,674
    Blog Entries
    15

    Default Re: Update - now IPv6 adress on interface

    Quote Originally Posted by suse_rasputin View Post
    I
    Now. Please. How to have NetworkManager but no IPv6 address on my interfaces?
    Hi
    If you set a static ip, netmask and gateway address, does it disappear?

    If you create a test user and use NetworkManager (dhcp) does the issue duplicate?

    Nothing on the device issuing the dhcp address firing off ipv6 leases?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #18
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,504
    Blog Entries
    3

    Default Re: Update - now IPv6 adress on interface

    Quote Originally Posted by suse_rasputin View Post
    How to disable the IPv6 address for the active interface with NetworkManager since one of the recent updates.
    There's a configuration file "/etc/NetworkManager.conf". But I don't know if there is a setting to disable IPv6. I did not see on while browsing the man page.

    There is a connection specific setting. You have to go into connection settings (right click on the NetworkManager icon). And then edit the connection that you are using.

    There's a tab for ipv6. You may have to maximize the connection editor, or scroll right, in order to see that tab.

    On that tab, there's a box for "Method". It defaults to "Automatic". Changing to "ignored" will probably disable ipv6. Maybe the change doesn't take effect until reboot.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #19

    Default Re: Update - now IPv6 adress on interface

    Hi nrickert!

    VERY good point! I had manually diabled IPv6 in the NetworkManager (right-click on icon) after installing TW.

    But now I can't change any settings there for the IPv6 tab, tried 4 different TWs. Switching from "Automatic" (which is chosen now) to anything else (e.g. "Igonre"), the "Apply"-button stays greyed-out, after clicking "OK" and entering the tab for IPv6 again, it is still set to "Automatic".

    How come!? We are getting closer...

    PS: Tried it with a fresh user on two systems, same result...


    ("/etc/NetworkManager.conf" is empty, wrt IPv6 and not an option, as it is reset by every TW update)
    Kind regards

    raspu

  10. #20

    Default Re: Update - now IPv6 adress on interface

    PPS: Tried to change these settings in the NetworkManager of a 42.3, there I get asked for the root password to change the interfaces IPv6 settings.

    Is this a bug in TW? Maybe?
    Kind regards

    raspu

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •