Page 1 of 5 123 ... LastLast
Results 1 to 10 of 41

Thread: 20170924 to 20170925 dup failed.

  1. #1
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    427

    Default 20170924 to 20170925 dup failed.

    Hot on the heels of my https://forums.opensuse.org/showthre...c-link-quot-OK , tonight i tried dup'ing from 20170924 to 20170925. This happened [again, there were many many many more of the "is not a symbolic link" messages than i've shown here]:
    Code:
    (240/256) Installing: libavformat57-3.3.4-3.4.x86_64 ............................................................[done]
    Additional rpm output:
    /sbin/ldconfig: /usr/lib/libbrcolm2.so.1 is not a symbolic link
    
    
    /sbin/ldconfig: /usr/lib/libbrscandec2.so.1 is not a symbolic link
    
    
    /sbin/ldconfig: /usr/lib/libbrcolm2.so.1 is not a symbolic link
    
    
    /sbin/ldconfig: /usr/lib/libbrscandec2.so.1 is not a symbolic link
    
    
    
    
    
    
    (241/256) Installing: libavformat56-2.8.13-4.4.x86_64 ...........................................................[done]
    Additional rpm output:
    /sbin/ldconfig: /usr/lib/libbrcolm2.so.1 is not a symbolic link
    
    
    /sbin/ldconfig: /usr/lib/libbrscandec2.so.1 is not a symbolic link
    
    
    /sbin/ldconfig: /usr/lib/libbrcolm2.so.1 is not a symbolic link
    
    
    /sbin/ldconfig: /usr/lib/libbrscandec2.so.1 is not a symbolic link
    
    
    
    
    
    
    (242/256) Installing: libavfilter6-3.3.4-3.4.x86_64 .............................................................[done]
    Additional rpm output:
    /sbin/ldconfig: /usr/lib/libbrcolm2.so.1 is not a symbolic link
    
    
    /sbin/ldconfig: /usr/lib/libbrscandec2.so.1 is not a symbolic link
    
    
    /sbin/ldconfig: /usr/lib/libbrcolm2.so.1 is not a symbolic link
    
    
    /sbin/ldconfig: /usr/lib/libbrscandec2.so.1 is not a symbolic link
    
    
    
    
    
    
    (243/256) Installing: MPlayer-1.2.r37916-6.11.x86_64 ............................................................[done]
    (244/256) Installing: audacious-plugins-3.9-10.4.x86_64 .........................................................[done]
    (245/256) Installing: transcode-1.1.7-4.6.x86_64 ...............................................................[error]
    Installation of transcode-1.1.7-4.6.x86_64 failed:
    Error: Subprocess failed. Error: RPM failed: error: unpacking of archive failed on file /usr/lib64/transcode/encode_lame.so;59ccb81c: cpio: chmod
    error: transcode-1.1.7-4.6.x86_64: install failed
    error: transcode-1.1.7-4.5.x86_64: erase skipped
    
    
    Abort, retry, ignore? [a/r/i] (a): r
    Installation of transcode-1.1.7-4.6.x86_64 failed:
    Error: Subprocess failed. Error: RPM failed: error: can't create transaction lock on /var/lib/rpm/.rpm.lock (Inappropriate ioctl for device)
    
    
    Abort, retry, ignore? [a/r/i] (a): r
    Installation of transcode-1.1.7-4.6.x86_64 failed:
    Error: Subprocess failed. Error: RPM failed: error: can't create transaction lock on /var/lib/rpm/.rpm.lock (Inappropriate ioctl for device)
    
    
    Abort, retry, ignore? [a/r/i] (a): r
    Installation of transcode-1.1.7-4.6.x86_64 failed:
    Error: Subprocess failed. Error: RPM failed: error: can't create transaction lock on /var/lib/rpm/.rpm.lock (Inappropriate ioctl for device)
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    (246/256) Installing: libavdevice57-3.3.4-3.4.x86_64 ...........................................................[error]
    Installation of libavdevice57-3.3.4-3.4.x86_64 failed:
    Error: Subprocess failed. Error: RPM failed: error: can't create transaction lock on /var/lib/rpm/.rpm.lock (Inappropriate ioctl for device)
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    (247/256) Installing: gstreamer-plugins-libav-1.12.3-7.1.x86_64 ................................................[error]
    Installation of gstreamer-plugins-libav-1.12.3-7.1.x86_64 failed:
    Error: Subprocess failed. Error: RPM failed: error: can't create transaction lock on /var/lib/rpm/.rpm.lock (Inappropriate ioctl for device)
    
    
    Abort, retry, ignore? [a/r/i] (a): a
    Warning: %posttrans scripts skipped while aborting:
        libreoffice-icon-theme-galaxy-5.4.1.2-1.3.noarch.rpm
        python2-chardet-3.0.4-3.1.noarch.rpm
        kpartx-0.7.3+10+suse.70ccb55b0439-1.1.x86_64.rpm
        libreoffice-icon-theme-breeze-5.4.1.2-1.3.noarch.rpm
        openSUSE-release-20170925-1.2.x86_64.rpm
        virtualbox-host-kmp-default-5.1.28_k4.13.3_1-1.1.x86_64.rpm
        libreoffice-icon-theme-sifr-5.4.1.2-1.3.noarch.rpm
        libreoffice-icon-theme-hicontrast-5.4.1.2-1.3.noarch.rpm
        cups-2.2.3-2.1.x86_64.rpm
        libreoffice-l10n-en-5.4.1.2-1.3.noarch.rpm
    
    
    Problem occurred during or after installation or removal of packages:
    Installation aborted by user
    Please see the above error message for a hint.
    Questions, in order of increasing paranoia:
    1. What happened?
    2. What should i do now please?
    3. Is it safe to reboot, or is my TW now broken?
    OS: openSUSE Tumbleweed KDE x64 Plasma 5.10.5. Browser: Vivaldi-Snapshot x64. She not he, her not him.

  2. #2
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    427

    Default Re: 20170924 to 20170925 dup failed.

    Because i do not understand what has happened, & if my TW is now broken or not, i have not yet attempted a reboot [as i don't know if i will be able to get back into my desktop], whilst i await expert advice to be posted, i thought i'd try another dup. The result was quite ugly:

    Code:
    sudo zypper dup
    sudo: unable to open /var/lib/sudo/ts/gooeygirl: Read-only file system
    [sudo] password for root: 
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Bad media attach point: http://repo.vivaldi.com/snapshot/rpm/x86_64/
    History:
     - Create attach point: Can't find a writable directory to create an attach point
    
    
    Abort, retry, ignore? [a/r/i/...? shows all options] (a): a
    ABORT request: Aborting requested by user
    OS: openSUSE Tumbleweed KDE x64 Plasma 5.10.5. Browser: Vivaldi-Snapshot x64. She not he, her not him.

  3. #3
    Join Date
    Sep 2012
    Posts
    4,044

    Default Re: 20170924 to 20170925 dup failed.

    Well, your (root) filesystem became read-only. It could become full, this could be result of hardware or software errors accessing filesystem. Check kernel logs what happened, check free space.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    17,072
    Blog Entries
    13

    Default Re: 20170924 to 20170925 dup failed.

    IIRC you have been trying to get a Brother scanner to work, these libs seem to belong to that software.

    And, like Andrei says, check the disk space.
    ° Appreciate my reply? Click the star and let me kow why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    427

    Default Re: 20170924 to 20170925 dup failed.

    Thanks for replying. My root still has 39 GB free of its 60 GB.

    I tried opening KSystemLog, but:
    Configuration file "/root/.config/ksystemlogrc" not writable.
    Please contact your system administrator.
    Oh, despite that message, it then let me see the entries. I have pasted them from before i began the dup, here... https://pastebin.com/pz2jVc8J ... i can't recall exactly when i began the dup, but maybe it was ~18:00 to 18:15'ish? For reference, it's now 20:30 my time, AEST.

    I now am feeling like much pain is imminent, so i thought it best to perform a data backup before going any further. This requires first being able to mount & decrypt the associated VeraCrypt volume on my USB3 stick, but:
    Read-only file system:/media/veracrypt1


    VeraCrypt:irectory::Create:29
    I'm now beginning to feel sick in the tummy...
    OS: openSUSE Tumbleweed KDE x64 Plasma 5.10.5. Browser: Vivaldi-Snapshot x64. She not he, her not him.

  6. #6
    Join Date
    Sep 2012
    Posts
    4,044

    Default Re: 20170924 to 20170925 dup failed.

    Quote Originally Posted by GooeyGirl View Post
    This is software problem.
    Code:
    Thursday, 28 September 2017 18:51:40 AEST   kernel  ------------[ cut here ]------------
    Thursday, 28 September 2017 18:51:40 AEST   kernel  WARNING: CPU: 6 PID:  24304 at ../fs/btrfs/extent-tree.c:6980  
    __btrfs_free_extent.isra.61+0x1df/0xd40 
    ...
    Thursday, 28 September 2017 18:51:40 AEST   kernel  BTRFS error (device sda2): unable to find ref byte nr 16952909824 parent  0 root 259  owner 673265 offset 0
    Thursday, 28 September 2017 18:51:40 AEST   kernel  BTRFS: Transaction aborted (error -2)
    This is what caused kernel to make filesystem read-only to prevent further corruption. At this point you can try reboot and hope that whatever problem it was had been transient and cleared itself, or attempt to fix filesystem manually. You should also open bug report. If you can wait, I'd open bug report and waited for some time (it can be days) for response in case developers may want some information from live system.

    But be prepared to restore filesystem from backup. If it is corrupted, it is likely the only way to recover (why it got corrupted is another question).

  7. #7
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    427

    Default Re: 20170924 to 20170925 dup failed.

    Thank you. I was also looking thru' that log & also found the entry you identified. Unlike you, i did not know exactly what it meant, other than i assumed it was... bad!

    I realise that it would help the Devs if i could do what you suggested, but this is my primary pc, & i need it working... now... so i'm sorry but i can't really wait around.

    I just looked at my Snapshots in YaST Snapper [which was not happy to launch, telling me again that it's read-only], & i am wondering if this might work... if i try a normal reboot & it fails [as i fear now is likely], then maybe i could restore the highlighted snapshot... which i think was ~12' before i initiated the dup. But what happens if even then, during that process, the system is still read-only? Then it would stop me from restoring the snapshot. Oh well, i guess i'm about to find out...

    OS: openSUSE Tumbleweed KDE x64 Plasma 5.10.5. Browser: Vivaldi-Snapshot x64. She not he, her not him.

  8. #8
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    427

    Default Re: 20170924 to 20170925 dup failed.

    Well, it's good news, bad news.

    Good: The reboot proceeded without any apparent drama, & upon being logged in again to my desktop, i appeared to have write access again with root, eg, i was now able to launch YaST without any warning messages, i was able to use VeraCrypt as normal & complete my precautionary backup.

    Bad: I cannot do any more dups. Baaaaaaaad. Clearly the majority of the packages of this 20170925 snapshot must have completed being installed earlier, per my initial Code Box, because this time only 13 or 14 were mentioned:
    Code:
    [sudo] password for root: 
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Retrieving repository 'Vivaldi' metadata ........................................................................[done]
    Building repository 'Vivaldi' cache .............................................................................[done]
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    
    Problem: problem with installed package vokoscreen-2.5.0-1.68.x86_64
     Solution 1: install vokoscreen-2.5.0-1.1.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
    
    
    Choose the above solution using '1' or cancel using 'c' [1/c] (c): 1
    Resolving dependencies...
    Computing distribution upgrade...
    
    
    The following item is locked and will not be changed by any action:
     Available:
      AdobeICCProfiles
    
    
    The following 2 NEW packages are going to be installed:
      gstreamer-plugins-bad-lang gstreamer-plugins-ugly-lang
    
    
    The following 2 applications are going to be REMOVED:
      Vivaldi "Vivaldi (snapshot)"
    
    
    The following 10 packages are going to be upgraded:
      audacious-plugins-extra audacious-plugins-lang ffmpeg gmplayer gstreamer-plugins-libav kplayer libavdevice57
      transcode vivaldi-snapshot vivaldi-stable
    
    
    The following package is going to be downgraded:
      vokoscreen
    
    
    The following package is going to change vendor:
      vokoscreen  http://packman.links2linux.de -> openSUSE
    
    
    10 packages to upgrade, 1 to downgrade, 2 new, 1 to change vendor.
    Overall download size: 48.2 MiB. Already cached: 56.8 MiB. After the operation, additional 199.7 KiB will be used.
    Continue? [y/n/...? shows all options] (y): 
    In cache vivaldi-snapshot-1.13.971.8-1.x86_64.rpm                                (1/13),  51.1 MiB (202.9 MiB unpacked)
    Retrieving package vivaldi-stable-1.12.955.38-1.x86_64                           (2/13),  48.2 MiB (181.9 MiB unpacked)
    Retrieving: vivaldi-stable-1.12.955.38-1.x86_64.rpm ..............................................[done (1020.7 KiB/s)]
    In cache gstreamer-plugins-bad-lang-1.12.3-1.1.noarch.rpm                        (3/13), 100.7 KiB (108.3 KiB unpacked)
    In cache gstreamer-plugins-ugly-lang-1.12.3-1.1.noarch.rpm                       (4/13),  58.2 KiB ( 74.5 KiB unpacked)
    In cache kplayer-0.7.2-2.319.x86_64.rpm                                          (5/13), 566.9 KiB (  2.6 MiB unpacked)
    In cache transcode-1.1.7-4.6.x86_64.rpm                                          (6/13),   1.4 MiB (  6.9 MiB unpacked)
    In cache audacious-plugins-extra-3.9-10.4.x86_64.rpm                             (7/13),  29.2 KiB ( 62.0 KiB unpacked)
    In cache audacious-plugins-lang-3.9-10.4.noarch.rpm                              (8/13), 370.9 KiB (  2.2 MiB unpacked)
    In cache gmplayer-1.2.r37916-6.11.x86_64.rpm                                     (9/13), 311.7 KiB (295.4 KiB unpacked)
    In cache gstreamer-plugins-libav-1.12.3-7.1.x86_64.rpm                          (10/13), 192.7 KiB (460.4 KiB unpacked)
    In cache libavdevice57-3.3.4-3.4.x86_64.rpm                                     (11/13),  81.6 KiB (128.0 KiB unpacked)
    In cache ffmpeg-3.3.4-3.4.x86_64.rpm                                            (12/13),   1.5 MiB (  2.2 MiB unpacked)
    In cache vokoscreen-2.5.0-1.1.x86_64.rpm                                        (13/13),   1.1 MiB (  1.8 MiB unpacked)
    Checking for file conflicts: ...................................................................................[error]
    Detected 1 file conflict:
    
    
    File /usr/share/xfce4/helpers/vivaldi.desktop
      from install of
         vivaldi-stable-1.12.955.38-1.x86_64 (Vivaldi)
      conflicts with file from package
         exo-data-0.11.4-1.1.noarch (@System)
    
    
    File conflicts happen when two packages attempt to install files with the same name but different contents. If you continue, conflicting files will be replaced losing the previous content.
    Continue? [yes/no] (no): y
    
    
    ( 1/13) Installing: vivaldi-snapshot-1.13.971.8-1.x86_64 .......................................................[error]
    Installation of vivaldi-snapshot-1.13.971.8-1.x86_64 failed:
    Error: Subprocess failed. Error: RPM failed: error: rpmdb: Requirename page 10 is on free list with type 7             
    error: rpmdb: PANIC: Invalid argument                                                                                  
    error: db4 error(-30974) from dbcursor->c_put: DB_RUNRECOVERY: Fatal error, run database recovery                      
    
    #####################################################
    # I had to remove most lines due to character limits in the Forum; pls see https://pastebin.com/zvDwJDqr for the full text content.
    #####################################################
    
    error: rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30974) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
    error: rpmdb: File handles still open at environment close
    error: rpmdb: Open file handle: /var/lib/rpm/Packages
    error: rpmdb: Open file handle: /var/lib/rpm/Transfiletriggername
    error: rpmdb: Open file handle: /var/lib/rpm/Name
    error: rpmdb: Open file handle: /var/lib/rpm/Basenames
    error: rpmdb: Open file handle: /var/lib/rpm/Group
    error: rpmdb: Open file handle: /var/lib/rpm/Requirename
    error: rpmdb: Open file handle: /var/lib/rpm/Providename
    error: rpmdb: Open file handle: /var/lib/rpm/Conflictname
    error: rpmdb: Open file handle: /var/lib/rpm/Obsoletename
    error: rpmdb: Open file handle: /var/lib/rpm/Triggername
    error: rpmdb: Open file handle: /var/lib/rpm/Dirnames
    error: rpmdb: Open file handle: /var/lib/rpm/Installtid
    error: rpmdb: Open file handle: /var/lib/rpm/Sigmd5
    error: rpmdb: Open file handle: /var/lib/rpm/Sha1header
    error: rpmdb: Open file handle: /var/lib/rpm/Filetriggername
    error: rpmdb: Open file handle: /var/lib/rpm/Recommendname
    error: rpmdb: Open file handle: /var/lib/rpm/Suggestname
    error: rpmdb: Open file handle: /var/lib/rpm/Supplementname
    error: rpmdb: Open file handle: /var/lib/rpm/Enhancename
    error: rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30974) from dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery
    
    
    Abort, retry, ignore? [a/r/i] (a): 
    Problem occurred during or after installation or removal of packages:
    Installation aborted by user
    Please see the above error message for a hint.
    Oh dear.
    OS: openSUSE Tumbleweed KDE x64 Plasma 5.10.5. Browser: Vivaldi-Snapshot x64. She not he, her not him.

  9. #9
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    599

    Default Re: 20170924 to 20170925 dup failed.

    Make a backup copy of "/var/lib/rpm/" and then try running, with root privileges:
    Code:
    rpm --rebuilddb
    Regards, Paul

    Tumbleweed (Snapshot: 20171013) KDE Plasma 5
    Leap 42.3 KDE Plasma 5

  10. #10
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    427

    Default Re: 20170924 to 20170925 dup failed.

    Ta Paul. I did it. Nothing exploded, albeit the response in Konsole was... underwhelming:
    Code:
    gooeygirl@linux-Tower:/var/lib> sudo rpm --rebuilddb
    [sudo] password for root: 
    gooeygirl@linux-Tower:/var/lib>
    Should i have expected more "excitement"? Should i reboot now before trying another dup?
    OS: openSUSE Tumbleweed KDE x64 Plasma 5.10.5. Browser: Vivaldi-Snapshot x64. She not he, her not him.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •