Results 1 to 6 of 6

Thread: Is libxine really needed anymore?

  1. #1
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,190

    Default Is libxine really needed anymore?

    I was going to run an update and got this:
    Code:
    Problem: nothing provides libMagickWand-7.Q16HDRI.so.4 needed by libxine2-1.2.8-127.6.i586
     Solution 1: install libxine2-1.2.8-3.3.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: break libxine2-1.2.8-127.6.i586 by ignoring some of its dependencies
    I haven't used XINE MEDIAPLAYER since forever hence this question is libxine really needed for anyting other than the XINE MEDIAPLAYER?
    I'm just a curious cat
    My 64 bit: CPU AMD RYZEN 9 3900X 12 Core GPU MSI Radeon RX5600 XT
    MOTHERBOARD GIGABYTE B550 AORUS PRO AC
    Opensuse Tumbleweed Plasma 5

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Is libxine really needed anymore?

    I'm pretty sure kaffeine 1.2.2 still uses libxine, 2.0 uses libvlc
    1.2.2 is still the default media player for kde
    if you don't use kaffeine or use 2.0 from kde:extra you don't need libxine
    that being said I still use xine-ui now and then it's not my default media player but it's got it's uses (I also use kaffeine)

  3. #3

    Default Re: Is libxine really needed anymore?

    Quote Originally Posted by I_A View Post
    1.2.2 is still the default media player for kde
    if you don't use kaffeine or use 2.0 from kde:extra you don't need libxine
    Not in Tumbleweed though, which only has 2.0.x for some time already.
    (1.2.2 would be available in KDE:Extra for Tumbleweed too though, as package "kaffeine4")

    Btw, strictly speaking, kaffeine is *not* the default media player for kde, it's not even installed by default since Leap 42.1...

    Regarding the original question: I don't think anything else than kaffeine4 (1.2.2) or xine-ui still use libxine.
    subtitlecomposer did in earlier versions, but they use mpv meanwhile.
    If you want to, try to uninstall it, you will get asked to confirm the list of packages to remove anyway. Just enter "n" if some other packages would be removed.
    Or use this to be safe:
    Code:
    zypper rm --dry-run libxine2
    (this will just do a test run and not actually remove anything)

    Why is your libxine2 a 32bit package btw?
    Apparently you do have a 64bit system, otherwise zypper shouldn't try to switch it to 64bit...
    Seems to be pretty useless then anyway.
    Last edited by wolfi323; 28-Sep-2017 at 10:44.

  4. #4
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,190

    Default Re: Is libxine really needed anymore?

    Quote Originally Posted by wolfi323 View Post
    Not in Tumbleweed though, which only has 2.0.x for some time already.
    (1.2.2 would be available in KDE:Extra for Tumbleweed too though, as package "kaffeine4")

    Btw, strictly speaking, kaffeine is *not* the default media player for kde, it's not even installed by default since Leap 42.1...

    Regarding the original question: I don't think anything else than kaffeine4 (1.2.2) or xine-ui still use libxine.
    subtitlecomposer did in earlier versions, but they use mpv meanwhile.
    If you want to, try to uninstall it, you will get asked to confirm the list of packages to remove anyway. Just enter "n" if some other packages would be removed.
    Or use this to be safe:
    Code:
    zypper rm --dry-run libxine2
    (this will just do a test run and not actually remove anything)

    Why is your libxine2 a 32bit package btw?
    Apparently you do have a 64bit system, otherwise zypper shouldn't try to switch it to 64bit...
    Seems to be pretty useless then anyway.
    Wolfi, Thanks tried the cli you wrote my system is still here working so apparently TW can live without it & I can too.
    As to the 32bit like most of the 32bit stuff I have its legacy stuff & for those JICs.
    I'm just a curious cat
    My 64 bit: CPU AMD RYZEN 9 3900X 12 Core GPU MSI Radeon RX5600 XT
    MOTHERBOARD GIGABYTE B550 AORUS PRO AC
    Opensuse Tumbleweed Plasma 5

  5. #5

    Default Re: Is libxine really needed anymore?

    Quote Originally Posted by Sagemta View Post
    Wolfi, Thanks tried the cli you wrote my system is still here working so apparently TW can live without it & I can too.
    Yes, the "system"/TW can definitely live without it, or any multimedia stuff at all for that matter...

    If you want to use an application that uses it, you need to have it installed though. But normally that should be taken care of automatically by package dependencies.
    And as mentioned, AFAIK there is not much stuff left that actually does use libxine...

    Other things (not yet mentioned) that I have installed here that use it:
    xine-browser-plugin (obviously...), kde3-konverter, kde3-amarok(-xine)

    As to the 32bit like most of the 32bit stuff I have its legacy stuff & for those JICs.
    Well, if they are not installed via RPM packages, or the packages do not correctly specify the dependencies, it may be possible to remove it without warning and break something that way.
    Impossible to say though without knowing exactly what you have installed.
    As it is a library, an application using it will normally completely fail to start, so you probably will notice it anyway...

  6. #6
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: Is libxine really needed anymore?

    You have configured your repositories to use Repo packman
    Code:
    zypper dup --from packman
    loyalty returns to those who practice it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •