Results 1 to 7 of 7

Thread: Flash and audio capture

  1. #1

    Default Flash and audio capture

    I am running Opensuse 42.2 and have used Midomi.com to identify unknown songs for some time. The website requests to use Flash to access the microphone and that has always captured the currently playing audio stream. This still works if the source is the browser (64-bit Firefox ESR) but it garbles the stream if the source is a music file on the hard drive.

    I have tried both Flash and the Freshplayerplugin. With Flash the plugin never shows up in the Recording tab of the Pulse Audio Mixer (pavucontrol). With Freshplayer the plugin shows up in the mixer and records audio played by the browser. Music from the hard drive is garbled.

    Any suggestions on what to try to clear up capture of music played from the hard drive?

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Flash and audio capture

    where is your flash from?
    Code:
    zypper se -si flash
    since adobe restarted flash development for linux freshplayer plugin is not needed as it is a wrapper for ppapi flash which is the same in version and functionality as npapi (mozilla) flash
    now if for some strange version npapi flash does not work why not use ppapi flash under a ppapi based browser like chromium or vivaldi?

  3. #3

    Default Re: Flash and audio capture

    Quote Originally Posted by I_A View Post
    where is your flash from?
    Code:
    zypper se -si flash
    since adobe restarted flash development for linux freshplayer plugin is not needed as it is a wrapper for ppapi flash which is the same in version and functionality as npapi (mozilla) flash
    now if for some strange version npapi flash does not work why not use ppapi flash under a ppapi based browser like chromium or vivaldi?

    I tried the latest Adobe Flash first. It doesn't even register on the recording tab of the Pulse Audio Mixer when yes is clicked to give Flash permission to use the microphone. I assumed Adobe gave Linux some type of incomplete version of Flash and uninstalled it and then installed Freshplayer. The Freshplayer plugin registers properly on the Record tab of the Pulse Audio Mixer when yes is clicked on the Flash microphone popup. Freshplayer also captures music played through Firefox cleanly. At least my experience is Freshplayer is more fully compatible with Linux than Adobe's Flash release.

  4. #4

    Default Re: Flash and audio capture

    PS -
    Flash under Chromium doesn't register on the Recording tab of Mixer either.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Flash and audio capture

    Quote Originally Posted by matchpointok View Post
    PS -
    Flash under Chromium doesn't register on the Recording tab of Mixer either.
    I've read that Adobe elected not to support pulse audio with flash. I assume the only possibility for the mic to work would be if it the Adobe flash works with alsa (? and I don't know if it does ? ) and if an alsa recognized mic is supported by some alsa plugin to pulse. But my limited looking into this suggests its (flash recording) not supported by pulse, by any alsa plugin, possibly nor even by alsa.
    Last edited by oldcpu; 24-Sep-2017 at 11:54.

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Flash and audio capture

    as it would seam adobe dropped pulse support and freshplayerplugin did use some sort of redirection with pulse you might have 2 options
    continue using pepper flash with freshplayer or try using Firefox for windows with flash for windows under wine, that setup worked well in the past for some setups

  7. #7

    Default Re: Flash and audio capture

    Quote Originally Posted by I_A View Post
    as it would seam adobe dropped pulse support and freshplayerplugin did use some sort of redirection with pulse you might have 2 options
    continue using pepper flash with freshplayer or try using Firefox for windows with flash for windows under wine, that setup worked well in the past for some setups
    Thanks to all who tried to answer. Always a bit frustrating when something that once worked stops. I think I will try a microphone before heading back towards a Windows solution.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •