Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 36

Thread: xfce Okular hyperlinks are not working

  1. #21
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by wolfi323 View Post
    If you want to use Firefox, you can just delete that "BrowserApplication" line though, as Firefox is the default anyway.

    Also, it may be that the application actually doesn't use the (KDE) default browser, but rather the application associated with the "text/html" mimetype.
    The standard file associations can be changed in "kcmshell4 filetypes".

    Note that KDE actually follows standards here, but KDE4 (being outdated and basically unmaintained) uses an older one.
    KF5 should actually respect the XFCE settings, or more precise, should use the same (newer) standard and config files as XFCE for this.
    Yes, it is working quite well in 42.3, the way it is expected to work.

    (Okular in 42.2 is still KDE4 based, 42.3 contains the KF5 version)
    ... heh, yeah, that was what I said in the post Deano accidently obliterated.

    At any rate, if SUSEpasc -- or anyone else, for that matter -- wants, I will continue digging around, since I am still running Xfce in 42.2 for awhile on one of my machines. I will just wait now for further comments, or queries, from anyone who needs a better solution.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  2. #22
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: xfce Okular hyperlinks are not working

    ... oh, yes, and thanks to both of you for pitching it.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  3. #23

    Default Re: xfce Okular hyperlinks are not working

    Thank you very much for all your suggestions. I tried the follow the advice to update to LEAP 42.3, but after reinstalling okular, it still simply opens R when clicking a hyperlink. Any suggestions what to do starting from this new basis? ps: sorry if you already made any, I didn't went trough all the posts in details.

  4. #24

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by SUSEpasc View Post
    Thank you very much for all your suggestions. I tried the follow the advice to update to LEAP 42.3, but after reinstalling okular, it still simply opens R when clicking a hyperlink. Any suggestions what to do starting from this new basis? ps: sorry if you already made any, I didn't went trough all the posts in details.
    Check the file associations for text/html.

    Code:
    xdg-mime query default text/html
    
    or, to explicitly ask what the KDE Frameworks consider:
    Code:
    ktraderclient5 --mimetype text/html --short
    
    Btw, is it really 'R' that's being started? 'R' is just a command line tool...

    Code:
    test@linux-lf90:~> R
    
    R version 3.3.1 (2016-06-21) -- "Bug in Your Hair"
    Copyright (C) 2016 The R Foundation for Statistical Computing
    Platform: x86_64-suse-linux-gnu (64-bit)
    
    R is free software and comes with ABSOLUTELY NO WARRANTY.
    You are welcome to redistribute it under certain conditions.
    Type 'license()' or 'licence()' for distribution details.
    
    R is a collaborative project with many contributors.
    Type 'contributors()' for more information and
    'citation()' on how to cite R or R packages in publications.
    
    Type 'demo()' for some demos, 'help()' for on-line help, or
    'help.start()' for an HTML browser interface to help.
    Type 'q()' to quit R.
    
    > help.start()
    starting httpd help server ... done
    If the browser launched by 'xdg-open' is already running, it is *not*
        restarted, and you must switch to its window.
    Otherwise, be patient ...
    > 
    
    (the help.start() launches Konqueror here because that's my configured default browser and application for text/html, but that's of course rather irrelevant here...)
    Last edited by wolfi323; 23-Sep-2017 at 09:50.

  5. #25

    Default Re: xfce Okular hyperlinks are not working

    Yeah, you are right, it is Rstudio being started. Sorry for that. I tried the suggested commands the outputs are:

    Code:
    xdg-mime query default text/html
    firefox.desktop
    respectively

    Code:
     ktraderclient5 --mimetype text/html --short
    mimetype is : text/html
    The desktop entry file "/usr/share/applications/evince.desktop" has an empty mimetype!
    got 8 offers.
    /usr/share/applications/rstudio.desktop
    /usr/share/applications/firefox.desktop
    /usr/share/applications/leafpad.desktop
    /usr/share/applications/gimp.desktop
    /usr/share/applications/okularApplication_txt.desktop
    /usr/share/applications/writer.desktop
    /usr/share/applications/org.gnome.gedit.desktop
    /usr/share/applications/geany.desktop

  6. #26

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by SUSEpasc View Post
    Yeah, you are right, it is Rstudio being started. Sorry for that.
    Ok, thanks for the clarification.

    Rstudio does indeed register itself as handler for text/html files, its .desktop file contains this:
    Code:
    MimeType=text/x-r-source;text/x-r;text/x-R;text/x-r-doc;text/x-r-sweave;text/x-r-markdown;text/x-r-html;text/x-r-presentation;application/x-r-data;application/x-r-project;text/x-r-history;text/x-r-profile;text/x-tex;text/x-markdown;text/html;text/css;text/javascript;text/x-chdr;text/x-csrc;text/x-c++hdr;text/x-c++src;
    respectively

    Code:
     ktraderclient5 --mimetype text/html --short
    mimetype is : text/html
    The desktop entry file "/usr/share/applications/evince.desktop" has an empty mimetype!
    got 8 offers.
    /usr/share/applications/rstudio.desktop
    /usr/share/applications/firefox.desktop
    /usr/share/applications/leafpad.desktop
    /usr/share/applications/gimp.desktop
    /usr/share/applications/okularApplication_txt.desktop
    /usr/share/applications/writer.desktop
    /usr/share/applications/org.gnome.gedit.desktop
    /usr/share/applications/geany.desktop
    So here is your problem, the KDE frameworks do consider Rstudio as preferred application for text/html.

    I'm not sure why though at the moment.

    Could you please post ~/.config/mimeapps.list?

    Also, changing the application order for text/html in "kcmshell5 filetypes" should fix it then, you probably have to install the package kde-cli-tools5 first though.

    And as this thread originally was about Leap 42.2:
    For Leap 42.2's Konqueror (which was still KDE4 based), you'd need to use "kcmshell4 filetypes", contained in kdebase4-runtime... (although, kcmshell5 should sync back the settings to KDE4 as well)
    Last edited by wolfi323; 25-Sep-2017 at 00:18.

  7. #27

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by wolfi323 View Post

    Could you please post ~/.config/mimeapps.list?
    Here you go

    Code:
    [Added Associations]
    text/x-tex=texstudio.desktop;leafpad.desktop;
    application/pdf=evince.desktop;okularApplication_djvu.desktop;draw.desktop;okular.desktop;gimp.desktop;kde4-okular.desktop;kde4-okularApplication_xps.desktop;
    application/x-rar=org.gnome.FileRoller.desktop;
    text/plain=leafpad.desktop;gimp.desktop;okularApplication_txt.desktop;org.kde.kwrite.desktop;kde4-okularApplication_txt.desktop;
    application/vnd.oasis.opendocument.text=writer.desktop;
    image/jpeg=ristretto.desktop;gimp.desktop;
    application/vnd.ms-excel=calc.desktop;
    application/vnd.openxmlformats-officedocument.spreadsheetml.sheet=calc.desktop;
    application/msword=writer.desktop;
    text/x-r-source=rstudio.desktop;
    application/x-ms-dos-executable=org.gnome.FileRoller.desktop;
    application/x-cd-image=brasero.desktop;
    image/png=ristretto.desktop;gimp.desktop;shotwell-viewer.desktop;
    text/x-bibtex=texstudio.desktop;org.kde.kwrite.desktop;
    x-scheme-handler/mailto=exo-mail-reader.desktop
    text/x-matlab=org.kde.kwrite.desktop;org.gnome.gedit.desktop;
    application/x-shellscript=org.kde.kwrite.desktop;
    text/x-c++src=geany.desktop;
    text/x-chdr=geany.desktop;
    message/rfc822=thunderbird.desktop;
    application/x-compressed-tar=org.gnome.FileRoller.desktop;
    application/vnd.oasis.opendocument.spreadsheet=calc.desktop;
    application/zip=org.gnome.FileRoller.desktop;
    text/x-lua=org.kde.kwrite.desktop;
    application/vnd.openxmlformats-officedocument.wordprocessingml.document=writer.desktop;
    application/vnd.ms-powerpoint=impress.desktop;
    application/vnd.openxmlformats-officedocument.presentationml.presentation=impress.desktop;
    x-scheme-handler/http=exo-web-browser.desktop
    x-scheme-handler/https=exo-web-browser.desktop
    inode/directory=exo-file-manager.desktop
    x-scheme-handler/trash=exo-file-manager.desktop
    application/x-gnuplot=leafpad.desktop;
    
    [Default Applications]
    text/plain=kde4-okularApplication_txt.desktop
    text/x-c++src=geany.desktop
    text/x-chdr=geany.desktop
    x-scheme-handler/mailto=thunderbird.desktop
    message/rfc822=thunderbird.desktop
    application/pdf=evince.desktop
    text/x-bibtex=texstudio.desktop
    text/x-matlab=org.gnome.gedit.desktop
    text/x-tex=texstudio.desktop
    Although I got the that the order in the output of ktraderclient5 --mimetype text/html --short seems to be the problem, I can't really follow what we are doing right now. Further I don't understand what you where saying besides your request to give you the above output. Could you maybe give me a short explanation what the files we are looking at are and what the used tools are and do?

  8. #28

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by wolfi323 View Post
    And as this thread originally was about Leap 42.2:
    For Leap 42.2's Konqueror (which was still KDE4 based), you'd need to use "kcmshell4 filetypes", contained in kdebase4-runtime... (although, kcmshell5 should sync back the settings to KDE4 as well)
    Sorry, I meant to write okular of course (not Konqueror), but the rest still applies.

  9. #29

    Default Re: xfce Okular hyperlinks are not working

    Whops, I started kcmshell4 filetypes and changed the order of programs. It now works. THANK YOU VERY MUCH!

    I'm still a bit puzzled how to get to this solution by myself, so if you could still add a short explanation, I would be more than happy.

  10. #30

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by SUSEpasc View Post
    Here you go
    Hm, that looks fine.

    Although I got the that the order in the output of ktraderclient5 --mimetype text/html --short seems to be the problem, I can't really follow what we are doing right now.
    Ideally, we'd try to find out *why* KDE considers Rstudio to be the preferred application.

    The main goal is to fix it for you though, I suppose.

    As it apparently is triggered by having Rstudio installed, I may try to do that myself and see if I can reproduce your issue.
    (I don't have XFCE installed either, but I suppose this should be repoducable with other desktops too if it's a general problem)

    Further I don't understand what you where saying besides your request to give you the above output.
    You should be able to fix your problem by running "kcmshell5 filetypes" in a terminal window and changing the application order for the "text/html" file type.

    Could you maybe give me a short explanation what the files we are looking at are and what the used tools are and do?
    The mentioned file (mimeapps.list) defines the user configured default applications for certain file types.

    xdg-mime is a desktop agnostic tool (i.e. it tries to support all desktops) to handle that, the "query" option allows to find out what the settings are.

    ktraderclient5 is a similar tool from KDE, and reflects what the KDE libraries are thinking. xdg-mime should actually use that when run on a KDE Desktop I think, but you are using XFCE so it tries to adapt to that.

    The difference in the outputs (apart from the fact that KDE considers several applications for a certain file type, KDE's file managers offer an "Open With" right-click menu that contains all those) shows that the problem is more in KDE's settings or tools.
    I'd probably need to take a look at the source code though to see how KDE's libraries come to that conclusion that Rstudio is preferred...
    Last edited by wolfi323; 25-Sep-2017 at 01:15.

Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •