Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: xfce Okular hyperlinks are not working

  1. #1

    Default xfce Okular hyperlinks are not working

    Hey there,

    I got a small problem, namely when clicking on a hyperlink in a pdf in Okular the system starts R and shows me - what I believe is the - html code of the webpage. Does anyone know how to fix this issue?

    Thank you very much for your help!

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,762

    Default Re: xfce Okular hyperlinks are not working

    Desktop used??

    Sounds like a file extension mix up

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,275

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by gogalthorp View Post
    Desktop used??
    Xfce as mentioned in the thread title
    Henk van Velden

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by SUSEpasc View Post
    Hey there,

    I got a small problem, namely when clicking on a hyperlink in a pdf in Okular the system starts R and shows me - what I believe is the - html code of the webpage. Does anyone know how to fix this issue?

    Thank you very much for your help!
    Mine open in kWrite, which I also installed in Xfce, so basically the same problem.

    Use Document Viewer instead of Okular.

    You will find that under Menu=>Office

    ... never been that important, though. In Okular, I generally right click, copy link, then paste in Firefox.

    Another way is to use the application finder. Again, in Okular, Right-click, copy link, Alt-F3 and paste, hit Enter
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,578
    Blog Entries
    1

    Default Re: xfce Okular hyperlinks are not working

    Normally, for KDE applications, the default application (eg browser) can be set via
    SystemSettings > Personalisation > Applications, choose the preferred application for web browser eg firefox.

    or via

    Code:
    kcmshell5 componentchooser
    *supplied by the the kde-cli-tools5 package.

  6. #6
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by deano_ferrari View Post
    Normally, for KDE applications, the default application (eg browser) can be set via
    SystemSettings > Personalisation > Applications, choose the preferred application for web browser eg firefox.

    or via

    Code:
    kcmshell5 componentchooser
    *supplied by the the kde-cli-tools5 package.
    Yes, but neither of these are available in Xfce Desktop.

    Also, this happens (in Okular) even though html is set to launch in Firefox in the preferred applications and in mime.

    Other applications I use respect that setting, but Okular seems not to. And, that is the same problem the OP is having.

    Note that it works just fine in 42.3
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,578
    Blog Entries
    1

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by Fraser_Bell View Post
    Yes, but neither of these are available in Xfce Desktop.
    That's why I hinted at the 'kde-cli-tools5' package.

  8. #8
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by SUSEpasc View Post
    Does anyone know how to fix this issue?
    One easy fix would be to update to 42.3.

    I believe 42.2 EOL is in January, so you will have to do so by then, anyway.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,578
    Blog Entries
    1

    Default Re: xfce Okular hyperlinks are not working

    Sorry, managed to delete your post Fraser_Bell.

    Anyway, for KDE4 app...
    Code:
    kcmshell4 componentchooser
    Install the necessary first

  10. #10
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: xfce Okular hyperlinks are not working

    Quote Originally Posted by deano_ferrari View Post
    Sorry, managed to delete your post Fraser_Bell.

    Anyway, for KDE4 app...
    Code:
    kcmshell4 componentchooser
    Install the necessary first
    Heh,heh. Out of curiosity, how did you manage to do that?
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •