Results 1 to 7 of 7

Thread: Tumblweed only boots to tty1

  1. #1
    Join Date
    Feb 2011
    Location
    New York City
    Posts
    96

    Default Tumblweed only boots to tty1

    After an update a couple of days ago Tumbleweed only boots to the tty1 command prompt and not to the desktop as usual. I can start the desktop by issuing `startx', and it works fine (as far as I can tell), but I am booted as the graphical user. Ctrl+Alt+F7 takes me to a screen with a blinking cursor and nothing else Ctrl+Alt+F1 returns me to the desktop.

    This happens with kernel 4.13.1, 4.12.11, 4.12.9 and 4.11.8, so obviously not kernel related. It seems that something was updated incorrectly on my system since no one else is reporting this, but I have no idea what, or how to go about getting things to `go back to normal'.
    OpenSUSE Tumbleweed Plasma 5

  2. #2

    Default Re: Tumblweed only boots to tty1

    Please post the output of:
    Code:
    systemctl status display-manager
    (run as root)
    and
    Code:
    systemctl get-default
    Last edited by wolfi323; 19-Sep-2017 at 05:13.

  3. #3
    Join Date
    Feb 2011
    Location
    New York City
    Posts
    96

    Default Re: Tumblweed only boots to tty1

    Code:
     
    systemctl status display-manager
    yields

    Code:
    ● display-manager.service - X Display Manager
       Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled; vendor preset: enabled)
       Active: inactive (dead)
    and

    Code:
    systemctl get-default
    gives

    Code:
    multi-user.target
    OpenSUSE Tumbleweed Plasma 5

  4. #4

    Default Re: Tumblweed only boots to tty1

    Quote Originally Posted by Brouwer2 View Post
    Code:
     
    systemctl status display-manager
    yields

    Code:
    ● display-manager.service - X Display Manager
       Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled; vendor preset: enabled)
       Active: inactive (dead)
    The display-manager is not even started, because:
    Code:
    systemctl get-default
    gives

    Code:
    multi-user.target
    your system is confgured to boot to text mode.

    Switch the default boot target to "graphical.target" in YaST->System->Services Manager, or do it by running:
    Code:
    sudo systemctl set-default graphical

  5. #5
    Join Date
    Feb 2011
    Location
    New York City
    Posts
    96

    Default Re: Tumblweed only boots to tty1

    Thanks, that did it. That was much easier than I expected .

    Would re-installing grub2 from the rescue dvd have changed this setting? My root partition was full at one point and an update was interrupted and somehow grub got messed up. I'm just wondering since I did not change this setting, knowingly, or anything else that might have, so it might good to know if the likely explanation is something on my end, and not more general.

    Thanks again for your help.
    OpenSUSE Tumbleweed Plasma 5

  6. #6

    Default Re: Tumblweed only boots to tty1

    Quote Originally Posted by Brouwer2 View Post
    Would re-installing grub2 from the rescue dvd have changed this setting?
    No.
    This has nothing to do with grub2.

    Installing/updating some "broken" package *might* have changed it, but if it were a general problem there would have been other reports about it I suppose.

    The default is just a symlink though (/etc/systemd/system/default.target), so also filesystem problems may have removed/broken it somehow.
    But that's just guessing...
    Last edited by wolfi323; 19-Sep-2017 at 06:16.

  7. #7
    Join Date
    Feb 2011
    Location
    New York City
    Posts
    96

    Default Re: Tumblweed only boots to tty1

    Thanks, that's good to know. Probably it had something to do with the update not completing...

    Thanks again.
    OpenSUSE Tumbleweed Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •