Results 1 to 8 of 8

Thread: Delay Plasma 5 Software Updater

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Delay Plasma 5 Software Updater

    Whenever I boot Leap 42.3 the plasma 5 software updater tries to check for software updates before an internet connection (wifi) has been established. This results in an error message usually appearing just before a wifi connection is made.
    Is there a way to delay plasma from checking for updates by about 3 - 5 seconds that would allow an internet connection to be established and the error message avoided?
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  2. #2

    Default Re: Delay Plasma 5 Software Updater

    Quote Originally Posted by farcusnz View Post
    Is there a way to delay plasma from checking for updates by about 3 - 5 seconds that would allow an internet connection to be established and the error message avoided?
    No, unless you change the code (it is written in QML which is based on Javascript, so the code is interpreted on runtime and installed as plain text).

    But, what's the error message exactly?

    If you mean that it says "Network offline" if you hover the mouse over it, you can ignore that.
    That's because it doesn't actually check and therefore doesn't actually know the network status (because PackageKit is not even running). It should respect the settings, i.e. if configured to check daily, it will only check 24 hours after the last check, which is unlikely during login (unless the system is powered off for a day or more).

    You could of course also make the internet connection a "system connection" (i.e. enable "Allow all users to connect) and store the password system-wide, then the connection will already established during boot, before any user logs in.

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Delay Plasma 5 Software Updater

    Quote Originally Posted by wolfi323 View Post
    But, what's the error message exactly?
    Update Error
    Problem connecting to a software origin There was a (possibly temporary) problem connecting to a software origins.
    Please check the detailed error for further details
    bad grammar and punctuation quoted directly from error message


    You could of course also make the internet connection a "system connection" (i.e. enable "Allow all users to connect) and store the password system-wide, then the connection will already established during boot, before any user logs in.
    I've tried going in to network manager > configure network connections > connection > edit and setting the connection as "all users may connect to this network" ( I assume this is what you mean by system connection?) but I am prompted for the root password each time I log in to a user account before a connection can be made
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  4. #4

    Default Re: Delay Plasma 5 Software Updater

    Quote Originally Posted by farcusnz View Post
    I've tried going in to network manager > configure network connections > connection > edit and setting the connection as "all users may connect to this network" ( I assume this is what you mean by system connection?) but I am prompted for the root password each time I log in to a user account before a connection can be made
    That's a "bug" in NetworkManager that happens if the password for a system connection is stored in the user account (i.e. kwallet or gnome-keyring).

    As I wrote, you should also configure the password for the connection to be stored system-wide.

  5. #5

    Default Re: Delay Plasma 5 Software Updater

    Quite an old topic but this still happening in Leap 15.

    Basically every single time I turn on a laptop I got a popup with error, that particular repository is unreachable, because wifi just connects couple of seconds after that.
    Every single start of laptop therefore I need to dismiss that error message and it is really not fun already doing that for several months, even few years I would say, every single day.

    Really, any possibility for delayed start or some dependency in systemd onto NetworkManager?

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,182
    Blog Entries
    1

    Default Re: Delay Plasma 5 Software Updater

    Quote Originally Posted by leeon_lee View Post
    Quite an old topic but this still happening in Leap 15.

    Basically every single time I turn on a laptop I got a popup with error, that particular repository is unreachable, because wifi just connects couple of seconds after that.
    Every single start of laptop therefore I need to dismiss that error message and it is really not fun already doing that for several months, even few years I would say, every single day.

    Really, any possibility for delayed start or some dependency in systemd onto NetworkManager?
    Why not reconfigure your network connection as a system-wide connection so that it is up before login occurs. It's been explained in numerous threads already.
    openSUSE Leap 15.0; KDE Plasma 5

  7. #7
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Delay Plasma 5 Software Updater

    Quote Originally Posted by leeon_lee View Post
    Quite an old topic but this still happening in Leap 15.

    Basically every single time I turn on a laptop I got a popup with error, that particular repository is unreachable, because wifi just connects couple of seconds after that.
    Every single start of laptop therefore I need to dismiss that error message and it is really not fun already doing that for several months, even few years I would say, every single day.

    Really, any possibility for delayed start or some dependency in systemd onto NetworkManager?
    as Deano_Ferrari says . . . configure a system wide connection will solve the issue for you . . .
    Network manager configuration > General tab check "All users may connect to this network"
    Then under WiFi Security select "Store password for all users"
    But it would be good if the updater went looking for a network connection before trying to search for updates. :-)
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  8. #8
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    893

    Default Re: Delay Plasma 5 Software Updater

    Quote Originally Posted by farcusnz View Post
    Whenever I boot Leap 42.3 the plasma 5 software updater tries to check for software updates before an internet connection (wifi) has been established. This results in an error message usually appearing just before a wifi connection is made.
    Is there a way to delay plasma from checking for updates by about 3 - 5 seconds that would allow an internet connection to be established and the error message avoided?
    Code:
    erlangen:~ # systemctl status NetworkManager-wait-online.service
    ● NetworkManager-wait-online.service - Network Manager Wait Online
       Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; disabled; vendor preset: disabled)
       Active: inactive (dead)
         Docs: man:nm-online(1)
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •