Results 1 to 8 of 8

Thread: 11.4 python 2.7

  1. #1

    Default 11.4 python 2.7

    Hi. I have old 11.4 version. I cant upgrade it. I need to install git, perl5 and python 2.7. I cant find repos for that. Can anyone help with this please ?

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,188

    Default Re: 11.4 python 2.7

    Please show us the output of;
    Code:
    cat /etc/SuSE-release
    .: miuku @ #opensuse @ irc.libera.chat

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,841

    Default Re: 11.4 python 2.7

    Henk van Velden

  4. #4

    Default Re: 11.4 python 2.7

    SUSE Linux Enterprise Server 11 (i586)
    VERSION = 11
    PATCHLEVEL = 4

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,841

    Default Re: 11.4 python 2.7

    Forget my post above.

    As Miuku already assumed, you do not have openSUSE 11.4 at all! You have SLES 11.

    Thus you are at the wrong forums. Please go to: https://forums.suse.com/forum.php
    Henk van Velden

  6. #6

    Default Re: 11.4 python 2.7

    Code:
    sudo zypper in git
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: git-1.7.3.4-3.6.i586 requires git-core = 1.7.3.4, but this requirement cannot be provided
      uninstallable providers: git-core-1.7.3.4-3.6.i586[MAIN]
     Solution 1: Following actions will be done:
      deinstallation of libsnmp15-5.4.2.1-8.12.22.1.i586
      downgrade of perl-satsolver-0.44.5-0.5.194.i586 to perl-satsolver-0.16.1-4.7.1.i586
      deinstallation of subscription-tools-1.0-0.21.1.noarch
      downgrade of hplip-hpijs-3.11.10-0.6.11.1.i586 to hplip-hpijs-3.11.1-6.1.i586
      downgrade of satsolver-tools-0.17.9-0.5.2.i586 to satsolver-tools-0.16.1-4.7.1.i586
      downgrade of python-satsolver-0.44.5-0.5.194.i586 to python-satsolver-0.16.1-4.7.1.i586
      downgrade of libzypp-9.38.8-0.7.1.i586 to libzypp-8.12.1-3.3.i586
      downgrade of deltarpm-3.5.git-4.9.3.i586 to deltarpm-3.5.git-2.1.i586
      downgrade of yast2-qt-pkg-2.21.4-2.5.56.i586 to yast2-qt-pkg-2.20.3-3.1.i586
      downgrade of zypper-1.6.326-0.7.2.i586 to zypper-1.5.3-3.2.i586
      deinstallation of libpackagekit-glib10-0.3.14-2.30.11.i586
      downgrade of yast2-libyui-2.21.1-2.5.93.i586 to yast2-libyui-2.20.2-3.1.i586
      downgrade of yast2-qt-2.21.5-1.5.29.i586 to yast2-qt-2.20.4-1.2.1.i586
      downgrade of yast2-ycp-ui-bindings-2.21.1-2.5.107.i586 to yast2-ycp-ui-bindings-2.20.3-3.1.i586
     Solution 2: do not install git-1.7.3.4-3.6.i586
     Solution 3: break git-1.7.3.4-3.6.i586 by ignoring some of its dependencies

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,841

    Default Re: 11.4 python 2.7

    I have no idea what you mean with the above post.

    Not withstanding your name open_suse_user here, the system you are asking about is NOT an openSUSE system. And while there may be some readers here that by incident have some experience with SLES, most of us here have not and thus will not risk to give you advice based on their openSUSE knowledge. You really better go to the SLES/SLED forums.
    Henk van Velden

  8. #8
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,188

    Default Re: 11.4 python 2.7

    Like hcvv said, not many people here use SLE and you should seek help at the SUSE SLE forums.

    I can tell you in advance though that by upgrading the python on SLE is not a simple thing (it can break in a thousand ways) and if possible, you should acquire SLE12SP3 instead for your deployment.
    .: miuku @ #opensuse @ irc.libera.chat

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •