Results 1 to 2 of 2

Thread: Games don't work with recent Tumbleweed installation

  1. #1

    Default Games don't work with recent Tumbleweed installation

    Most of the games don't work with steam with recent Tumbleweed installation. I have an AMD card with Mesa 17.2.

    It seems that the main problem is related with ssl version. For example, running steam from shell, Hitman prints this message:
    Code:
    /home/vickop/.local/share/Steam/steamapps/common/Hitman™/bin/HitmanPro: error while loading shared libraries: libssl.so.37: cannot open shared object file: No such file or directory
    When I can solve the problems associated with this by adding symbolic links to all my directories /usr/lib/xxx, some games are crashing by segmentation fault and others work.

    F1 2015 it's printing:
    Code:
    error while loading shared libraries: libCoreFoundation.so.476: cannot open shared object file: No such file or directory
    I have noticed that if I start steam by telling it to look for its libraries in the game directory, I can get it started:
    Code:
    vickop@localhost:~> LD_LIBRARY_PATH=/home/vickop/.local/share/Steam/steamapps/common/F1\ 2015/lib/x86_64 steam
    It's very frustrating that when it seems that developers are finally making games for Linux, everything suddenly stops working, and it's impossible to make it work.

    Solutions? Go back to Ubuntu?

    Thank you guys

  2. #2
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    246

    Default Re: Games don't work with recent Tumbleweed installation

    In the first output, look for libssl.so.37 which belongs to Leap42.1 https://software.opensuse.org/package/libssl37
    Is the list of repositories right?
    I've tried installing it now on Thumbleweed and coming up to the account choice
    loyalty returns to those who practice it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •