Results 1 to 5 of 5

Thread: No connection to internet after suspending

  1. #1
    Join Date
    Oct 2009
    Location
    Berlin.
    Posts
    90

    Default No connection to internet after suspending

    HI
    I've updated my tumbleweed to the 20170908 version and now every time when I resume my laptop after suspending it. I got no connection to the my wireless network.
    I get the list of wireless networks available, thus the wireless card is working. But when I hit "connect" nothing happens. So I have to reboot my laptop to get connected.

    Before the update there was no problem.

    ifconfig
    Code:
    enp0s31f6: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether fc:3f:db:b5:e2:43  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
            device interrupt 16  memory 0xe4400000-e4420000  
    
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1000  (Local Loopback)
            RX packets 682  bytes 50992 (49.7 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 682  bytes 50992 (49.7 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 192.168.178.73  netmask 255.255.255.0  broadcast 192.168.178.255
            inet6 fe80::38b7:6d9c:5d94:6d84  prefixlen 64  scopeid 0x20<link>
            ether a4:34:d9:5b:17:74  txqueuelen 1000  (Ethernet)
            RX packets 18229  bytes 14566275 (13.8 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 16200  bytes 2720811 (2.5 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    iwconfig
    Code:
    lo        no wireless extensions.                                                
                                                                                     
    enp0s31f6  no wireless extensions.                                               
    
    wlp2s0    IEEE 802.11  ESSID:"FRITZ!Box 7362 SL"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 34:81:C4:CE:FF:42   
              Bit Rate=144.4 Mb/s   Tx-Power=22 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:on
              Link Quality=62/70  Signal level=-48 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:4  Invalid misc:79   Missed beacon:0
    System:
    Code:
    OS Tumbleweed 20170908 
    Desktop KDE 5.10.5
    linux-bm5k 4.12.11-1-default #1 x86_64 x86_64 x86_64 GNU/Linux

  2. #2
    Join Date
    Oct 2009
    Location
    Berlin.
    Posts
    90

    Default Re: No connection to internet after suspending

    After resuming I get this with iwconfig and ifconfig

    Code:
    iwconfig
    
    lo        no wireless extensions.
    
    enp0s31f6  no wireless extensions.
    
    wlp2s0    IEEE 802.11  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=22 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:on
              
    ifconfig
    enp0s31f6: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether fc:3f:db:b5:e2:43  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
            device interrupt 16  memory 0xe4400000-e4420000  
    
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1000  (Local Loopback)
            RX packets 706  bytes 52192 (50.9 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 706  bytes 52192 (50.9 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    wlp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether b2:07:3f:e1:d4:5b  txqueuelen 1000  (Ethernet)
            RX packets 27321  bytes 22267433 (21.2 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 23493  bytes 3828467 (3.6 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,102
    Blog Entries
    1

    Default Re: No connection to internet after suspending

    HI
    I've updated my tumbleweed to the 20170908 version and now every time when I resume my laptop after suspending it. I got no connection to the my wireless network.
    I get the list of wireless networks available, thus the wireless card is working. But when I hit "connect" nothing happens. So I have to reboot my laptop to get connected.
    Are you using NetworkManager to manage your network connection? Rebooting is a bit extreme! What happens if you simply restart the network?
    Code:
    sudo systemctl restart network
    If using NetworkManager, you can also do
    Code:
    sudo systemctl restart NetworkManager

  4. #4
    Join Date
    Oct 2009
    Location
    Berlin.
    Posts
    90

    Default Re: No connection to internet after suspending

    Yes, I'm using NetworkManager.

    Thank you, with
    Code:
    sudo systemctl restart NetworkManager
    indeed I restart my network and it works properly without rebooting the OS.

    I'm getting however the following crash of kdeint5 immediately after restarting the NetworkManager:

    Code:
    kdeninit5 PID:2138 Signal: Segmentation fault (11)

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,102
    Blog Entries
    1

    Default Re: No connection to internet after suspending

    Quote Originally Posted by drnn1076 View Post
    Yes, I'm using NetworkManager.

    Thank you, with
    Code:
    sudo systemctl restart NetworkManager
    indeed I restart my network and it works properly without rebooting the OS.
    Good - as expected.

    I'm getting however the following crash of kdeint5 immediately after restarting the NetworkManager:

    Code:
    kdeninit5 PID:2138 Signal: Segmentation fault (11)
    This might need a bug report to resolve.

    https://en.opensuse.org/openSUSE:Submitting_bug_reports
    https://bugzilla.opensuse.org/enter_...&format=guided

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •