Results 1 to 10 of 10

Thread: [Konsole] Question marks in the place of the accents on filename

  1. #1
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    381

    Default [Konsole] Question marks in the place of the accents on filename

    Greetings !!

    I did the error to upgrade three of my computers with LEAP 42.2.

    + All accents are replaced by '?' questionmarks...

    http://paste.opensuse.org/33284592

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,439

    Default Re: [Konsole] Question marks in the place of the accents on filename

    That is because you have two different encodings on the same system. Do you know what the encoding was of your earlier set up?

  3. #3

    Default Re: [Konsole] Question marks in the place of the accents on filename

    @soundlord: an addition to john_hudson's post:

    1) Perhaps the glibc-locale rpm is missing.

    2) A side-note: I noticed a questionmark in the location mentioned in your posting (Location: Li�ge Walifornia).
    I am viewing this in Firefox 55.0.3, and have my encoding set to Unicode (Menubar > View > Text Encoding > Unicode).
    That questionmark is probably an 'è' (e with an grave accent), but entered with a different encoding (CP1252?).

    Cheers,
    Leen

  4. #4

    Default Re: [Konsole] Question marks in the place of the accents on filename

    And what output do you get when you run the command "locale" in konsole?

    A wrong/invalid locale would be a likely reason for your problem, as the fallback is "C" without UTF-8.

    See also this recent thread:
    https://forums.opensuse.org/showthre...o-I-set-locale
    Last edited by wolfi323; 16-Sep-2017 at 06:35.

  5. #5
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    381

    Default Re: [Konsole] Question marks in the place of the accents on filename

    Yep, I spent 3 dayz to try to make the network working here... since LEAP 42.2 has appeared here nothing seems to be like before ^^

    Concerning the locale, I looked the locale on computers where it works as expected and tried to modify /etc/sysconfig/language and yast2//etc/sysconfig editor -> environment -> Language with same settings... without success

    Normally the previous settings where english as main language (I can not bear the french translations ^^) and the utf8 setting is fr_BE.UTF-8.

    It works on a 13.2 opensuse and 42.2 opensuse, but on THIS computer with 42.2 it doesn't work.

    http://paste.opensuse.org/75308956

    I got in this computer that works (better ^^):

    Code:
    sirius:/ # locale
    LANG=POSIX
    LC_CTYPE=fr_BE.UTF-8
    LC_NUMERIC="POSIX"
    LC_TIME="POSIX"
    LC_COLLATE="POSIX"
    LC_MONETARY="POSIX"
    LC_MESSAGES="POSIX"
    LC_PAPER="POSIX"
    LC_NAME="POSIX"
    LC_ADDRESS="POSIX"
    LC_TELEPHONE="POSIX"
    LC_MEASUREMENT="POSIX"
    LC_IDENTIFICATION="POSIX"
    LC_ALL=

  6. #6
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    381

    Default Re: [Konsole] Question marks in the place of the accents on filename

    Original situation: considering that the Konsole view settings are UTF8 and the Profile is set to utf8

    http://paste.opensuse.org/51491705

  7. #7
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    381

    Default Re: [Konsole] Question marks in the place of the accents on filename

    glibc-locale is installed...

    http://paste.opensuse.org/11654574

  8. #8
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    381

    Default Re: [Konsole] Question marks in the place of the accents on filename

    2) A side-note: I noticed a questionmark in the location mentioned in your posting (Location: Li�ge Walifornia).
    I am viewing this in Firefox 55.0.3, and have my encoding set to Unicode (Menubar > View > Text Encoding > Unicode).
    That questionmark is probably an 'è' (e with an grave accent), but entered with a different encoding (CP1252?).
    Yep I did set my profile under Windows when Linux was dead... I jumped here to get help ^^
    I never changed it untill today ^^

  9. #9

    Default Re: [Konsole] Question marks in the place of the accents on filename

    Quote Originally Posted by soundlord View Post
    Concerning the locale, I looked the locale on computers where it works as expected and tried to modify /etc/sysconfig/language and yast2//etc/sysconfig editor -> environment -> Language with same settings... without success
    And what exactly did you change it to?

    Also note that the desktop's settings override this on login.

    Code:
    sirius:/ # locale
    LANG=POSIX
    Did you run this as user or as root?
    As everything (except LC_CTYPE) is set to POSIX, it was rather as root.

    We need the logged in *user*'s settings though.
    Last edited by wolfi323; 18-Sep-2017 at 04:40.

  10. #10
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    381

    Default Re: [Konsole] Question marks in the place of the accents on filename

    solved: I set "yes" to the box named "local parameters for root user", kept the checkbox enabled for utf-8 encoding and set fr_BE in the detailed locals in the popup menu.

    All that done in the language feature item in Yast2.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •