Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Laptop cam is not working anymore

  1. #1
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Laptop cam is not working anymore

    lsusb -vHi guys,

    "Cheese" is showing me this message: "No devices found".

    I already tried to reinstall it and also some packages, but nothing work.

    Some useful information:

    HTML Code:
    viniciusbr@linux-9urx:~> cheeseGtk-Message: Failed to load module "unity-gtk-module"Gtk-Message: Failed to load module "unity-gtk-module"
    (cheese:30038): Gtk-WARNING **: Theme parsing error: cheese.css:7:35: The style property GtkScrollbar:min-slider-length is deprecated and shouldn't be used anymore. It will be removed in a future version** Message: cheese-application.vala:211: Error during camera setup: Nenhum dispositivo localizado
    
    (cheese:30038): cheese-CRITICAL **: cheese_camera_device_get_name: assertion 'CHEESE_IS_CAMERA_DEVICE (device)' failed
    (cheese:30038): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
    (cheese:30038): GLib-GIO-CRITICAL **: g_settings_schema_key_type_check: assertion 'value != NULL' failed
    (cheese:30038): GLib-CRITICAL **: g_variant_get_type_string: assertion 'value != NULL' failed
    (cheese:30038): GLib-GIO-CRITICAL **: g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given
    ** (cheese:30038): CRITICAL **: cheese_preferences_dialog_setup_resolutions_for_device: assertion 'device != NULL' failed
    And the lsusb -v is here: http://susepaste.org/6813498 and sudo lspci -k here http://susepaste.org/59698474
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,188
    Blog Entries
    1

    Default Re: Laptop cam is not working anymore

    The webcam device is reported in the lsusb output
    Code:
    Bus 001 Device 004: ID 13d3:5165 IMC Networks
    Let's see if a driver is loaded...
    Code:
    usb-devices|awk '/13d3/' RS="\n\n"
    and a device node exists....
    Code:
    ls -l /dev/video*

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,188
    Blog Entries
    1

    Default Re: Laptop cam is not working anymore

    It does look like your problem is with the application/supporting libraries though. Where did you install that application from?

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: Laptop cam is not working anymore

    Quote Originally Posted by deano_ferrari View Post
    The webcam device is reported in the lsusb output
    Code:
    Bus 001 Device 004: ID 13d3:5165 IMC Networks
    I recall an old thread on this make of webcam: https://forums.opensuse.org/showthre...-openSuse-13-1 where my old research suggested the webcam is UVC compatible.

    I'm not up to date wrt support apps needed, but back in the openSUSE-13.1 days various v4l libraries were needed for webcam functionality.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: Laptop cam is not working anymore

    I also read a post where this error message:
    Code:
    g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given
    was because a user had the webcam switched off in BIOS. That may not be the cause here, but its likely worth checking.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,188
    Blog Entries
    1

    Default Re: Laptop cam is not working anymore

    Quote Originally Posted by oldcpu View Post
    I also read a post where this error message:
    Code:
    g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given
    was because a user had the webcam switched off in BIOS. That may not be the cause here, but its likely worth checking.
    Yes, agreed....and perhaps making sure that firmware is loaded (if applicable).

  7. #7
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: Laptop cam is not working anymore

    Quote Originally Posted by deano_ferrari View Post
    The webcam device is reported in the lsusb output
    Code:
    Bus 001 Device 004: ID 13d3:5165 IMC Networks
    Let's see if a driver is loaded...
    Code:
    usb-devices|awk '/13d3/' RS="\n\n"
    and a device node exists....
    Code:
    ls -l /dev/video*
    Code:
    viniciusbr@linux-9urx:~> usb-devices|awk '/13d3/' RS="\n\n"T:  Bus=01 Lev=02 Prnt=02 Port=02 Cnt=02 Dev#=  4 Spd=480 MxCh= 0
    D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1
    P:  Vendor=13d3 ProdID=5165 Rev=08.23
    S:  Manufacturer=Azurewave
    S:  Product=USB Camera
    S:  SerialNumber=NULL
    C:  #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
    I:  If#= 0 Alt= 0 #EPs= 1 Cls=0e(video) Sub=01 Prot=00 Driver=uvcvideo
    I:  If#= 1 Alt= 0 #EPs= 0 Cls=0e(video) Sub=02 Prot=00 Driver=uvcvideo
    Code:
    viniciusbr@linux-9urx:~> ls -l /dev/video*
    crw-rw----+ 1 root video 81, 0 Set 15 10:00 /dev/video0
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  8. #8
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: Laptop cam is not working anymore

    Quote Originally Posted by deano_ferrari View Post
    Yes, agreed....and perhaps making sure that firmware is loaded (if applicable).
    I looked in the bios but something seems to be OK (despite I don't know exactly were can I find information about the cam).
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  9. #9
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: Laptop cam is not working anymore

    Quote Originally Posted by deano_ferrari View Post
    It does look like your problem is with the application/supporting libraries though. Where did you install that application from?
    Direct from the official repos.
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: Laptop cam is not working anymore

    I have read of users with the 13d3:5165 webcam complaining they could not get it to work under GNU/Linux. I've also read of others succeeding if they also use v4l apps to assist. Have you tried investigating if v4l apps may help ? I can't provide any more specific advice, as my laptop will run cheese without v4l - but then it is a different make of webcam.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •