Immediately after booting up I went to YaST/Users and Groups.... It went through all the checks and then aborted. I then went to VT and typed sudo tail -f /var/log/YaST2/y2log and here is the result:

2017-09-13 09:59:09 <1> localhost(2466) [Perl] modules/UsersPlugins.pm(UsersPlugins::Read):66 Available plugin: UsersPluginLDAPShadowAccount
2017-09-13 09:59:09 <1> localhost(2466) [Perl] modules/UsersPlugins.pm(UsersPlugins::Read):66 Available plugin: UsersPluginQuota
2017-09-13 09:59:10 <2> localhost(2466) [Ruby] yast/builtins.rb:586 tostring builtin called on wrong type Class
2017-09-13 09:59:10 <3> localhost(2466) [Ruby] modules/Sequencer.rb:265 sequencer: Returned value not symbol: #<Class:0x92cfc64>
2017-09-13 09:59:10 <3> localhost(2466) [Ruby] modules/Sequencer.rb:337 sequencer: Invalid ret: nil
2017-09-13 09:59:10 <1> localhost(2466) [Ruby] clients/users.rb:347 Users module finished with false
2017-09-13 09:59:10 <1> localhost(2466) [Ruby] clients/users.rb:348 ----------------------------------------
2017-09-13 09:59:10 <1> localhost(2466) [Interpreter] bin/y2start:56 Called YaST client returned.
2017-09-13 09:59:10 <1> localhost(2466) [Y2Ruby] binary/YRuby.cc(~YRuby):117 Shutting down ruby interpreter.
2017-09-13 09:59:10 <1> localhost(2466) [Y2Perl] YPerl.cc(destroy):164 Shutting down embedded Perl interpreter.

I followed this with yast in VT and again tried to create a new user but it aborted . I then repeated the tail... command and here is the output:

2017-09-13 10:04:19 <1> localhost(5229) [Y2Ruby] binary/YRuby.cc(~YRuby):117 Shutting down ruby interpreter.
2017-09-13 10:04:19 <1> localhost(5229) [Y2Perl] YPerl.cc(destroy):164 Shutting down embedded Perl interpreter.
2017-09-13 10:04:22 <1> localhost(4695) [ncurses] NCurses.cc(RedirectToLog):565 isatty(stderr)yes
2017-09-13 10:04:22 <1> localhost(4695) [ncurses] NCurses.cc(RedirectToLog):574 isatty(stdout)yes
2017-09-13 10:04:22 <1> localhost(4695) [Ruby] clients/menu.rb:303 Got 0 from /sbin/yast users >&2
2017-09-13 10:04:37 <1> localhost(4695) [Interpreter] bin/y2start:56 Called YaST client returned.
2017-09-13 10:04:37 <1> localhost(4695) [ncurses] YNCursesUI.cc(~YNCursesUI):113 Stop YNCursesUI
2017-09-13 10:04:37 <1> localhost(4695) [ncurses] NCurses.cc(~NCurses):145 Shutdown NCurses...
2017-09-13 10:04:37 <1> localhost(4695) [ncurses] NCurses.cc(~NCurses):164 NCurses down
2017-09-13 10:04:37 <1> localhost(4695) [Y2Ruby] binary/YRuby.cc(~YRuby):117 Shutting down ruby interpreter.

All the other YaST functions seem to work. Help would be appreciated,