Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

  1. #1
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Exclamation Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

    Hello. I've been on the verge of writing this post for the past couple of months, but kept holding off in the hope that "it'll be alright, surely the next TW zypper dup will fix it"... but it never has.

    Native Plasma5 pgms like KInfoCentre, KSysGuard, Dolphin... are not affected by this problem. Certain other pgms are affected, eg, Thunderbird, KMyMoney, LibreOffice... I use these pgms every day, & so the problem is constantly "in my face" & thus very irritating.

    The problem is that these various pgms' vertical & horizontal scrollbars, for the past couple of months, have lost their arrows at both ends of the bars, despite the Settings still showing these as being selected & thus supposedly active. As such, nowadays in all the affected pgms i can only scroll by grabbing the scrollbar with the mouse pointer & dragging it in the desired direction. No longer can i scroll simply by clicking on the arrows, as they no longer exist.

    I first began using TW in May this year, & back then this problem did not exist. I have TW KDE on both my Tower & Lappy, & both now exhibit this problem [for months]. In Tower i also have multiple TW VMs [so i can do various tests / experiments without endangering my real TW]. These various TW VMs are all at various different snapshot dates, & so today i have been able to discover that the TW 20170701 snapshot [Plasma 5.10.2] was GOOD, but by the time of the 20170725 snapshot [Plasma 5.10.4] the problem already had begun. All snapshots after that, including up to at least 20170904 [Tower, Plasma 5.10.5] & 20170909 [Lappy, Plasma 5.10.5], have continued to have this problem.

    I also have a Leap KDE 42.3 VM, & it does not have this problem. Of course, its Plasma version is much older, so that's not necessarily a surprise.

    The fault seems not to be caused by the specific pgms themselves. I proved this by, in the 20170701 snapshot VM, firstly checking that LibreOffice & KMyMoney scrollbars were good [re arrows], then i manually updated both those pgms with zypper up to the current versions... the scrollbars are still good [arrows still present].

    Here's pics from the 20170701 snapshot; KMyMoney [1st & 2nd] & LibreOffice Writer [3rd]:



    Here's the corresponding pics from Tower's real 20170904 snapshot:

    Oh, there's a limit of 4 pics per post, so i'll put these final two in a separate post.

    I use identical settings in all these installations, as follows:
    1. Workspace Theme
    • Look & Feel = openSUSE
    • Desktop Theme = Oxygen

    2. Icons
    • Theme = Oxygen

    3. Application Style

    • Widget Style = Oxygen
    • Window Decorations = Plastik
    • GNOME Application Style [GTK]
      • GTK2 Theme = oxygen-gtk
      • GTK3 Theme = Emacs



    Do other people also experience this problem? Does anyone have any solutions please [note, the problem persists with non-Oxygen themes, but i dislike all those aesthetically, so this would not be an acceptable solution even if they did work]?

  2. #2
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

    The 2nd KMM pic, & then the LO pic, from Tower's 20170904 TW:


  3. #3

    Default AW: Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

    The scrollbar arrows have been disabled by default in the Breeze widget style a while ago, in 5.10.0 IIRC.

    You can configure the scrollbar arrows in KDE's settings though:
    Application Appearance->Widget Style, click on the "Configure..." button and switch to the "Scrollbars" tab.

    The "Oxygen" style hasn't been changed (it's configurable there as well), but in your screenshots without scrollbar arrows you are clearly using "Breeze" (not "Oxygen" as you write).

    Thunderbird is a GTK application though, and uses the GTK settings. And for GTK, this is *not* configurable... You need to use a theme that has the arrows, e.g. oxygen-gtk (only available for GTK2 though, because GTK3 removed support for such theming engines).

  4. #4

    Default Re: Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

    PS, for clarification:
    Quote Originally Posted by GooeyGirl View Post
    I use identical settings in all these installations, as follows:
    1. Workspace Theme
    • Look & Feel = openSUSE
    • Desktop Theme = Oxygen

    2. Icons
    • Theme = Oxygen

    3. Application Style

    • Widget Style = Oxygen
    • Window Decorations = Plastik
    • GNOME Application Style [GTK]
      • GTK2 Theme = oxygen-gtk
      • GTK3 Theme = Emacs

    In your screenshots without arrows, you definitely do *not* use these settings, it's rather Breeze as icon theme and widget style (the desktop theme is not visible in your screenshots... ).
    These settings should give you arrows by default.
    Last edited by wolfi323; 13-Sep-2017 at 03:40.

  5. #5
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

    I DO NOT use Breeze. I stated that explicitly. I listed my settings very carefully, based on actually being in each respective part of System Settings [to visually confirm they were still selected]. Given you seem to think i am either dishonest or delusional, here now are the actual pics from my System Settings:










    Three more coming, in next post.

  6. #6
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.








    If, as you confidently assert, all my TW installations since 20170725 are truly using Breeze, then i hope you will agree from my supplied pics that i have done all i can to NOT have that happen. That's why i made this post ... there is a problem.

  7. #7

    Default Re: Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

    Quote Originally Posted by GooeyGirl View Post
    I DO NOT use Breeze. I stated that explicitly.
    Yes, you stated that.
    But your previous screenshots DO SHOW Breeze.

    Given you seem to think i am either dishonest or delusional
    I was not thinking that at all.

    There is a discrepancy between the settings you listed and what the screenshots showed though, whatever the reason is.

    One I thing I imagined was that you maybe changed the look&feel setting, which will reset all the other individual settings (widget style, icon theme, ...).

    here now are the actual pics from my System Settings:
    These do look like Oxygen, and the scrollbars should have arrows, don't they?
    You nicely cut them off so that it's not visible...

    Maybe try changing the settings and change them back.
    I notice that the applications you showed before are based on kdelibs4, while systemsettings5 is KF5 based, that may explain the discrepancy.
    I.e. the KDE4 settings might be wrong and configured to use Breeze.
    Last edited by wolfi323; 13-Sep-2017 at 04:23.

  8. #8

    Default Re: Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

    PS, to be explicit:
    Quote Originally Posted by wolfi323 View Post
    Maybe try changing the settings and change them back.
    I notice that the applications you showed before are based on kdelibs4, while systemsettings5 is KF5 based, that may explain the discrepancy.
    I.e. the KDE4 settings might be wrong and configured to use Breeze.
    Change the widget style to "Breeze", click Apply, then change it back to "Oxygen" and click Apply again.
    That should sync back the setting to KDE4 and hopefully fix your problem.

  9. #9

    Default Re: Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

    Also check that the package kdebase4-workspace-liboxygenstyle is installed.
    That contains the KDE4 Oxygen widget style.
    If that's not installed, KDE4 applications obviously cannot use it and will fall back to Breeze.

  10. #10
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

    Thanks.

    Change the widget style to "Breeze", click Apply, then change it back to "Oxygen" and click Apply again.
    That should sync back the setting to KDE4 and hopefully fix your problem.
    It did not help... but i'm not giving up yet, heehee. It's late here now so i shall resume this challenge tomorrow. Then, i plan to repeat that step you gave, but, also then logout/in, then launch KMM, TB & LO again to see. If they are still no good then, i was wondering about maybe something drastic like removing ALL "oxygen" components with YaST2, rebooting, reinstalling them, reselecting them in System Settings, then crossing my fingers...

    BTW, in parallel with all the posts here, i cloned that "good" 20170701 VM, then in the clone i ran "zypper dup --no-allow-vendor-change". Once that VM was rebooted, & is now 20170909, it continues to be good. That marks it as starkly different to my Tower AND Lappy's "real" TWs, AND all but one of my TW VMs. Ie, of ~8 TW installations here, currently only ONE of them is correctly showing the scrollbar arrows, despite them all using the same System Settings.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •