Results 1 to 8 of 8

Thread: Cannot upgrade openSUSE 12.1 to openSUSE Leap 42.3

  1. #1

    Default Cannot upgrade openSUSE 12.1 to openSUSE Leap 42.3

    The openSUSE Leap 42.3 download web page says "If you’re already running openSUSE you can upgrade by booting from the DVD/USB"

    I am trying to upgrade openSUSE 12.1 with Installation Media - Intel 64-bit (x86_64) iso downloaded from the Leap 42.3 web page. and I get the following message:

    The installed product (openSUSE 12.1) is not compatible with the product on the installation media (openSUSE Leap 42.3).

    ** While it says "Installation Media - Intel 64-bit (x86_64)" doesn't x86 suggest it has a 32bit installer as well as 64bit, or is that only in the Windows world?

    ** Is this my problem because of a 32bit installed version?


    ** What do I need to do to upgrade to openSUSE Leap 42.3?

    I really don't want to start from scratch if I can help it

    Installed OS details:


    host:~ # uname -m
    i686


    host:~ # uname -a
    Linux host 3.1.10-1.29-desktop #1 SMP PREEMPT Fri May 31 20:10:04 UTC 2013 (2529847) i686 i686 i386 GNU/Linux

    host:~ # cat /etc/SuSE-release
    openSUSE 12.1 (i586)
    VERSION = 12.1
    CODENAME = Asparagus

    host:~ # cat /etc/os-release
    NAME=openSUSE
    VERSION = 12.1 (Asparagus)
    VERSION_ID="12.1"
    PRETTY_NAME="openSUSE 12.1 (Asparagus) (i586)"
    ID=opensuse



    CPU installed:
    Intel Celeron E3400 / 2.6 GHz processor
    Number of Cores Dual-Core
    Processor Number E3400
    64-bit Computing Yes
    Compatible Processor Socket LGA775 Socket

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Cannot upgrade openSUSE 12.1 to openSUSE Leap 42.3

    too many questions sorry if I miss an awnser
    LEAP is based on SLE and that distribution is 64bit only so no 32bit for LEAP
    although it might be possible to do an upgrade from 12.1 I'm not sure how reliable the upgrade would be 12.1 is just too old the recommended upgrade cyle is to do an upgrade to the next version ie 12.1->12.2....->42.3 but that would be a bad joke, while you might be able to jump a few releases ie 12.1->12.3 I doubt that a jump to 42.3 would work especially the different architectures x86 and x64
    you may not want to start from scratch but plasma 5 is completely different from kde4 and gnome that comes with 42.3 is incompatible with what came with 12.1 so you can't really use your old settings files
    you could and should leave your old home partition you might have an issue with your old user account as I've never used an old account on a new setup but you can use a different name and just copy your old files

  3. #3

    Default Re: Cannot upgrade openSUSE 12.1 to openSUSE Leap 42.3

    Quote Originally Posted by graham_parker View Post
    The openSUSE Leap 42.3 download web page says "If you’re already running openSUSE you can upgrade by booting from the DVD/USB"

    I am trying to upgrade openSUSE 12.1 with Installation Media - Intel 64-bit (x86_64) iso downloaded from the Leap 42.3 web page. and I get the following message:
    The installed product (openSUSE 12.1) is not compatible with the product on the installation media (openSUSE Leap 42.3).
    Well, as the message tries to say, upgrades from 12.1 to 42.3 are not supported/possible.
    The jump is too big.

    Isn't there an option to ignore that though? (but you may run into problems later anyway...)

    Better do incremental upgrades instead (12.1->12.2->12.3->13.1->13.2->42.1->42.2->42.3).
    You may try to skip one version or the other in between, in particular there should be no problems going from 13.2 to 42.3 directly.
    Especially in earlier versions, only upgrades from one to the next were supported/tested though.

    Or (maybe better) do a fresh installation instead of an upgrade.
    By default, /home is on a separate partition and will be reused, so you shouldn't loose your personal data/application settings.

    ** While it says [/COLOR][COLOR=#006400]"Installation Media - Intel 64-bit (x86_64)" doesn't x86 suggest it has a 32bit installer as well as 64bit, or is that only in the Windows world?
    x86 means 32bit, yes, but note that it says x86_64 which means 64bit.

    And Leap is *only* available for 64bit (since 42.1), mainly because its base SLE12 is also 64bit only. openSUSE 13.2 was the last 32bit version, though Tumbleweed (the rolling distribution) is still available in 32bit too.


    ** Is this my problem because of a 32bit installed version?
    No, that shouldn't matter if you boot from the installation DVD. It would just switch to 64bit.

  4. #4

    Default Re: Cannot upgrade openSUSE 12.1 to openSUSE Leap 42.3

    PS: forgot to mention that you can still download the older versions (12.x, 13.x) from here:
    http://ftp5.gwdg.de/pub/opensuse/dis.../distribution/
    (the installation DVDs are in the "iso" subfolders)

    If you are willing to take a risk, paths like this would maybe work:
    12.1->12.3->13.2->42.3
    or maybe even 12.1->13.2->42.3
    No guarantees though!
    (but if things go wrong, you can always do a fresh installation anyway...)
    Last edited by wolfi323; 13-Sep-2017 at 03:13.

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Cannot upgrade openSUSE 12.1 to openSUSE Leap 42.3

    my 2¢
    there has been way too much change between 12.1 and 42.3 and very little to gain by doing an upgrade, as wolfi323 said the recommended way is to upgrade release by release but doing 8 sequential upgrades is way too much work and bandwidth
    if you have an install media and are willing to play around you could try and install 42.3 directly worst case scenario your system won't boot and you'll have to do a clean install
    but I believe there is a real probability the upgrade would be semi successful bast case scenario you'll have a few old 12.1 packages installed but as those will be 32bit they shouldn't interfere with LEAP and you could remove them after the upgrade just remove all 3rd party repo's and drivers (nvidia or ati) before doing the upgrade as an old nvidia or ati kernel module might prevent a successful boot
    as I said there is nothing really to gain with an upgrade you'll still need to configure kde or gnome to your liking

  6. #6

    Default Re: Cannot upgrade openSUSE 12.1 to openSUSE Leap 42.3

    Thank you everyone for your thoughts and comments, really appreciated.

    I have my system is also configured with LVM across 2 x 1TB HDDs so was hoping not to have to disturb this, but maybe risky doing an upgrade in 1 jump.

    All the feedback gives me something to think about now at least, and will help decide on a way forward.

    Cheers All,
    Graham.

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Cannot upgrade openSUSE 12.1 to openSUSE Leap 42.3

    well I've never used a LVM but you should be able to reuse your partitioning
    https://doc.opensuse.org/documentati...st2.system.lvm
    if you do a clean install do not accept the partitioning setup but chose custom disk partition then select reread partitions and go on from there

  8. #8

    Default Re: Cannot upgrade openSUSE 12.1 to openSUSE Leap 42.3

    Quote Originally Posted by I_A View Post
    well I've never used a LVM but you should be able to reuse your partitioning
    https://doc.opensuse.org/documentati...st2.system.lvm
    if you do a clean install do not accept the partitioning setup but chose custom disk partition then select reread partitions and go on from there
    Thanks Shaman, I thinks that's the road I will take, just backing up data first. Cheers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •