Results 1 to 7 of 7

Thread: freerdp crash when remote desktop produces sound

  1. #1
    Join Date
    May 2015
    Location
    Italy
    Posts
    379

    Default freerdp crash when remote desktop produces sound

    Hi, yesterday freerdp was updated to v2.0.0~rc0-1.1. Since then, whenever the remote desktop produces a sound, freerdp crashes.
    Does anybody else experience this?
    Should I report it upstream?

    TIA
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  2. #2
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    428

    Default Re: freerdp crash when remote desktop produces sound

    Could you post your cli options? At least the ones for sound?

    Hendrik

  3. #3
    Join Date
    May 2015
    Location
    Italy
    Posts
    379

    Default Re: freerdp crash when remote desktop produces sound

    Hi Hendrik!

    Quote Originally Posted by hendwolt View Post
    Could you post your cli options? At least the ones for sound?

    Hendrik
    I'm not really using any cli options, because I'm using freerdp through KRDC.
    In KRDC I have configured sound to play through the local PC, using ALSA.

    However, after posting my first message I noticed that today Tumbleweed failed to detect my sound hardware, so it behaves as if I have no sound output devices. Maybe that's the problem (although I believe this should not crash freerdp anyway).

    As soon as I can reboot I'll see if this is just a transient problem or something related to an updated kernel (I'm on 4.12.11-1-default). Provided my next boot will recognize my sound hardware, I'll see if the freerdp problem is due to the missing output device and I will report back.

    Thank you!
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  4. #4
    Join Date
    May 2015
    Location
    Italy
    Posts
    379

    Default Re: freerdp crash when remote desktop produces sound

    A second after replying it dawned on me that I could use ps to see the cli options.
    So here it is, FWIW:
    Code:
    xfreerdp -decorations /w:1874 /h:1016 /kbd:0x00000410 /d:d1 /u:AMENDED /parent-window:6298939 /bpp:24 /audio-mode:0 /sound:sys:alsa /drive:media /home/cristiano /network:lan /rfx /cert-ignore +clipboard /port:3389 /v:AMENDED /p:***************
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  5. #5
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    428

    Default Re: freerdp crash when remote desktop produces sound

    I tried to reproduce your issue, but I was not "successful". That means, on my system freerdp does not crash. I use the cli version. Maybe you could test this, event though I don't think, that it makes a difference.
    If you want to file a bug report, I suggest, to file an openSUSE bug first. AFAIR there was a packaging issue with 2.0.0-RC0.

    Hendrik

  6. #6
    Join Date
    May 2015
    Location
    Italy
    Posts
    379

    Default Re: freerdp crash when remote desktop produces sound

    OK, now I'm sure I have a problem with sound.
    Hardware is detected correctly, but pulseaudio daemon does not start.

    I have the log full of lines like these:
    Code:
    set 14 09:08:58 xmper8q3.gcv.dom pulseaudio[32188]: [pulseaudio] module-ladspa-sink.c: The 'master' module argument is deprecated and may be removed in the future, please use the 'sink_master' argument instead.
    set 14 09:08:58 xmper8q3.gcv.dom pulseaudio[32188]: [pulseaudio] module-ladspa-sink.c: Master sink not found.
    set 14 09:08:58 xmper8q3.gcv.dom pulseaudio[32188]: [pulseaudio] module.c: Failed to load module "module-ladspa-sink" (argument: "sink_name=ladspa_output.mbeq_1197.mbeq master= plugin=mbeq_1197 label=mbeq control=3.0,3.0,7.3,7.0,3.0,-1.0,-6.6,-6.3,-4.5,-4.0,1.1,1.2,5.8,7.9,8.8"): initialization failed.
    set 14 09:08:58 xmper8q3.gcv.dom pulseaudio[32188]: [pulseaudio] main.c: Module load failed.
    set 14 09:08:58 xmper8q3.gcv.dom pulseaudio[32188]: [pulseaudio] main.c: Failed to initialize daemon.
    set 14 09:08:58 xmper8q3.gcv.dom pulseaudio[32185]: [pulseaudio] main.c: Daemon startup failed.
    However, this is off-topic now.
    I'll post a new thread with these details.

    Thank you Hendrik for your help!!

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  7. #7
    Join Date
    May 2015
    Location
    Italy
    Posts
    379

    Default Re: freerdp crash when remote desktop produces sound

    Just to end the thread, so that if someone comes here searching for help on pulseaudio problems he knows what I did to solve them: I deleted everything under ~/.config/pulse and then the pulseaudio daemon started without problems.

    Hope this helps..

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •