Results 1 to 10 of 10

Thread: Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

  1. #1
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Default Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

    Just by chance I realized today that a highly confidential word document (for me...) was cached multiple times
    in folders (e.g. /2338_0) below /home/~/.cache/kioexec/krun/..

    Looks like those copies have been generated by Dolphin when I navigated to some samba share of my
    file server (e.g.: smb://myserver/someshare/) and opened this document (after having it decrypted temporarily with PGP)

    Is there any chance to avoid such copies to be auto-generated by Dolphin or associated code?

  2. #2

    Default Re: Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

    Quote Originally Posted by hardy59 View Post
    Looks like those copies have been generated by Dolphin when I navigated to some samba share of my
    file server (e.g.: smb://myserver/someshare/) and opened this document (after having it decrypted temporarily with PGP)
    That's done by KIO (KDE's network-transparent file IO framework), if you browse to smb:// in dolphin and open a file with a non-KDE application (that doesn't support/use KIO). And that's "necessary" because that application wouldn't be able to access the file otherwise.

    To avoid this, mount the share first and browse to the mount point in dolphin, so that the files are "local" and can be accessed by every application.
    You can do that with something like "sudo mount //HOST/SHARE mountpoint", or use smb4k (but install it from KDE:Extra, the standard version has mounting disabled because it is considered to be a security risk).

  3. #3
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Thumbs up Re: Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

    Quote Originally Posted by wolfi323 View Post
    That's done by KIO (KDE's network-transparent file IO framework), if you browse to smb:// in dolphin and open a file with a non-KDE application (that doesn't support/use KIO). And that's "necessary" because that application wouldn't be able to access the file otherwise.

    To avoid this, mount the share first and browse to the mount point in dolphin, so that the files are "local" and can be accessed by every application.
    You can do that with something like "sudo mount //HOST/SHARE mountpoint", or use smb4k (but install it from KDE:Extra, the standard version has mounting disabled because it is considered to be a security risk).
    OK, I see. Thanks a lot for the explanation!

    With all older openSUSE versions (i.e. 13.1) I used to mount my samba shares with smb4k - but now, with Leap, I failed and didn't find any hint how to fix it...
    So thanks again for helping with that problem too!

    Cheers,
    Hardy

  4. #4
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Default Re: Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

    Unfortunately I failed today installing the "mounting-enabled" version of smb4k from KDE:Extra repo...
    Actually I failed already when I tried to add the repo as described here: https://software.opensuse.org/downlo...&package=smb4k
    The "manual way" is described as follows:


    Code:
    (become sudo first, of course)
    # zypper addrepo https://download.opensuse.org/reposi...KDE:Extra.repo
    # zypper refresh
    # zypper install smb4k
    Already the first command returned an error:
    Code:
    Thales:~ # zypper addrepo https://download.opensuse.org/repositories/KDE:Extra/openSUSE_Leap_42.3/KDE:Extra.repo
    Download (curl) error for 'https://download.opensuse.org/repositories/KDE:Extra/openSUSE_Leap_42.3/KDE:Extra.repo':
    Error code:  Bad URL
    Error message: Protocol http not supported or disabled in libcurl
    Strange, as I was specifying the URL which used the https protocol.... which sounds fine, as libcurl mentioned that http is unsupported.

    However, I tried again, but this time with http protocol:

    Code:
    Thales:~ # zypper addrepo http://download.opensuse.org/repositories/KDE:Extra/openSUSE_Leap_42.3/KDE:Extra.repo
    Adding repository 'Additional packages maintained by the KDE team (openSUSE_Leap_42.3)' ....................................................................................................................................[done]
    Repository 'Additional packages maintained by the KDE team (openSUSE_Leap_42.3)' successfully added
    URI         : http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_42.3/
    Enabled     : Yes                                                                     
    GPG Check   : Yes                                                                     
    Autorefresh : No                                                                      
    Priority    : 99 (default priority)                                                   
    Repository priorities are without effect. All enabled repositories share the same priority.
    This did the trick and I then could successfully install smb4k.

    When I checked the protocols used in all other reps I found out that all of them are "http" !

    So my questions are:

    • Is it normal to have just http repos?
    • Why does the https URL version fail with the KDE:Extra repo?


    Any hint is appreciated!
    Cheers,
    Hardy

  5. #5
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Default Re: Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

    After some research I might be able to give the answers by myself:

    Code:
    Question 1: is it normal to have just http repos?
    Yes, this is totally normal.

    Code:
    Question 2: Why does the https URL version fail with the KDE:Extra repo?
    Because the https protocol is not supported/enabled in libcurl... BUT the error message "Error message: Protocol http not supported or disabled in libcurl" seems to have a typo: It should be "https" instead of "http".
    The problem has nothing to do with the repo "KDE:Extra" used here.





  6. #6

    Default Re: Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

    Quote Originally Posted by hardy59 View Post
    Unfortunately I failed today installing the "mounting-enabled" version of smb4k from KDE:Extra repo...
    Actually I failed already when I tried to add the repo as described here: https://software.opensuse.org/downlo...&package=smb4k
    The "manual way" is described as follows:


    Code:
    (become sudo first, of course)
    # zypper addrepo https://download.opensuse.org/reposi...KDE:Extra.repo
    # zypper refresh
    # zypper install smb4k
    Already the first command returned an error:
    Code:
    Thales:~ # zypper addrepo https://download.opensuse.org/repositories/KDE:Extra/openSUSE_Leap_42.3/KDE:Extra.repo
    Download (curl) error for 'https://download.opensuse.org/repositories/KDE:Extra/openSUSE_Leap_42.3/KDE:Extra.repo':
    Error code:  Bad URL
    Error message: Protocol http not supported or disabled in libcurl
    Indeed.

    You don't need that .repo description file though, just add the repo URL directly:
    Code:
    zypper addrepo -f http://download.opensuse.org/repositories/KDE:Extra/openSUSE_Leap_42.3/ KDE:Extra
    Btw, you find the KDE:Extra repo also listed in YaST->Software Repositories, if you click Add and choose "Community Repositories"...

    Quote Originally Posted by hardy59 View Post

    Code:
    Question 2: Why does the https URL version fail with the KDE:Extra repo?
    Because the https protocol is not supported/enabled in libcurl...

    Hm, I doubt that this is the reason, because curl can use https:// just fine.
    Looks rather like a "server problem":
    Code:
    $ curl https://download.opensuse.org/repositories/KDE:Extra/openSUSE_Leap_42.3/KDE:Extra.repo
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>301 Moved Permanently</title>
    </head><body>
    <h1>Moved Permanently</h1>
    <p>The document has moved <a href="http://download.opensuse.org/repositories/KDE:/Extra/
    openSUSE_Leap_42.3/KDE:Extra.repo">here</a>.</p>
    <hr>
    <address>Apache/2.2.34 (Linux/SUSE) Server at download.opensuse.org Port 443</address>
    </body></html>
    
    (and/or curl/zypper not following the 301 redirection...)
    Last edited by wolfi323; 16-Sep-2017 at 06:17.

  7. #7
    Join Date
    Sep 2012
    Posts
    5,230

    Default Re: Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

    Quote Originally Posted by wolfi323 View Post
    Looks rather like a "server problem"
    Yes. That openSUSE download server still does not support https, is indeed server problem.
    (and/or curl/zypper not following the 301 redirection...)
    It does follow 301 redirection, but zypper explicitly restricts redirection to https only in this case. Note that error message says "Protocol http not supported or disabled in libcurl", not https:
    Code:
    bor@bor-Latitude-E5450:~$ curl --proto-redir =https --location https://download.opensuse.org/repositories/KDE:Extra/openSUSE_Leap_42.3/KDE:Extra.repo
    curl: (1) Protocol "http" not supported or disabled in libcurl

  8. #8
    Join Date
    Jun 2008
    Location
    Nuernberg
    Posts
    18

    Default Re: Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

    Quote Originally Posted by arvidjaar View Post
    Yes. That openSUSE download server still does not support https, is indeed server problem.

    It does follow 301 redirection, but zypper explicitly restricts redirection to https only in this case. Note that error message says "Protocol http not supported or disabled in libcurl", not https:
    Code:
    bor@bor-Latitude-E5450:~$ curl --proto-redir =https --location https://download.opensuse.org/repositories/KDE:Extra/openSUSE_Leap_42.3/KDE:Extra.repo
    curl: (1) Protocol "http" not supported or disabled in libcurl
    One thing is that

    https://download.opensuse.org/reposi...KDE:Extra.repo

    will not redirect and return the content. The extra / inclusion seems to trigger it.

  9. #9
    Join Date
    Sep 2012
    Posts
    5,230

    Default Re: Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

    Quote Originally Posted by msmeissn View Post
    One thing is that

    https://download.opensuse.org/reposi...KDE:Extra.repo

    will not redirect and return the content. The extra / inclusion seems to trigger it.
    OK, but it does understand that extra '/' is missing in original URL and correctly redirects; is it possible to make it redirect to https URL in this case? Alternatively simply returning 404 would probably be less confusing.

  10. #10
    Join Date
    Jun 2008
    Location
    Nuernberg
    Posts
    18

    Default Re: Cached files in /home/~/.cache/kioexec/krun/####_# ? How to avoid?

    Quote Originally Posted by arvidjaar View Post
    OK, but it does understand that extra '/' is missing in original URL and correctly redirects; is it possible to make it redirect to https URL in this case? Alternatively simply returning 404 would probably be less confusing.
    I filed two github issues.

    https://github.com/openSUSE/open-bui...ce/issues/3848

    for the .repo content should be https and

    https://github.com/openSUSE/open-bui...ce/issues/3847

    for the incorrect / redirection.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •