Results 1 to 7 of 7

Thread: mysql error: Can not create a new thread (error 1135).

  1. #1

    Default mysql error: Can not create a new thread (error 1135).

    Hello. I was using the 42.1 opensuse leap server and mysql was perfect. I changed to the version of opensuse 42.2 and then to version 42.3 and mysql no longer works.
    It gives an error of: mysql error: Can not create a new thread (error 1135).

    The values ​​of ulimit -a are:
    core file size (blocks, -c) 0
    data seg size (kbytes, -d) unlimited
    scheduling priority (-e) 0
    file size (blocks, -f) unlimited
    pending signals (-i) 31711
    max locked memory (kbytes, -l) 64
    max memory size (kbytes, -m) unlimited
    open files (-n) 1024
    pipe size (512 bytes, -p) 8
    POSIX message queues (bytes, -q) 819200
    real-time priority (-r) 0
    stack size (kbytes, -s) 8192
    cpu time (seconds, -t) unlimited
    max user processes (-u) 1850
    virtual memory (kbytes, -v) unlimited
    file locks (-x) unlimited

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,005

    Default Re: mysql error: Can not create a new thread (error 1135).

    I think some information is in order;

    Are you using MySQL Community Server or MariaDB?

    - Does it output this error when you start the service or after some time?
    - How many connections do you have configured in your my.cnf?
    - Do you really need that many?

    Could you copy paste the output of; systemctl status mysql and encode the output in CODE tags
    Code:
    Like this!
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    428

    Default Re: mysql error: Can not create a new thread (error 1135).

    In the past this was usually solved by setting "TasksMax=nnn" in the mysql.service file to a higher value.

    Hendrik

  4. #4

    Default Re: mysql error: Can not create a new thread (error 1135).

    Hello, thank you very much for your support.
    I'm in Brazil and using a translator.
    I'm using community 5.6.37.

    I figured it out to when it reaches 489 threads. That's it, and it gives the error number 1135.
    It seems to me that it is a bug in opensuse 42.2 and 42.3, because in opensuse 42.1 it works perfectly.
    - How many connections do you have configured in your my.cnf? 1200

    mysql: ~ # systemctl status mysql

    â mysql.service - MySQL server Loaded: loaded (/usr/lib/systemd/system/mysql.service; enabled; vendor preset: disabled) Active: active (running) since Mon 2017-09-11 14:56:24 -03; 1h 12min ago Process: 1671 ExecStartPost = / usr / lib / mysql / mysql-systemd-helper wait (code = exited, status = 0 / SUCCESS) Process: 1644 ExecStartPre = / usr / lib / mysql / mysql-systemd-helper upgrade (code = exited, status = 0 / SUCCESS) Process: 1586 ExecStartPre = / usr / lib / mysql / mysql-systemd-helper install (code = exited, status = 0 / SUCCESS) Main PID: 1670 (mysqld) Tasks: 25 (limit: 512) CGroup: /system.slice/mysql.service â € "1670 / usr / sbin / mysqld --defaults-file = / etc / my.cnf --user = mysql Sep 11 14:56:23 mysql mysql-systemd-helper [1670]: 170911 14:56:23 [Note] InnoDB: Highest supported file format is Barracuda. Sep 11 14:56:23 mysql mysql-systemd-helper [1670]: 170911 14:56:23 [Note] InnoDB: 128 rollback segment (s) are active. Sep 11 14:56:23 mysql mysql-systemd-helper [1670]: 170911 14:56:23 [Note] InnoDB: Waiting for purge to start Sep 11 14:56:23 mysql mysql-systemd-helper [1670]: 170911 14:56:23 [Note] InnoDB: Percona XtraDB (http://www.percona.com) 5.6.36-82.0 started; log sequence number 1616737 Sep 11 14:56:23 mysql mysql-systemd-helper [1670]: 170911 14:56:23 [Note] Server socket created on IP: '::'. Mysql mysql-systemd-helper [1670]: 170911 14:56:23 [Warning] 'proxies_priv' entry '@% root @ mysql' ignored in --skip-name-resolve mode. Sep 11 14:56:23 mysql mysql-systemd-helper [1670]: 170911 14:56:23 [Note] / usr / sbin / mysqld: ready for connections. Sep 11 14:56:23 mysql mysql-systemd-helper [1670]: Version: '10 .0.31-MariaDB 'socket:' /var/run/mysql/mysql.sock 'port: 3306 SLE 12 SP1 package Sep 11 14:56:24 mysql mysql-systemd-helper [1671]: MySQL is alive

  5. #5
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,005

    Default Re: mysql error: Can not create a new thread (error 1135).

    You could try what Hendwolt suggested

    Edit /usr/lib/systemd/system/mysql.service, then add TasksMax=infinity under [Service] and systemctl daemon-reload, then try to start MySQL.

    If it fails, edit the same file and try adding; LimitNOFILE=16384 under [Service] and reload + restart.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  6. #6

    Thumbs up Re: mysql error: Can not create a new thread (error 1135).

    Many thanks Miuku and also the Hendrik for the help.
    After the changes worked.
    Big hug to all.



    Geraldo.

  7. #7
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,005

    Default Re: mysql error: Can not create a new thread (error 1135).

    By the way, because the .service files are often changed and overwritten during updates, you should copy your /usr/lib/systemd/system/mysql.service to /etc/systemd/system/

    This way it will not be changed during updates and your changes will not be lost!
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •