Results 1 to 7 of 7

Thread: Citrix Receiver stopped working

  1. #1

    Default Citrix Receiver stopped working


    Running Tumbleweed with Gnome (Wayland) for a while now.
    I was using the Citrix Receiver without problems until I updated recently. That was before the issues with the opensuse repos started.

    Suse Full package (self-service support)

    zypper info ICAClient
    Informatie voor pakket ICAClient:
    Installatiebron : @System
    Naam : ICAClient
    Versie :
    Arch : x86_64
    Leverancier : Citrix Systems, Inc
    Installatiegrootte : 50,4 MiB
    Geïnstalleerd : Ja
    Status : actueel
    Broncodepakket : ICAClient-
    Samenvatting : Citrix Receiver for Linux
    Beschrijving :
    Citrix Receiver lets you access your enterprise files, applications, and
    desktops from your favorite device wherever you are. Just ask your IT
    department how to get started.

    Description of the problem:
    When I start the citrix receiver application, it briefly displays the window (where the published applications/desktops are). Then it immediately shuts down.
    When running the command from the application shortcut:
    ~> /opt/Citrix/ICAClient/selfservice --icaroot /opt/Citrix/ICAClient
    openjdk version "1.8.0_144"
    OpenJDK Runtime Environment (IcedTea 3.5.1) (suse-2.1-x86_64)
    OpenJDK 64-Bit Server VM (build 25.144-b01, mixed mode)
    Segmentatiefout (geheugendump gemaakt)

    Output from journalctl:

    sep 11 19:56:54 <hostname> kernel: selfservice[5770]: segfault at 8 ip 00007f1727009cc8 sp 00007f1722eca7a0 error 4 in[7f1726a09000+6b0000]
    sep 11 19:56:54 <hostname> systemd[1]: Started Process Core Dump (PID 5821/UID 0).
    sep 11 19:56:54 <hostname> systemd-coredump[5822]: Process 5769 (selfservice) of user 1000 dumped core.

    openSUSE-release: 20170909-1.2
    kernel: 4.12.11-1-default

    Today I updated to latest TW release, however no change.
    All information above is after this update as you can see from the release version.

    I know foreign packages are not supported, but I would be glad if anybody could show me a direction for troubleshooting.

  2. #2

    Default Re: Citrix Receiver stopped working

    A new Reciever package was released by Citrix.
    So I tested with my current setup, same symptoms

    ~> /opt/Citrix/ICAClient/selfservice --icaroot /opt/Citrix/ICAClient
    openjdk version "1.8.0_144"
    OpenJDK Runtime Environment (IcedTea 3.5.1) (suse-3.1-x86_64)
    OpenJDK 64-Bit Server VM (build 25.144-b01, mixed mode)
    Segmentatiefout (geheugendump gemaakt)

    Kernel: 4.13.3-1-default
    openSUSE-release: 20170927-1.2

    Anyone having same issue?

  3. #3
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: Citrix Receiver stopped working

    Note the following reported bug which was considered resolved last year

    Based on that bug report, you should try installing webkitgtk 2.4.11

    Another possible try is to install the later TW libwebkitgtk package
    zypper in libwebgtk-3_0-0
    Reading the descriptions of other similar reported errors, it's likely your problem has something to do with SSL, so you might want to at least briefly skim your Server SSL settings (ie. has it been updated to install patched SSL released last year?)

    In any case successful or not, there is usually little anyone can do about a segmentation fault.
    You'll want to submit a bug at

    Beginner Wiki Quickstart -
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4
    Join Date
    Jun 2008
    Blog Entries

    Default Re: Citrix Receiver stopped working

    Anything using webkitgtk (3.0) won't be dealt with by a bug report, it is dead and is being actively removed from Tumbleweed...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Citrix Receiver stopped working

    Both many thanks for your responses.
    Regarding SSL, this could be part of the issue, but my gut says it's something else.

    When installing the receiver package and launching it for the first time, after accepting the eula, you have to enter a Citrix Access Gateway.
    Usually an error pops up saying the server's certificate is not trusted, when connecting to it.
    In several threads on the forum the following solution is provided:
    sudo ln -s /etc/ssl/certs/* /opt/Citrix/ICAClient/keystore/cacerts/
    This solution has always worked fine for me.

    So to be sure I installed a fresh TW and a Leap 42.3 VM.
    Both with Gnome, default install and current updates.
    Tested the receiver package in both:
    - On TW: same issue as on my host
    - On Leap 42.3: fully functional receiver, so no crashes.
    Of course I had to correct the certs as above in both VM's.

    I also noticed that in Leap no dependency had to be installed.
    In TW these dependencies were installed:
    (1/4) Installeren van: libjavascriptcoregtk-1_0-0-2.4.11-6.3.x86_64 ....[gereed]
    (2/4) Installeren van: libwebkitgtk-1_0-0-2.4.11-6.3.x86_64 ............[gereed]
    (3/4) Installeren van: libwebkitgtk2-lang-2.4.11-6.3.noarch ............[gereed]
    (4/4) Installeren van: ICAClient- ..............[gereed]
    So I guess it's best that I submit a bug report indeed.

  6. #6

    Default Re: Citrix Receiver stopped working

  7. #7

    Default Re: Citrix Receiver stopped working

    I'm happy to announce that the bug is fixed.
    Patience is a virtue

    As an extra, some info on the citrix forum.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts