Results 1 to 3 of 3

Thread: Can't unlock screen after update from 42.2 to 42.3

  1. #1

    Default Can't unlock screen after update from 42.2 to 42.3

    When the lock screen is active I can't unlock the lock screen by entering
    the password. When I enter password the login screen goes away for a moment
    and then pops up again. As workaround I need to do a root login in to a text
    terminal an run "loginctl unlock-sessions". Checking the syslog shows some
    entries that might be related to the problem: like
    Code:
    2017-09-09T13:37:51.548596+02:00 linux-z0jl console-kit-daemon[3626]:
    (process:5161): GLib-CRITICAL **: g_slice_set_config: assertion
    'sys_page_size == 0' failed
    However these entries aren't in a 1.:1 relation to the unlock tries.
    Xorg.log shows no problem.
    I can't be a wrong password, because this would be shown on the login screen
    and logged into syslog.
    This a Leap 42.3 installation with two special things:
    Running a kernel from kernel stable ( problem showed up with 4.12.10 and
    4.13.0)
    propriatary nvidia driver installed from .run file.

    With 42.2 I've seen a similar problem from time to time when glx was broken because Xorg or mesa updates updates overwrote nvidias glx files. But now that happens also after a fresh reinstall of the nvidia driver, which used to fix the problem in 42.2.
    Any ideas what is going wrong here are welcome.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Can't unlock screen after update from 42.2 to 42.3

    How exactly did you perform the upgrade 42.2 => 42.3 ?
    Do you see this issue with the stock kernel and the nvidia packages from the nvidia repo ??
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Can't unlock screen after update from 42.2 to 42.3

    I adapted all repos to the new version by editing the files in /etc/zypp/repos.d and then run zypper ref and zypper dup.
    Haven't tried the stock kernel and the nvidia repo. The running kernel version (4.12.10) and the nvidia driver (384.59) didn't change during the update.
    Meanwhile I updated kernel to 4.13.0 and nvidia to 384.69 using the same procedures which used to work always with 42.2.But that didn't help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •