Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: RPM failed: Can't exec 'rpm' (No such file or directory)

  1. #1

    Default RPM failed: Can't exec 'rpm' (No such file or directory)

    Hello,

    My rpm stopped working after installing some node packages. I don't know how and why but I certainly know that I wasn't doing anything else. (since node is installed /usr/bin I did run sudo)

    Error: Subprocess failed. Error: RPM failed: Can't exec 'rpm' (No such file or directory).
    Last thing that I installed with zypper was shutter, but I don't think that broke my rpm?

    Rpm is still in bin:
    Code:
    ls bin/rp* │bin/rpm 
    But somehow zypper can't access it? It was unset from zypper rpm location?

    Can I fix it without installing another OS?

    Additional Info:
    uname -a:Linux linux-4jvx 4.12.9-1-default #1 SMP PREEMPT Fri Aug 25 07:08:45 UTC 2017 (f2ab6ba) x86_64 x86_64 x86_64 GNU/Linux

    Thank you.

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    1,892

    Default Re: RPM failed: Can't exec 'rpm' (No such file or directory)

    First question;

    What happens when you execute rpm? Does it actually work or splurt out any warnings / errors?
    .: miuku #suse @ irc.freenode.net
    .: https://build.opensuse.org/project/show/home:Miuku
    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: RPM failed: Can't exec 'rpm' (No such file or directory)

    Hi Miuku,

    When I run rpm:
    Code:
    rpm                            
    RPM version 4.13.0.1                
    Copyright (C) 1998-2002 - Red Hat, Inc.                                 
    This program may be freely redistributed under the terms of the GNU GPL                                                                         
    
    Usage: rpm [-afgpcdLlsiv?] [-a|--all] [-f|--file] [-g|--group] [-p|--package] [--pkgid] [--hdrid] [--triggeredby] [--whatrequires]              
            [--whatprovides] [--whatrecommends] [--whatsuggests] [--whatsupplements] [--whatenhances] [--nomanifest] [-c|--configfiles]             
            [-d|--docfiles] [-L|--licensefiles] [--dump] [-l|--list] [--queryformat=QUERYFORMAT] [-s|--state] [--nofiledigest] [--nofiles]          
            [--nodeps] [--noscript] [--allfiles] [--allmatches] [--badreloc] [-e|--erase=<package>+] [--excludedocs] [--excludepath=<path>]         
            [--force] [-F|--freshen=<packagefile>+] [-h|--hash] [--ignorearch] [--ignoreos] [--ignoresize] [-i|--install] [--justdb]                
            [--nodeps] [--nofiledigest] [--nocontexts] [--noorder] [--noscripts] [--notriggers] [--oldpackage] [--percent]                          
            [--prefix=<dir>] [--relocate=<old>=<new>] [--replacefiles] [--replacepkgs] [--test] [-U|--upgrade=<packagefile>+]                       
            [--reinstall=<packagefile>+] [-D|--define='MACRO EXPR'] [--undefine=MACRO] [-E|--eval='EXPR'] [--macros=<FILE:...>] [--noplugins]       
            [--nodigest] [--nosignature] [--rcfile=<FILE:...>] [-r|--root=ROOT] [--dbpath=DIRECTORY] [--querytags] [--showrc] [--quiet]             
            [-v|--verbose] [--version] [-?|--help] [--usage] [--scripts] [--setperms] [--setugids] [--conflicts] [--obsoletes]                      
            [--provides] [--requires] [--recommends] [--suggests] [--supplements] [--enhances] [--info] [--changelog] [--changes] [--xml]           
            [--triggers] [--filetriggers] [--last] [--dupes] [--filesbypkg] [--fileclass] [--filecolor] [--fscontext] [--fileprovide]               
            [--filerequire] [--filecaps] 
    

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    21,926

    Default Re: RPM failed: Can't exec 'rpm' (No such file or directory)

    Quote Originally Posted by hodispk View Post
    Hello,

    My rpm stopped working after installing some node packages. I don't know how and why but I certainly know that I wasn't doing anything else. (since node is installed /usr/bin I did run sudo)



    Last thing that I installed with zypper was shutter, but I don't think that broke my rpm?

    Rpm is still in bin:
    Code:
    ls bin/rp* │bin/rpm 
    But somehow zypper can't access it? It was unset from zypper rpm location?

    Can I fix it without installing another OS?

    Additional Info:
    uname -a:Linux linux-4jvx 4.12.9-1-default #1 SMP PREEMPT Fri Aug 25 07:08:45 UTC 2017 (f2ab6ba) x86_64 x86_64 x86_64 GNU/Linux

    Thank you.
    We see the output, but what is missing here is the command you used. Please always copy/paste the prompt, the command, the output and the next prompt. Only so people can detect who you were, where you were, what you did and what you got (in short, all what you saw).

    And please copy/paste direct from the terminal window in the post between the CODE tags. E.g. when I do
    Code:
    henk@boven:~> ls /bin/rp*
    /bin/rpm
    henk@boven:~>
    it looks definitely different from what you post. I assume you changed something there and that will not raise the trust others have in the exactness of the information you provide.
    Henk van Velden

  5. #5

    Default Re: RPM failed: Can't exec 'rpm' (No such file or directory)

    Hi hcvv,

    The command I used:
    Code:
    alexandru@linux-4jvx:~> sudo zypper update
    
    Output.txt:
    Code:
    Building repository 'skype (stable)' cache [...done]
    Warning: Skipping repository 'skype (stable)' because of the above error.
    Loading repository data...
    Reading installed packages...
    
    
    The following 3 package updates will NOT be installed:
      gegl-0_2 kernel-default-4.12.9-1.3 rpm
    
    
    The following 2 NEW packages are going to be installed:
      libqalculate11 udftools
    
    
    The following 28 applications are going to be REMOVED:
      "Activity Bar" "Analog Clock" "Battery and Brightness" Breeze Calendar Clipboard "CPU Load Monitor" "Device Notifier" "Digital Clock" "Global Menu" GParted "GStreamer Multimedia Codecs" "Hard Disk I/O Monitor" "Hard Disk Space Usage" Image "LibreOffice Base" "LibreOffice Calc" "LibreOffice Draw" "LibreOffice Impress" "LibreOffice Writer" Lock/Logout "Media Player" "Memory Status" "Network Monitor" Notifications "Plain Color" Slideshow "System Tray"
    
    
    The following 125 packages are going to be upgraded:
      akonadi-server alsa-plugins alsa-plugins-pulse autofs btrfsprogs btrfsprogs-udev-rules bundle-lang-common-en bundle-lang-gnome-en bundle-lang-kde-en curl docbook-xsl-stylesheets drkonqi5 glibc glibc-32bit glibc-extra glibc-i18ndata glibc-locale gparted gpg2 gstreamer gstreamer-plugins-bad gstreamer-plugins-base gstreamer-plugins-good iscsiuio kdebase4-workspace-libs kernel-firmware libbtrfs0 libcurl4 libgstadaptivedemux-1_0-0 libgstallocators-1_0-0 libgstapp-1_0-0 libgstaudio-1_0-0 libgstbadaudio-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstfft-1_0-0 libgstgl-1_0-0 libgstmpegts-1_0-0 libgstpbutils-1_0-0 libgstphotography-1_0-0 libgstreamer-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0 libgsttag-1_0-0 libgsturidownloader-1_0-0 libgstvideo-1_0-0 libgstwayland-1_0-0 libhdf4 libKF5AkonadiAgentBase5 libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5 libnghttp2-14 libpango-1_0-0 libparted0 libpolkit0 libQt5Concurrent5 libQt5Core5 libQt5DBus5 libQt5Gui5 libQt5Network5 libQt5OpenGL5 libQt5PrintSupport5 libqt5-qtbase-platformtheme-gtk3 libQt5Sql5 libQt5Sql5-mysql libQt5Sql5-sqlite libQt5Test5 libQt5Widgets5 libQt5Xml5 libreoffice libreoffice-base libreoffice-base-drivers-mysql libreoffice-branding-upstream libreoffice-calc libreoffice-draw libreoffice-filters-optional libreoffice-icon-theme-breeze libreoffice-icon-theme-galaxy libreoffice-icon-theme-hicontrast libreoffice-icon-theme-sifr libreoffice-impress libreoffice-kde4 libreoffice-l10n-en libreoffice-mailmerge libreoffice-math libreoffice-pyuno libreoffice-writer libsystemd0 libsystemd0-32bit libudev1 libudev1-32bit libva1 libva-drm1 libva-egl1 libva-glx1 libva-x11-1 libzip5 nscd open-iscsi openSUSE-release parted perl-DBI perl-IO-Socket-SSL perl-JSON-XS plasma5-workspace plasma5-workspace-libs polkit python3-chardet systemd systemd-32bit systemd-bash-completion systemd-logger systemd-sysvinit telepathy-mission-control-plugin-goa typelib-1_0-Pango-1_0 typelib-1_0-Polkit-1_0 ucode-amd udev yast2-auth-client
    
    The following product is going to be upgraded:
      "openSUSE Tumbleweed"
    
    125 packages to upgrade, 2 new.
    Overall download size: 0 B. Already cached: 190.4 MiB. After the operation, additional 9.3 MiB will be used.
    Continue? [y/n/...? shows all options] (y): In cache btrfsprogs-udev-rules-4.12.1-1.1.noarch.rpm (1/127),  55.2 KiB (  387   B unpacked)
    In cache bundle-lang-common-en-13.2-54.1.noarch.rpm (2/127), 225.1 KiB (  1.4 MiB unpacked)
    In cache bundle-lang-gnome-en-13.2-54.1.noarch.rpm (3/127),   1.3 MiB (  7.0 MiB unpacked)
    In cache bundle-lang-kde-en-13.2-54.1.noarch.rpm (4/127), 834.4 KiB (  4.7 MiB unpacked)
    In cache docbook-xsl-stylesheets-1.79.0-4.1.noarch.rpm (5/127),   4.2 MiB ( 24.4 MiB unpacked)
    In cache glibc-i18ndata-2.26-2.1.noarch.rpm (6/127),   3.1 MiB (  8.9 MiB unpacked)
    In cache kernel-firmware-20170823-1.1.noarch.rpm (7/127),  46.0 MiB (202.7 MiB unpacked)
    In cache libreoffice-branding-upstream-5.4.0.3-2.4.noarch.rpm (8/127),   1.1 MiB (809.8 KiB unpacked)
    In cache libreoffice-icon-theme-galaxy-5.4.0.3-2.4.noarch.rpm (9/127),   1.7 MiB (  2.7 MiB unpacked)
    In cache perl-IO-Socket-SSL-2.025-1.4.noarch.rpm (10/127), 205.2 KiB (508.5 KiB unpacked)
    In cache python3-chardet-3.0.4-2.1.noarch.rpm (11/127), 169.1 KiB (  1.1 MiB unpacked)
    In cache systemd-bash-completion-234-3.1.noarch.rpm (12/127), 300.8 KiB ( 80.5 KiB unpacked)
    In cache ucode-amd-20170823-1.1.noarch.rpm (13/127),  59.7 KiB ( 28.6 KiB unpacked)
    In cache yast2-auth-client-3.3.17-1.1.noarch.rpm (14/127),  60.9 KiB (268.8 KiB unpacked)
    In cache glibc-2.26-2.1.x86_64.rpm (15/127),   1.9 MiB (  6.8 MiB unpacked)
    In cache glibc-32bit-2.26-2.1.x86_64.rpm (16/127),   1.5 MiB (  4.4 MiB unpacked)
    In cache openSUSE-release-20170904-1.2.x86_64.rpm (17/127), 531.9 KiB (843.6 KiB unpacked)
    In cache libreoffice-icon-theme-breeze-5.4.0.3-2.4.noarch.rpm (18/127),   1.2 MiB (  2.8 MiB unpacked)
    In cache udftools-1.3-1.3.x86_64.rpm (19/127),  67.8 KiB (172.0 KiB unpacked)
    In cache telepathy-mission-control-plugin-goa-3.12.14-1.1.x86_64.rpm (20/127),  90.4 KiB ( 18.5 KiB unpacked)
    In cache perl-JSON-XS-3.04-1.1.x86_64.rpm (21/127), 103.3 KiB (252.7 KiB unpacked)
    In cache perl-DBI-1.637-1.1.x86_64.rpm (22/127), 738.0 KiB (  2.0 MiB unpacked)
    In cache libzip5-1.2.0-4.1.x86_64.rpm (23/127),  74.0 KiB (141.5 KiB unpacked)
    In cache libva1-1.8.3-2.1.x86_64.rpm (24/127),  62.1 KiB (133.7 KiB unpacked)
    In cache libva-drm1-1.8.3-2.1.x86_64.rpm (25/127),  23.7 KiB ( 10.2 KiB unpacked)
    In cache libudev1-234-3.1.x86_64.rpm (26/127), 340.4 KiB (134.2 KiB unpacked)
    In cache libsystemd0-234-3.1.x86_64.rpm (27/127), 505.5 KiB (588.1 KiB unpacked)
    In cache libparted0-3.2-13.1.x86_64.rpm (28/127), 173.6 KiB (381.2 KiB unpacked)
    In cache libpango-1_0-0-1.40.11-2.1.x86_64.rpm (29/127), 198.1 KiB (516.1 KiB unpacked)
    In cache libnghttp2-14-1.25.0-1.1.x86_64.rpm (30/127), 107.1 KiB (155.1 KiB unpacked)
    In cache libhdf4-4.2.11-6.17.x86_64.rpm (31/127), 400.2 KiB (  1.3 MiB unpacked)
    In cache libgstreamer-1_0-0-1.12.2-2.1.x86_64.rpm (32/127), 692.4 KiB (  1.9 MiB unpacked)
    In cache libbtrfs0-4.12.1-1.1.x86_64.rpm (33/127),  75.0 KiB ( 50.9 KiB unpacked)
    In cache libQt5Core5-5.9.1-5.1.x86_64.rpm (34/127),   2.0 MiB (  5.5 MiB unpacked)
    In cache kdebase4-workspace-libs-4.11.22-9.1.x86_64.rpm (35/127), 974.9 KiB (  3.7 MiB unpacked)
    In cache iscsiuio-0.7.8.2-36.1.x86_64.rpm (36/127), 105.4 KiB (177.5 KiB unpacked)
    In cache gpg2-2.2.0-1.1.x86_64.rpm (37/127),   1.9 MiB (  7.0 MiB unpacked)
    In cache glibc-locale-2.26-2.1.x86_64.rpm (38/127),   6.2 MiB (122.2 MiB unpacked)
    In cache glibc-extra-2.26-2.1.x86_64.rpm (39/127), 102.4 KiB ( 23.9 KiB unpacked)
    In cache btrfsprogs-4.12.1-1.1.x86_64.rpm (40/127), 673.8 KiB (  3.8 MiB unpacked)
    In cache alsa-plugins-pulse-1.1.4-2.1.x86_64.rpm (41/127),  41.8 KiB ( 84.0 KiB unpacked)
    In cache alsa-plugins-1.1.4-2.1.x86_64.rpm (42/127),  60.1 KiB (149.2 KiB unpacked)
    In cache systemd-32bit-234-3.1.x86_64.rpm (43/127), 417.2 KiB (338.4 KiB unpacked)
    In cache libudev1-32bit-234-3.1.x86_64.rpm (44/127), 345.5 KiB (149.4 KiB unpacked)
    In cache libsystemd0-32bit-234-3.1.x86_64.rpm (45/127), 527.7 KiB (678.5 KiB unpacked)
    In cache libreoffice-icon-theme-sifr-5.4.0.3-2.4.noarch.rpm (46/127), 837.4 KiB (  1.6 MiB unpacked)
    In cache libva-x11-1-1.8.3-2.1.x86_64.rpm (47/127),  28.3 KiB ( 22.6 KiB unpacked)
    In cache libva-egl1-1.8.3-2.1.x86_64.rpm (48/127),  21.8 KiB (  5.9 KiB unpacked)
    In cache parted-3.2-13.1.x86_64.rpm (49/127), 219.5 KiB (609.4 KiB unpacked)
    In cache typelib-1_0-Pango-1_0-1.40.11-2.1.x86_64.rpm (50/127),  51.6 KiB ( 72.5 KiB unpacked)
    In cache libcurl4-7.55.0-2.1.x86_64.rpm (51/127), 262.3 KiB (513.9 KiB unpacked)
    In cache gstreamer-1.12.2-2.1.x86_64.rpm (52/127), 238.3 KiB (522.6 KiB unpacked)
    In cache libQt5Xml5-5.9.1-5.1.x86_64.rpm (53/127), 168.3 KiB (481.3 KiB unpacked)
    In cache libQt5Test5-5.9.1-5.1.x86_64.rpm (54/127), 167.9 KiB (454.9 KiB unpacked)
    In cache libQt5Sql5-5.9.1-5.1.x86_64.rpm (55/127), 182.9 KiB (525.7 KiB unpacked)
    In cache libQt5DBus5-5.9.1-5.1.x86_64.rpm (56/127), 261.0 KiB (783.7 KiB unpacked)
    In cache libQt5Concurrent5-5.9.1-5.1.x86_64.rpm (57/127), 102.8 KiB (260.8 KiB unpacked)
    In cache libKF5AkonadiPrivate5-17.08.0-2.1.x86_64.rpm (58/127), 189.0 KiB (533.6 KiB unpacked)
    In cache libreoffice-icon-theme-hicontrast-5.4.0.3-2.4.noarch.rpm (59/127), 555.2 KiB (  1.1 MiB unpacked)
    In cache libva-glx1-1.8.3-2.1.x86_64.rpm (60/127),  27.5 KiB ( 22.6 KiB unpacked)
    In cache systemd-234-3.1.x86_64.rpm (61/127),   2.9 MiB (  9.8 MiB unpacked)
    In cache libqalculate11-2.0.0-1.1.x86_64.rpm (62/127), 610.8 KiB (  2.3 MiB unpacked)
    In cache curl-7.55.0-2.1.x86_64.rpm (63/127), 272.6 KiB (470.0 KiB unpacked)
    In cache libgsturidownloader-1_0-0-1.12.2-3.1.x86_64.rpm (64/127),  84.7 KiB ( 30.9 KiB unpacked)
    In cache libgstphotography-1_0-0-1.12.2-3.1.x86_64.rpm (65/127),  82.5 KiB ( 34.2 KiB unpacked)
    In cache libgstmpegts-1_0-0-1.12.2-3.1.x86_64.rpm (66/127), 119.4 KiB (162.5 KiB unpacked)
    In cache libgstcodecparsers-1_0-0-1.12.2-3.1.x86_64.rpm (67/127), 175.7 KiB (266.4 KiB unpacked)
    In cache libgstbadbase-1_0-0-1.12.2-3.1.x86_64.rpm (68/127),  99.7 KiB ( 71.1 KiB unpacked)
    In cache gstreamer-plugins-base-1.12.2-2.1.x86_64.rpm (69/127), 747.8 KiB (  2.2 MiB unpacked)
    In cache libQt5Sql5-sqlite-5.9.1-5.1.x86_64.rpm (70/127), 112.9 KiB (297.8 KiB unpacked)
    In cache libQt5Sql5-mysql-5.9.1-5.1.x86_64.rpm (71/127), 117.2 KiB (310.0 KiB unpacked)
    In cache libQt5Network5-5.9.1-5.1.x86_64.rpm (72/127), 674.0 KiB (  2.4 MiB unpacked)
    In cache udev-234-3.1.x86_64.rpm (73/127),   1.4 MiB (  7.3 MiB unpacked)
    In cache libgstadaptivedemux-1_0-0-1.12.2-3.1.x86_64.rpm (74/127), 109.0 KiB ( 95.6 KiB unpacked)
    In cache libgstvideo-1_0-0-1.12.2-2.1.x86_64.rpm (75/127), 243.8 KiB (601.2 KiB unpacked)
    In cache libQt5Gui5-5.9.1-5.1.x86_64.rpm (76/127),   2.5 MiB (  9.5 MiB unpacked)
    In cache systemd-sysvinit-234-3.1.x86_64.rpm (77/127), 295.6 KiB (  5.3 KiB unpacked)
    In cache systemd-logger-234-3.1.x86_64.rpm (78/127), 289.9 KiB (  1.0 KiB unpacked)
    In cache open-iscsi-2.0.875-36.1.x86_64.rpm (79/127), 362.8 KiB (  2.1 MiB unpacked)
    In cache nscd-2.26-2.1.x86_64.rpm (80/127), 160.4 KiB (150.9 KiB unpacked)
    In cache libpolkit0-0.113-5.1.x86_64.rpm (81/127),  64.2 KiB (159.3 KiB unpacked)
    In cache autofs-5.1.3-2.1.x86_64.rpm (82/127), 636.8 KiB (  3.5 MiB unpacked)
    In cache libgstwayland-1_0-0-1.12.2-3.1.x86_64.rpm (83/127),  78.0 KiB ( 10.1 KiB unpacked)
    In cache libgstbadvideo-1_0-0-1.12.2-3.1.x86_64.rpm (84/127),  94.8 KiB ( 55.3 KiB unpacked)
    In cache libgstapp-1_0-0-1.12.2-2.1.x86_64.rpm (85/127),  86.7 KiB ( 59.1 KiB unpacked)
    In cache libqt5-qtbase-platformtheme-gtk3-5.9.1-5.1.x86_64.rpm (86/127), 188.4 KiB (596.7 KiB unpacked)
    In cache libQt5Widgets5-5.9.1-5.1.x86_64.rpm (87/127),   2.1 MiB (  6.5 MiB unpacked)
    In cache polkit-0.113-5.1.x86_64.rpm (88/127), 113.9 KiB (259.5 KiB unpacked)
    In cache libgsttag-1_0-0-1.12.2-2.1.x86_64.rpm (89/127), 148.9 KiB (236.6 KiB unpacked)
    In cache libgstbasecamerabinsrc-1_0-0-1.12.2-3.1.x86_64.rpm (90/127),  84.5 KiB ( 26.7 KiB unpacked)
    In cache plasma5-workspace-libs-5.10.5-2.1.x86_64.rpm (91/127), 234.6 KiB (701.7 KiB unpacked)
    In cache libQt5PrintSupport5-5.9.1-5.1.x86_64.rpm (92/127), 246.9 KiB (756.4 KiB unpacked)
    In cache libQt5OpenGL5-5.9.1-5.1.x86_64.rpm (93/127), 199.3 KiB (587.8 KiB unpacked)
    In cache libKF5AkonadiCore5-17.08.0-2.1.x86_64.rpm (94/127), 660.6 KiB (  2.2 MiB unpacked)
    In cache drkonqi5-5.10.5-2.1.x86_64.rpm (95/127), 252.7 KiB (779.3 KiB unpacked)
    In cache typelib-1_0-Polkit-1_0-0.113-5.1.x86_64.rpm (96/127),  27.3 KiB ( 22.6 KiB unpacked)
    In cache gparted-0.29.0-1.1.x86_64.rpm (97/127), 700.7 KiB (  2.7 MiB unpacked)
    In cache libgstaudio-1_0-0-1.12.2-2.1.x86_64.rpm (98/127), 208.5 KiB (437.2 KiB unpacked)
    In cache libKF5AkonadiXml5-17.08.0-2.1.x86_64.rpm (99/127),  67.2 KiB (101.2 KiB unpacked)
    In cache libKF5AkonadiWidgets5-17.08.0-2.1.x86_64.rpm (100/127), 252.0 KiB (807.1 KiB unpacked)
    In cache libKF5AkonadiAgentBase5-17.08.0-2.1.x86_64.rpm (101/127), 143.0 KiB (383.2 KiB unpacked)
    In cache plasma5-workspace-5.10.5-2.1.x86_64.rpm (102/127),   5.5 MiB ( 13.4 MiB unpacked)
    In cache libgstpbutils-1_0-0-1.12.2-2.1.x86_64.rpm (103/127), 136.8 KiB (225.2 KiB unpacked)
    In cache libgstbadaudio-1_0-0-1.12.2-3.1.x86_64.rpm (104/127),  86.2 KiB ( 30.5 KiB unpacked)
    In cache akonadi-server-17.08.0-2.1.x86_64.rpm (105/127), 912.2 KiB (  3.0 MiB unpacked)
    In cache libgstriff-1_0-0-1.12.2-2.1.x86_64.rpm (106/127),  89.3 KiB ( 54.4 KiB unpacked)
    In cache libreoffice-l10n-en-5.4.0.3-2.4.noarch.rpm (107/127), 431.7 KiB (777.0 KiB unpacked)
    In cache libgstrtsp-1_0-0-1.12.2-2.1.x86_64.rpm (108/127), 109.1 KiB (131.5 KiB unpacked)
    In cache libgstrtp-1_0-0-1.12.2-2.1.x86_64.rpm (109/127), 106.8 KiB (131.4 KiB unpacked)
    In cache libgstfft-1_0-0-1.12.2-2.1.x86_64.rpm (110/127),  83.4 KiB ( 42.1 KiB unpacked)
    In cache libgstallocators-1_0-0-1.12.2-2.1.x86_64.rpm (111/127),  72.2 KiB ( 14.2 KiB unpacked)
    In cache libreoffice-5.4.0.3-2.4.x86_64.rpm (112/127),  61.3 MiB (227.7 MiB unpacked)
    In cache libgstsdp-1_0-0-1.12.2-2.1.x86_64.rpm (113/127),  97.1 KiB ( 90.6 KiB unpacked)
    In cache libgstgl-1_0-0-1.12.2-3.1.x86_64.rpm (114/127), 203.8 KiB (386.3 KiB unpacked)
    In cache libreoffice-writer-5.4.0.3-2.4.x86_64.rpm (115/127),   3.3 MiB ( 14.1 MiB unpacked)
    In cache libreoffice-pyuno-5.4.0.3-2.4.x86_64.rpm (116/127), 463.4 KiB (889.2 KiB unpacked)
    In cache libreoffice-math-5.4.0.3-2.4.x86_64.rpm (117/127), 590.5 KiB (  1.5 MiB unpacked)
    In cache libreoffice-kde4-5.4.0.3-2.4.x86_64.rpm (118/127), 275.8 KiB (229.3 KiB unpacked)
    In cache libreoffice-impress-5.4.0.3-2.4.x86_64.rpm (119/127), 778.0 KiB (  2.3 MiB unpacked)
    In cache libreoffice-draw-5.4.0.3-2.4.x86_64.rpm (120/127), 406.0 KiB (591.4 KiB unpacked)
    In cache libreoffice-calc-5.4.0.3-2.4.x86_64.rpm (121/127),   6.8 MiB ( 27.6 MiB unpacked)
    In cache libreoffice-base-5.4.0.3-2.4.x86_64.rpm (122/127),   2.6 MiB ( 10.8 MiB unpacked)
    In cache gstreamer-plugins-good-1.12.2-2.1.x86_64.rpm (123/127),   1.6 MiB (  5.1 MiB unpacked)
    In cache gstreamer-plugins-bad-1.12.2-3.1.x86_64.rpm (124/127),   1.4 MiB (  4.9 MiB unpacked)
    In cache libreoffice-mailmerge-5.4.0.3-2.4.x86_64.rpm (125/127), 223.3 KiB ( 34.7 KiB unpacked)
    In cache libreoffice-filters-optional-5.4.0.3-2.4.x86_64.rpm (126/127), 519.6 KiB (  3.6 MiB unpacked)
    Checking for file conflicts: [.........done]
    (  1/127) Installing: btrfsprogs-udev-rules-4.12.1-1.1.noarch [.error]
    Installation of btrfsprogs-udev-rules-4.12.1-1.1.noarch failed:
    Error: Subprocess failed. Error: RPM failed: Can't exec 'rpm' (No such file or directory).
    Abort, retry, ignore? [a/r/i] (a):

  6. #6
    Join Date
    May 2012
    Location
    Finland
    Posts
    1,892

    Default Re: RPM failed: Can't exec 'rpm' (No such file or directory)

    Could you do a little test, instead of using sudo - could you run the following command;

    su
    (it will ask for your root password)
    zypper dup

    And see if it still complains about rpm missing. I wonder if there's an environmental variable / path issue at work here.
    .: miuku #suse @ irc.freenode.net
    .: https://build.opensuse.org/project/show/home:Miuku
    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  7. #7

    Default Re: RPM failed: Can't exec 'rpm' (No such file or directory)

    Quote Originally Posted by Miuku View Post
    Could you do a little test, instead of using sudo - could you run the following command;

    su
    (it will ask for your root password)
    zypper dup

    And see if it still complains about rpm missing. I wonder if there's an environmental variable / path issue at work here.
    Code:
    alexandru@linux-4jvx:~> su
    Password:  
    linux-4jvx:/home/alexandru # zypper dup
    bash: zypper: command not found
    linux-4jvx:/home/alexandru #  
    
    But `sudo zypper update` works. Please check my previous post.

  8. #8
    Join Date
    May 2012
    Location
    Finland
    Posts
    1,892

    Default Re: RPM failed: Can't exec 'rpm' (No such file or directory)

    Did you, when you were playing around with node, make any changes to /etc/profile, .profile, bashrc or similar file regarding the PATH environmental variable?
    .: miuku #suse @ irc.freenode.net
    .: https://build.opensuse.org/project/show/home:Miuku
    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  9. #9

    Default Re: RPM failed: Can't exec 'rpm' (No such file or directory)

    Quote Originally Posted by Miuku View Post
    Did you, when you were playing around with node, make any changes to /etc/profile, .profile, bashrc or similar file regarding the PATH environmental variable?
    Manually not. I did not edit any environment variables since I added jdk alternatives. Few weeks ago. Zypper worked until I ran node with sudo.
    My /etc/environment was wiped out after that so I added again JAVA_HOME and MVN_HOME. I don't know how a default /etc/environment file looks like so I can compare... /etc/profile, .profile, .bashrc looks normal.

  10. #10
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    7,853

    Default Re: RPM failed: Can't exec 'rpm' (No such file or directory)

    Assuming you're using some console app other than Xterm,

    When you ran
    Code:
    su
    And entered your password,
    Did the font color in your console change to red, or did it remain the same as before?
    A red font color is confirmation that you've successfully elevated to root permissions.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •