Results 1 to 8 of 8

Thread: Network-Manager not starting on boot

  1. #1

    Default Network-Manager not starting on boot

    Hi

    I've just installed leap 42.3 and I'm having a few issues with starting the network service on boot with a RTL8188SU usb card. It starts fine if I use wicked. However, to use the nm-applet I always have to reconfigure the network in yast. Any ideas? I also have to launch nm-applet manually.

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Network-Manager not starting on boot

    First, which desktop?

    ... but once you set the system network to be managed by Network Manager in Yast, you then do no further setup of networks in Yast. Subsequent setups are done in Network Manager through the applet (that should be) on the panel. Depending on which desktop, we might be able to tell you how to add it to the panel.

    As for having the network start at boot with Network Manager, when you edit a connection in Network Manager, you will find in the dialogues a checkbox to Automatically Connect and a checkbox for "All Users may connect ..." You need to check both of these, and since this then makes the connection a system-wide one, you will be asked for the root password to save the changes.
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  3. #3

    Default Re: Network-Manager not starting on boot

    Quote Originally Posted by Fraser_Bell View Post
    First, which desktop?

    ... but once you set the system network to be managed by Network Manager in Yast, you then do no further setup of networks in Yast. Subsequent setups are done in Network Manager through the applet (that should be) on the panel. Depending on which desktop, we might be able to tell you how to add it to the panel.

    As for having the network start at boot with Network Manager, when you edit a connection in Network Manager, you will find in the dialogues a checkbox to Automatically Connect and a checkbox for "All Users may connect ..." You need to check both of these, and since this then makes the connection a system-wide one, you will be asked for the root password to save the changes.

    Hi

    Yes all those steps were done. My desktop is a home build one using a Gigabyte Z68MA-D2H-B3 motherboard. output of lshw -short below. I think the issue is related to the wireless usb card, which uses the r8712u module. This isn't being loaded on boot but can be manually modprobed.

    system Z68MA-D2H-B3
    /0 bus Z68MA-D2H-B3
    /0/0 memory 128KiB BIOS
    /0/4 processor Intel(R) Core(TM) i5-2500K CP
    /0/4/a memory 64KiB L1 cache
    /0/4/b memory 6MiB L2 cache
    /0/17 memory 16GiB System Memory
    /0/17/0 memory 4GiB DIMMProject-Id-Version:
    /0/17/1 memory 4GiB DIMMProject-Id-Version:
    /0/17/2 memory 4GiB DIMMProject-Id-Version:
    /0/17/3 memory 4GiB DIMMProject-Id-Version:
    /0/100 bridge 2nd Generation Core Processor
    /0/100/2 display 2nd Generation Core Processor
    /0/100/16 communication 6 Series/C200 Series Chipset
    /0/100/1a bus 6 Series/C200 Series Chipset
    /0/100/1a/1 usb1 bus EHCI Host Controller
    /0/100/1a/1/1 bus Integrated Rate Matching Hub
    /0/100/1a/1/1/2 input USB Multimedia Keyboard
    /0/100/1b multimedia 6 Series/C200 Series Chipset
    /0/100/1c bridge 6 Series/C200 Series Chipset
    /0/100/1c.6 bridge 6 Series/C200 Series Chipset
    /0/100/1c.6/0 enp2s0 network RTL8111/8168/8411 PCI Express
    /0/100/1c.7 bridge 6 Series/C200 Series Chipset
    /0/100/1c.7/0 bus EJ168 USB 3.0 Host Controller
    /0/100/1c.7/0/0 usb3 bus xHCI Host Controller
    /0/100/1c.7/0/0/1 input USB Optical Mouse
    /0/100/1c.7/0/0/2 multimedia Webcam C270
    /0/100/1c.7/0/1 usb4 bus xHCI Host Controller
    /0/100/1d bus 6 Series/C200 Series Chipset
    /0/100/1d/1 usb2 bus EHCI Host Controller
    /0/100/1d/1/1 bus Integrated Rate Matching Hub
    /0/100/1d/1/1/1 generic 11n USB Adapter
    /0/100/1e bridge 82801 PCI Bridge
    /0/100/1f bridge Z68 Express Chipset Family LP
    /0/100/1f.2 storage 6 Series/C200 Series Chipset
    /0/100/1f.3 bus 6 Series/C200 Series Chipset
    /0/100/1f.5 storage 6 Series/C200 Series Chipset
    /0/1 scsi0 storage
    /0/1/0.0.0 /dev/sda disk 1TB WDC WD1002FAEX-0
    /0/1/0.0.0/1 /dev/sda1 volume 350MiB Windows NTFS volume
    /0/1/0.0.0/2 /dev/sda2 volume 930GiB Windows NTFS volume
    /0/1/0.0.0/3 /dev/sda3 volume 450MiB Windows NTFS volume
    /0/1/0.1.0 /dev/cdrom disk iHAS124 B
    /0/2 scsi1 storage
    /0/2/0.0.0 /dev/sdb disk 750GB SAMSUNG HD753LJ
    /0/2/0.0.0/1 /dev/sdb1 volume 488GiB Windows NTFS volume
    /0/2/0.0.0/2 /dev/sdb2 volume 210GiB EXT4 volume
    /0/2/0.1.0 /dev/sdc disk 750GB SAMSUNG HD753LJ
    /0/2/0.1.0/1 /dev/sdc1 volume 454GiB Windows NTFS volume
    /0/2/0.1.0/2 /dev/sdc2 volume 244GiB Extended partition
    /0/2/0.1.0/2/5 /dev/sdc5 volume 15GiB Linux swap / Solaris pa
    /0/2/0.1.0/2/6 /dev/sdc6 volume 228GiB Linux filesystem parti
    /1 wlx0014d1d2d5c0 network Wireless interface

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,033

    Default Re: Network-Manager not starting on boot

    Quote Originally Posted by Fraser_Bell View Post
    First, which desktop?
    Was referring to the desktop environment you're using. KDE, Gnome, Xfce, etc. (as opposed to your desktop hardware.)
    Regards, Paul

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Network-Manager not starting on boot

    I really doubt that you've enabled Network Manager to manage your networking.

    YaST > System > Network Settings > Global Tab

    Top dropdown,
    You need to change to "Network Manager Service"

    Otherwise,
    You're still using Wicked which can only remember one network connection setting at a time.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6

    Default Re: Network-Manager not starting on boot

    [QUOTE=tannington;2836976]Was referring to the desktop environment you're using. KDE, Gnome, Xfce, etc. (as opposed to your desktop hardware.)[/QU


    Ah apologies, it's Gnome

  7. #7

    Default Re: Network-Manager not starting on boot

    Quote Originally Posted by tsu2 View Post
    I really doubt that you've enabled Network Manager to manage your networking.

    YaST > System > Network Settings > Global Tab

    Top dropdown,
    You need to change to "Network Manager Service"

    Otherwise,
    You're still using Wicked which can only remember one network connection setting at a time.

    TSU

    Don't doubt, it was done

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,708
    Blog Entries
    1

    Default Re: Network-Manager not starting on boot

    Based on your comment about the wireless driver...
    I think the issue is related to the wireless usb card, which uses the r8712u module. This isn't being loaded on boot but can be manually modprobed.
    ...it's not a NetworkManager issue. In any case you can verify that all is well with NM using....

    Code:
    sudo systemctl status NetworkManager
    To get a handle on what is happening with the driver at boot run
    Code:
    dmesg|egrep "r8712u|firmware"
    Last edited by deano_ferrari; 06-Sep-2017 at 13:52.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •