Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Annoying LibreOffice problem

Hybrid View

  1. #1

    Default Annoying LibreOffice problem

    The LibreOffice version from the repos can't load java-based extensions. This is particularly annoying since I am rather reliant on zotero. The other extension affected is LanguageTool. I have ticked the java-environment in settings (Oracle 1.8.0), but any attempt to activate either extension results in a Java-loader error. As a temporary fix, I have installed LibreOffice 5.4.1.2 from libreoffice.org. However, whenever I run zypper dup --no-allow-vendor-change, I end up with the faulty libreoffice version again.

    A quick google search seems to suggest that I am not the only one with this problem. Is there anything I can do to solve it without the need to install versions of LibreOffice from suppliers other than Opensuse?

  2. #2

    Default Re: Annoying LibreOffice problem

    Quote Originally Posted by eddiekls View Post
    The LibreOffice version from the repos can't load java-based extensions. This is particularly annoying since I am rather reliant on zotero. The other extension affected is LanguageTool. I have ticked the java-environment in settings (Oracle 1.8.0), but any attempt to activate either extension results in a Java-loader error. As a temporary fix, I have installed LibreOffice 5.4.1.2 from libreoffice.org. However, whenever I run zypper dup --no-allow-vendor-change, I end up with the faulty libreoffice version again.

    A quick google search seems to suggest that I am not the only one with this problem. Is there anything I can do to solve it without the need to install versions of LibreOffice from suppliers other than Opensuse?
    I have tried installing an updated Opensuse-Libreoffice (4.2.1 from Factory), but still no luck. The error messages are:

    Code:
    javaloader error - could not find class com/sun/star/comp/loader/JavaLoader
    and then

    Code:
    (com.sun.star.uno.RuntimeException) { { Message = "javaloader error - could not find class com/sun/star/comp/loader/JavaLoader", Context = (com.sun.star.uno.XInterface) @0 } }
    I am back to LibreOffices packages, which work perfectly well. Still, this is rather annoying.

  3. #3

    Default Re: Annoying LibreOffice problem getting more anoying

    Quote Originally Posted by eddiekls View Post
    I have tried installing an updated Opensuse-Libreoffice (4.2.1 from Factory), but still no luck. The error messages are:

    Code:
    javaloader error - could not find class com/sun/star/comp/loader/JavaLoader
    and then

    Code:
    (com.sun.star.uno.RuntimeException) { { Message = "javaloader error - could not find class com/sun/star/comp/loader/JavaLoader", Context = (com.sun.star.uno.XInterface) @0 } }
    I am back to LibreOffices packages, which work perfectly well. Still, this is rather annoying.
    The saga continues: How on earth can I stop zypper from re-installing libreoffice every time I perform a
    Code:
    zypper dup
    or
    Code:
    zypper dup --no-allow-vendor-change
    ?

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Annoying LibreOffice problem

    TW is rolling ie most packages update because each dup is a no OS build.

    To the problem have you installed Java??

  5. #5

    Default Re: Annoying LibreOffice problem

    Quote Originally Posted by gogalthorp View Post
    TW is rolling ie most packages update because each dup is a no OS build.

    To the problem have you installed Java??
    Yes, Java is installed, recognised and ticed. Otherwise, the extensions wouldn't work with LibreOffice Org's packages either. I am using Oracle 1.8.0-131.

  6. #6
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,332

    Default Re: Annoying LibreOffice problem getting more anoying

    Quote Originally Posted by eddiekls View Post
    ... How on earth can I stop zypper from re-installing libreoffice every time I perform a ...
    Lock the packages perhaps...

    (with root privileges)

    Code:
    zypper al <package name>
    To check which packages are locked

    Code:
    zypper ll
    To remove a lock

    Code:
    zypper rl <package name>
    or use yast2 if you prefer the gui approach...

    http://paste.opensuse.org/view/raw/1d7fc1f2
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191211) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  7. #7

    Default Re: Annoying LibreOffice problem getting more anoying

    Quote Originally Posted by tannington View Post
    Lock the packages perhaps...

    (with root privileges)

    Code:
    zypper al <package name>
    To check which packages are locked

    Code:
    zypper ll
    To remove a lock

    Code:
    zypper rl <package name>
    or use yast2 if you prefer the gui approach...

    http://paste.opensuse.org/view/raw/1d7fc1f2
    Thanks, locking the packages works! Now I just need to wait for a fix to the java-problem.

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,332

    Default Re: Annoying LibreOffice problem getting more anoying

    Quote Originally Posted by eddiekls View Post
    Now I just need to wait for a fix to the java-problem.
    I don't know where your problem lies, ie, libreoffice, java, or openSUSE

    It might be worth asking on the libreoffice forum, maybe someone there can shed light on the problem, or better still offer a solution

    https://forum.openoffice.org/en/foru...orum.php?f=101

    (Don't let the URL fool you, the site is for all *office variants, although I must say the libreoffice section doesn't look too active)
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191211) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  9. #9

    Default Re: Annoying LibreOffice problem getting more anoying

    Quote Originally Posted by tannington View Post
    I don't know where your problem lies, ie, libreoffice, java, or openSUSE

    It might be worth asking on the libreoffice forum, maybe someone there can shed light on the problem, or better still offer a solution

    https://forum.openoffice.org/en/foru...orum.php?f=101

    (Don't let the URL fool you, the site is for all *office variants, although I must say the libreoffice section doesn't look too active)
    I believe the problem lies with OpenSuse. I have tested other versions of Libreoffice downloaded from libreoffice.org as well as a snap pack from Ubuntu's snap store, all integrated the extensions well. I then re-installed an earlier OpenSuse version, and that had no problem either. The installed Java-version has always remained unchanged. It seems as if the fault has first been re-introduced (OpenSuse packages had the problem in the past, if I remember right it was around 4.0 or 4.1) with the release of 5.3 and exists since. Unfortunately, I don't know how to get in touch with the packager(s).

  10. #10
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,332

    Default Re: Annoying LibreOffice problem getting more anoying

    Quote Originally Posted by eddiekls View Post
    ... Unfortunately, I don't know how to get in touch with the packager(s).
    Report as a bug on openSUSE bugzilla

    https://bugzilla.opensuse.org/enter_...ation=openSUSE

    it uses the same login credentials as this forum, so no need to create an account.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191211) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •