Results 1 to 5 of 5

Thread: Official Nvidia drivers with Prime

  1. #1

    Default Official Nvidia drivers with Prime

    Hello.

    I'm not good with hardware but it came to my attention that the reason for me not being able to play games on Suse is the fact that I'm using my integrated Intel card instead of my Nvidia.
    I know I'm using Intel because I ran:
    Code:
    $ glxinfo | grep -i vendor
    server glx vendor string: SGI
    client glx vendor string: Mesa Project and SGI
        Vendor: Intel Open Source Technology Center (0x8086)
    OpenGL vendor string: Intel Open Source Technology Center
    So, I read that there has recently been released official Nvidia drivers in a repo.
    I installed them and everything is the same - OS still think I should use Intel instead of Nvidia (Windows somehow uses Nvidia I guess).
    I don't have any option in BIOS to choose the graphics card so I read and I found out about Prime being able to switch between cards.

    I found this package, installed it and followed the instructions without installing mentioned Nvidia drivers (since I now have the official ones) from nvidia.ymp.
    But when I reboot, I have a black screen and in order to use Suse again I have to press ctrl+alt+F1 to log in without graphics, run command "prime-select intel" and reboot again.

    Any idea how can I make Prime work with the official drivers and not the community ones from package's page?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,285

    Default Re: Official Nvidia drivers with Prime

    No use the community drivers. First uninstall the regular driver

    If this is a note book it probably an Optimus setup

    Here is another option
    https://en.opensuse.org/SDB:NVIDIA_Bumblebee

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,237

    Default Re: Official Nvidia drivers with Prime

    Hi, please be aware that suse-prime has not been updated for more than one year now and might not work with current Tumbleweed.
    You might also try dri-prime with the open source Nouveau driver, see hints in this thread https://forums.opensuse.org/showthre...Optimus-laptop
    I once tried installing the Nvidia driver "the hard way" on an Optimus laptop, but it was not possible to switch back to the Intel driver to save power afterwards. Also I had to use Lightdm instead of sddm or gdm, with a custom configuration.
    As advised by gogalthorp, Bumblebee is a viable alternative for general use, but might not yield the performance gamers usually seek.
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  4. #4

    Default Re: Official Nvidia drivers with Prime

    Quote Originally Posted by kokosek View Post
    I found this package, installed it and followed the instructions without installing mentioned Nvidia drivers (since I now have the official ones) from nvidia.ymp.
    But when I reboot, I have a black screen and in order to use Suse again I have to press ctrl+alt+F1 to log in without graphics, run command "prime-select intel" and reboot again.

    Any idea how can I make Prime work with the official drivers and not the community ones from package's page?
    Hello kokosek,

    for me, nvidia-prime works flawlessly on a Leap 42.2 installation. I use a NVIDIA GT650M and the newest driver (384.90).
    Short and sweet, find my notes how I installed it:

    Step 1:
    * first bring your system to the latest version incl all updates
    * remove any bumblebee packages and settings, if installed
    * install latest nvidia-driver and the package suse-prime (current version for Leap 42.2 = suse-prime-0.1-29.2)
    * insert extra setting in ”/etc/X11/xdm/Xsetup” according to the instructions for the package suse-prime

    Step 2:
    * change into init 3 mode
    * run "prime-select nvidia" to activate the NVIDIA-driver and to fully switch on the NVIDIA card
    * create a new xorg.conf automatically, to do that run "nvidia-xconfig"
    * Change into init 5 mode / or type "startx"
    * enjoy !


    !! important, if there is a new NVIDIA-driver available:
    * change into init 3 mode
    * change to the intel card before updating via “prime-select intel"
    * Change into init 5 mode / or type "startx" and update the nvidia-drivers
    --> now repeat Step 2 (see above)


    The instructions base on the How-To from user "Brunolab" here:
    https://forums.opensuse.org/showthre...d-of-bumblebee
    Thanks a lot, Brunolab !


    In my opinion you have a broken "xorg.conf" file, which still refers to the intel driver.
    Try to follow the steps indicated above. I hope it works out.

    Cheers

  5. #5
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,237

    Default Re: Official Nvidia drivers with Prime

    Quote Originally Posted by Bergamo_1983 View Post
    Hello kokosek,

    for me, nvidia-prime works flawlessly on a Leap 42.2 installation. I use a NVIDIA GT650M and the newest driver (384.90).
    Readers please be careful: suse-prime works on Leap 42.2 but NOT on current Tumbleweed; once TW required suse-prime-alt but that package has not been updated for months AFAIK.
    Also, something might have changed in Leap 42.3 too, I didn't check it myself yet.
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •