Results 1 to 4 of 4

Thread: KDE Virtual Terminal Encoding Problem

  1. #1

    Default KDE Virtual Terminal Encoding Problem

    Hi...

    I'm having a problem that looks like an encoding issue with kde on Tumbleweed but I can't say with certainty. Using both Konsole and Yakuake when I launch ncmpcpp to connect to MPD, the virtual terminals look like the attached image: https://i.imgur.com/eYSeemP.png. Notice the question mark like characters at the top left and bottom left of the screen!! Those are supposed to be line characters. This issue began a few weeks ago and has not gone away with zypper updates.

    When I use ncmpcpp using a "real" terminal (Ctrl+Alt+Fnumber) I don't have this problem. Thus I tend to believe it's either a kde issue or display issue. All of my encoding settings seem fine. Yast & KDE's system settings have language set correctly (American English). Yast and Konsole use character encoding UTF-8 as does ncmpcpp and mpd.

    The only other terminal application that I see a similar issue with so far is nano. https://i.imgur.com/MKaUfYg.png Notice how the key-bindings on the bottom of the screen are NOT aligned as they usually are (^J Justify is not centered). Same with "M-W WhereIs Next".

    Any suggestions would be appreciated.

    Code:
    labouie@Tumbleweed:~> locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=

  2. #2

    Default Re: KDE Virtual Terminal Encoding Problem

    I found the solution to the issues in the mailing list. Within Konsole and Yakuake TERM was set to "TERM=xterm-256color". Per advice from the mailing list in Konsole go to Settings -> Edit Current Profile -> General tab -> Environment button. Changed it to "TERM=xterm-xfree86". Do the same for Yakuake.

    https://lists.opensuse.org/opensuse-.../msg00529.html

  3. #3

    Default Re: KDE Virtual Terminal Encoding Problem

    I just realized that after making my update and upon shutting down of Konsole/Yakuake and relaunching, my directories were no longer in color when typing "ls". Thus I needed to edit file /etc/DIR_COLORS and add "TERM xterm-xfree86" to the list of values to regain directory color.

    Hope this helps someone.

  4. #4

    Default Re: KDE Virtual Terminal Encoding Problem

    It's a bug in the terminfo-base package and affects all terminal emulators, not just Konsole.
    https://bugzilla.opensuse.org/show_bug.cgi?id=1054448

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •