Results 1 to 7 of 7

Thread: No network when booting LXQt

  1. #1
    Join Date
    Sep 2017
    Location
    Blue Mountains, Australia
    Posts
    2

    Default No network when booting LXQt

    My Leap 42.3 works fine with KDE, internet via WiFi and all.
    I did a 1 click install of LXQt. On logging into LXQt the basic desktop works OK but there is no network of any kind. I tried to define a WiFi connection but can't enter any data, not even as SuperUser. How do I fix this?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,366
    Blog Entries
    2

    Default Re: No network when booting LXQt

    Have you enabled Network Manager
    YaST > Network Settings > Global Options tab
    or
    Preferences > Network Settings > Global Options tab

    Then you should be able to create a WiFi network connection.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,452

    Default Re: No network when booting LXQt

    Also, if you want to configure the network once it is up and running, log in to KDE. It will offer more configuration options which will then be honoured in LXQt.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,366
    Blog Entries
    2

    Default Re: No network when booting LXQt

    Quote Originally Posted by john_hudson View Post
    Also, if you want to configure the network once it is up and running, log in to KDE. It will offer more configuration options which will then be honoured in LXQt.
    I have not noticed options, but yes configuring is organized and displayed differently.
    So, depending on personal preferences a different Desktop can make a personal difference.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5
    Join Date
    Sep 2017
    Location
    Blue Mountains, Australia
    Posts
    2

    Default Re: No network when booting LXQt

    Quote Originally Posted by tsu2 View Post
    Have you enabled Network Manager
    YaST > Network Settings > Global Options tab
    or
    Preferences > Network Settings > Global Options tab

    Then you should be able to create a WiFi network connection.

    TSU
    Thanks, Tsu and John,
    I found what went wrong.
    in the Preferences > Network Settings > Global options tab you have the choice to select either "Wicked Service" or "Network Manager Service".
    I selected Wicked Service with an automatic start at boot. This works fine with KDE but doesn't work with LXQt which demands the Network Manager. When I select "Network Manager Service" this works fine with LXQT.

    As for John, yes I can see KDE may be a bit more versatile. It's just that I've been away from SUSE for more than 10 years. For the last 6 years I've been using DEBIAN with an LXDE desktop so I thought I might be a bit more at home with LXQT.
    I'll stay with KDE for a while and see how it feels!
    Ausmuso

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,739
    Blog Entries
    3

    Default Re: No network when booting LXQt

    Quote Originally Posted by Ausmuso View Post
    This works fine with KDE but doesn't work with LXQt which demands the Network Manager. When I select "Network Manager Service" this works fine with LXQT.
    LXQt doesn't really "demand" NetworkManager. I have it working fine with "wicked".

    Yes, sure, there's an applet in the tray that says the network is disconnected. I just ignore that when running LXQt, and everything continues to work (including network connections).

    XFCE does the same thing. I think I can tell it to not run the network applet. But I leave it running, so that it will be there if I ever switch from "wicked" to "NetworkManager".
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,366
    Blog Entries
    2

    Default Re: No network when booting LXQt

    Quote Originally Posted by nrickert View Post
    LXQt doesn't really "demand" NetworkManager. I have it working fine with "wicked".

    Yes, sure, there's an applet in the tray that says the network is disconnected. I just ignore that when running LXQt, and everything continues to work (including network connections).

    XFCE does the same thing. I think I can tell it to not run the network applet. But I leave it running, so that it will be there if I ever switch from "wicked" to "NetworkManager".
    From what I've seen,
    When networking is managed by Wicked, there are two network applets (maybe they should use different icons to lessen confusion?).
    One always displays network properties and run time data,
    The other as said says "Disconnected."

    This second "Disconnected" applet is because by default Network Manager is installed (and this second applet is part of Network Manager) although disabled. Maybe sometime someone would fix this... I assume that it might not be too difficult to for example write a tweak to "disable" in the Unit file that removes the applet from the tray, and adds the applet if "enabled."

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •