Hi guys,

I come from ubuntu and I am having lots of problems with openSuse after the installation.

I am using Win10 and OpenSuse in two different HDDs. When I selected OpenSuse at boot for the first time, I got non-graphical interface (I must say also that couldn't do the installation in graphical mode due to the nvidia drivers).

Searching a lot I did:

  • Tried to startx but an error came out
  • modified permissions.local like this


/etc/permissions.local
Code:
#
# /etc/permissions.local
#
# After editing this file run
#	chkstat --system --set
# to apply the changes.
#
# This file is used by chkstat (and indirectly by various RPM package scripts)
# to check or set the modes and ownerships of files and directories in
# the installation.
#
# In particular, this file will not be touched during an upgrade of the
# installation. It is designed to be a placeholder for local
# additions by the administrator of the system to reflect filemodes
# of locally installed packages or to override file permissions as
# shipped with the distribution.
#
# Format:
# <file> <owner>:<group> <permission>
#
# Please see the file /etc/permissions for general usage hints of the
# /etc/permissions* files.
# Please remember that logfiles might be modified by the logfile
# rotation facilities (e.g. logrotate) so settings entered here might
# be overridden. Also devices files (/dev/*) are not static but
# managed via udev so this file can't be used to modify device
# permissions either.
#


#
# suexec is only secure if the document root doesn't contain files
# writeable by wwwrun. Make sure you have a safe server setup
# before setting the setuid bit! See also
# https://bugzilla.novell.com/show_bug.cgi?id=263789
# http://httpd.apache.org/docs/trunk/suexec.html
#
#/usr/sbin/suexec2            root:root       4755
#/usr/sbin/suexec             root:root       4755


# setuid bit on Xorg is only needed if no display manager, ie startx
# is used. Beware of CVE-2010-2240.
#

###MODIFIED THIS####
/usr/bin/Xorg                 root:root       4711
  • Then I created new xorg.conf with
    Code:
    X -configure
    command, and
    Code:
    cp /root/xorg.conf.new /etc/X11/xorg.conf
Code:

  • I set vesa as driver in this file


xorg.conf
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 384.59  (buildmeister@swio-display-x64-rhel04-01)  Thu Jul 20 01:03:28 PDT 2017




Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection


Section "Files"
    ModulePath      "/usr/lib64/xorg/modules"
    FontPath        "/usr/share/fonts/misc:unscaled"
    FontPath        "/usr/share/fonts/Type1/"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/ghostscript/"
    FontPath        "/usr/share/fonts/cyrillic:unscaled"
    FontPath        "/usr/share/fonts/misc/sgi:unscaled"
    FontPath        "/usr/share/fonts/truetype/"
    FontPath        "built-ins"
EndSection


Section "Module"
    Load           "glx"
    Load           "vnc"
EndSection


Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection


Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection


Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection


Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection


Section "Device"


        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "VideoKey"           	# <i>
        #Option     "WrappedFB"          	# [<bool>]
        #Option     "GLXVBlank"          	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "PageFlip"           	# [<bool>]
        #Option     "SwapLimit"          	# <i>
        #Option     "AsyncUTSDFS"        	# [<bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "DRI"                	# <i>
    Identifier     "Card0"
    Driver         "vesa"
    BusID          "PCI:1:0:0"
EndSection


Section "Device"


        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "DefaultRefresh"     	# [<bool>]
        #Option     "ModeSetClearScreen" 	# [<bool>]
    Identifier     "Card1"
    Driver         "vesa"
    BusID          "PCI:0:2:0"
EndSection


Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       1
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection


Section "Screen"
    Identifier     "Screen1"
    Device         "Card1"
    Monitor        "Monitor1"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       1
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

  • Then I did
    Code:
    startx
    and It worked (but with bad screen resolution)
  • I tried to install NVIDIA drivers from YAST but lots of error came
  • Finally I downloaded NVIDIA drivers from their webpage, and isntalled manually. I got my GUI session ok, but when did
    Code:
    zypper update
    said that some services will be removed or something like that.
  • When reboot I was again in non-graphical session and now can't startx nor NVIDIA (also tried to reinstall the nvidia .run from console and nothing...)


NVIDIA GTX970 (2 monitors)

Xorg.0.log
Code:
[   463.981] 
X.Org X Server 1.18.3
Release Date: 2016-04-04
[   463.981] X Protocol Version 11, Revision 0
[   463.982] Build Operating System: openSUSE SUSE LINUX
[   463.982] Current Operating System: Linux linux-vya0 4.4.79-19-default #1 SMP Thu Aug 10 20:28:47 UTC 2017 (2dd03e8) x86_64
[   463.982] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.79-19-default root=UUID=6cbab775-46bc-4254-b1ef-a8e82c37d543 ro nouveau.modeset=0 resume=/dev/sda2 splash=silent quiet showopts
[   463.983] Build Date: 18 July 2017  08:19:38AM
[   463.983]  
[   463.983] Current version of pixman: 0.34.0
[   463.984] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   463.984] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   463.986] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Sep  3 12:14:06 2017
[   463.986] (II) Loader magic: 0x80fce0
[   463.986] (II) Module ABI versions:
[   463.986] 	X.Org ANSI C Emulation: 0.4
[   463.986] 	X.Org Video Driver: 20.0
[   463.986] 	X.Org XInput driver : 22.1
[   463.986] 	X.Org Server Extension : 9.0
[   463.987] (--) using VT number 2


[   463.987] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   463.987] (II) xfree86: Adding drm device (/dev/dri/card0)
[   463.987] (II) xfree86: Adding drm device (/dev/dri/card1)
[   463.988] (--) PCI: (0:0:2:0) 8086:0412:1458:d000 rev 6, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[   463.989] (--) PCI:*(0:1:0:0) 10de:13c2:1458:3683 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[   463.989] List of video drivers:
[   463.990] 	nvidia
[   463.990] 	vesa
[   463.990] 	fbdev
[   463.991] 	modesetting
[   463.991] (II) LoadModule: "nvidia"
[   463.991] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[   463.991] (II) Module nvidia: vendor="NVIDIA Corporation"
[   463.991] 	compiled for 4.0.2, module version = 1.0.0
[   463.991] 	Module class: X.Org Video Driver
[   463.991] (II) LoadModule: "vesa"
[   463.991] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[   463.991] (II) Module vesa: vendor="X.Org Foundation"
[   463.991] 	compiled for 1.18.3, module version = 2.3.4
[   463.991] 	Module class: X.Org Video Driver
[   463.991] 	ABI class: X.Org Video Driver, version 20.0
[   463.991] (II) LoadModule: "fbdev"
[   463.991] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[   463.991] (II) Module fbdev: vendor="X.Org Foundation"
[   463.991] 	compiled for 1.18.3, module version = 0.4.4
[   463.991] 	Module class: X.Org Video Driver
[   463.991] 	ABI class: X.Org Video Driver, version 20.0
[   463.991] (II) LoadModule: "modesetting"
[   463.992] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[   463.992] (II) Module modesetting: vendor="X.Org Foundation"
[   463.992] 	compiled for 1.18.3, module version = 1.18.3
[   463.992] 	Module class: X.Org Video Driver
[   463.992] 	ABI class: X.Org Video Driver, version 20.0
[   463.992] (II) NVIDIA dlloader X Driver  384.59  Wed Jul 19 23:14:49 PDT 2017
[   463.992] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   463.992] (II) VESA: driver for VESA chipsets: vesa
[   463.992] (II) FBDEV: driver for framebuffer: fbdev
[   463.992] (II) modeset(G0): using drv /dev/dri/card1
[   463.992] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   464.112] (++) Using config file: "/root/xorg.conf.new"
[   464.112] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   464.113] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   464.113] (==) ServerLayout "X.org Configured"
[   464.113] (**) |-->Screen "Screen0" (0)
[   464.113] (**) |   |-->Monitor "Monitor0"
[   464.113] (**) |   |-->Device "Card0"
[   464.113] (**) |-->Screen "Screen1" (1)
[   464.113] (**) |   |-->Monitor "Monitor1"
[   464.113] (**) |   |-->Device "Card1"
[   464.113] (**) |-->Input Device "Mouse0"
[   464.113] (**) |-->Input Device "Keyboard0"
[   464.113] (==) Automatically adding devices
[   464.113] (==) Automatically enabling devices
[   464.113] (==) Automatically adding GPU devices
[   464.113] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   464.113] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
[   464.113] 	Entry deleted from font path.
[   464.113] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
[   464.113] 	Entry deleted from font path.
[   464.113] (**) FontPath set to:
	/usr/share/fonts/misc:unscaled,
	/usr/share/fonts/Type1/,
	/usr/share/fonts/100dpi:unscaled,
	/usr/share/fonts/75dpi:unscaled,
	/usr/share/fonts/ghostscript/,
	/usr/share/fonts/cyrillic:unscaled,
	/usr/share/fonts/truetype/,
	built-ins,
	/usr/share/fonts/misc:unscaled,
	/usr/share/fonts/Type1/,
	/usr/share/fonts/100dpi:unscaled,
	/usr/share/fonts/75dpi:unscaled,
	/usr/share/fonts/ghostscript/,
	/usr/share/fonts/cyrillic:unscaled,
	/usr/share/fonts/truetype/,
	built-ins
[   464.113] (**) ModulePath set to "/usr/lib64/xorg/modules"
[   464.113] (**) Extension "XFree86-DGA" is disabled
[   464.113] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   464.113] (WW) Disabling Mouse0
[   464.113] (WW) Disabling Keyboard0
[   464.113] (II) Loading sub module "fb"
[   464.113] (II) LoadModule: "fb"
[   464.113] (II) Loading /usr/lib64/xorg/modules/libfb.so
[   464.113] (II) Module fb: vendor="X.Org Foundation"
[   464.113] 	compiled for 1.18.3, module version = 1.0.0
[   464.113] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   464.113] (II) Loading sub module "wfb"
[   464.113] (II) LoadModule: "wfb"
[   464.113] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[   464.113] (II) Module wfb: vendor="X.Org Foundation"
[   464.113] 	compiled for 1.18.3, module version = 1.0.0
[   464.113] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   464.113] (II) Loading sub module "ramdac"
[   464.113] (II) LoadModule: "ramdac"
[   464.113] (II) Module "ramdac" already built-in
[   464.114] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[   464.114] (EE) NVIDIA:     system's kernel log for additional error messages and
[   464.114] (EE) NVIDIA:     consult the NVIDIA README for details.
[   464.114] (WW) Falling back to old probe method for vesa
[   464.114] Number of created screens does not match number of detected devices.
  Configuration failed.