Results 1 to 5 of 5

Thread: uninstalled texlive - but zypper dup wants to install it again

  1. #1

    Default uninstalled texlive - but zypper dup wants to install it again

    Hi,
    I removed all texlive-packages some days ago but now "zypper dup" wants to re-install it (> 2100 packages!!). I checked all dependencies => everything looks fine. No other package seems to depend on any texlive-package. I don't understand, why zypper wants to install these texlive-packages again. Does zypper remember/remain some informations about package-groups /-patterns?
    Can anyone help?
    Kind regards
    aki17

  2. #2
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: uninstalled texlive - but zypper dup wants to install it again

    Quote Originally Posted by aki17 View Post
    Hi,
    I removed all texlive-packages some days ago but now "zypper dup" wants to re-install it (> 2100 packages!!). I checked all dependencies => everything looks fine. No other package seems to depend on any texlive-package. I don't understand, why zypper wants to install these texlive-packages again. Does zypper remember/remain some informations about package-groups /-patterns?
    Can anyone help?
    Kind regards
    aki17
    Check if you have installed> ImageMagick-extra
    If you uninstall it and see that texlive disappears
    loyalty returns to those who practice it

  3. #3

    Default Re: uninstalled texlive - but zypper dup wants to install it again

    No, ImageMagick-extra is not installed.

    But I now discovered: The texlive-packages aren't required but recommended. If I run "zypper dup" with "--no-recommends" option, zypper works like expected and doesn't try to re-install these texlive-packages.
    Is there any way to find out, why zypper recommends these packages? Should I try to delete some caches / history or else?

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,822

    Default Re: uninstalled texlive - but zypper dup wants to install it again

    There is a set of "recommended packages" for an avarage openSUSE installation. Your packages seem to belong to those.

    In YaST > Software > Software Managment there is a tab Options and it has a menu item to ignore recommended packages. Check it and see if it helps.

    I do not know the zypper equivalent, but you can of course browse
    Code:
    man zypper
    for it.
    Henk van Velden

  5. #5
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: uninstalled texlive - but zypper dup wants to install it again

    I did a try; just block it
    -> texlive-gsftopk
    ->texlive-epstopdf
    ->texlive-cjk-gs-integrate
    loyalty returns to those who practice it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •