Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

  1. #11
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,148

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    I am not seeing this problem. Using the latest snapshot 31082017 with the packman rpm k3b-17.08.0-10.1.x86_64.rpm dated the 25th August.

    Now that the issue with mp3 has disappeared the separate codec rpm was dropped by packman in June as the codec element was meged (back) into the main rpm.

  2. #12

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    Quote Originally Posted by dth2 View Post
    Now that the issue with mp3 has disappeared the separate codec rpm was dropped by packman in June as the codec element was meged (back) into the main rpm.
    Actually that change was in November already. Since then there is no separate k3b-codecs package any more.
    From the package changelog:
    Code:
     * Wed Nov 30 2016 wbauer@tmo.at
    - Obsolete k3b-codecs, the additional codecs are part of the main
      package now
    And meanwhile, libmad and lame are in the standard Tumbleweed repo, so even the openSUSE package can provide mp3 support now.
    That change has only been submitted last week though and is not yet in TW:
    https://build.opensuse.org/request/show/519602

    As soon as this is accepted (and the next snapshot published), there is no need at all for the Packman package any more (on Tumbleweed, that is).

    Seems that Packman dropped their TW package a few days too soon though...
    Last edited by wolfi323; 04-Sep-2017 at 03:43.

  3. #13

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    Quote Originally Posted by I_A View Post
    I think that has to do with the fact that the k3b TW package version 17.04 is a kf5 app and there are some bugs to iron out while LEAP is still the kde4/Qt4 based 2.0.3
    Not at all.
    (well, there were indeed a few bugs, but unrelated to *missing* mp3 support... )

    edit it has nothing to do with kf5 it's an upstream bug related to transcode
    https://github.com/KDE/k3b/blob/master/ChangeLog
    it's fixed in 17.07 which hasn't been packaged for TW yet
    That transcode "bug" (support has been removed completely in 17.04) is fixed in openSUSE since June though.
    Last edited by wolfi323; 04-Sep-2017 at 03:48.

  4. #14

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    PS: if you urgently need mp3 support, you can install k3b from KDE:Applications (the devel project for Tumbleweed) for now, until the new package reaches the main repos. That does have mp3 support since last week.
    https://software.opensuse.org//download.html?project=KDE%3AApplications&package=k3b

    (I'd recommend to download and install that one package though and not add the full repo...)
    Last edited by wolfi323; 04-Sep-2017 at 03:52.

  5. #15
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,712

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    @wolfi323

    Thanks for the clarification.

    For the moment I'm using k3b 17.08.0-10.1 from the Leap 42.3 packman repository as that works OK with TW...
    Regards, Paul

    2x Tumbleweed (Snapshot: 20210106) KDE Plasma 5
    2x Leap 15.2 KDE Plasma 5

  6. #16
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    172

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    Latest version (17.08.0-2.1) from the tumbleweed repo is now working as expected.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •