Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

  1. #1
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,033

    Default K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    Did an install of TW (20170825) a couple of days ago on a new PC, currently in the process of setting it up.

    K3b is giving the "MP3 Audio Decoder plugin not found." message at startup.

    http://paste.opensuse.org/view/raw/5bd6d3bd

    If one looks at "Settings -> Configure K3b... -> Plugins" then both the "K3b MAD Decoder", and "K3b Lame MP3 Encoder" are missing.

    This is with:

    k3b 17.08.0-1.1
    libmad0 0.15.1b-1.1
    lame 3.99.5-1.1
    libmp3lame0 3.99.5-1.1

    all from http://download.opensuse.org/tumbleweed/repo/oss/

    So I'm not too sure why k3b thinks they're missing...


    Now, my usual recourse has been to install from Packman, http://ftp.gwdg.de/pub/linux/misc/pa...SE_Tumbleweed/ and do a vendor switch.

    However those packages as of yesterday and today (2017-09-01) are no longer present in the Packman repository.

    (Out of curiosity, I've just looked at Packman for 42.3 and the packages are still present there.)

    ... hmm
    Regards, Paul

  2. #2

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame droppedfrom packman?

    On Fri, 01 Sep 2017 14:06:01 +0000, tannington wrote:

    > Did an install of TW (20170825) a couple of days ago on a new PC,
    > currently in the process of setting it up.
    >
    > K3b is giving the "MP3 Audio Decoder plugin not found." message at
    > startup.
    >
    > http://paste.opensuse.org/view/raw/5bd6d3bd
    >
    > If one looks at "Settings -> Configure K3b... -> Plugins" then both the
    > "K3b MAD Decoder", and "K3b Lame MP3 Encoder" are missing.
    >
    > This is with:
    >
    > k3b 17.08.0-1.1 libmad0 0.15.1b-1.1 lame 3.99.5-1.1 libmp3lame0
    > 3.99.5-1.1
    >
    > all from http://download.opensuse.org/tumbleweed/repo/oss/
    >
    > So I'm not too sure why k3b thinks they're missing...
    >
    >
    > Now, my usual recourse has been to install from Packman,
    > http://ftp.gwdg.de/pub/linux/misc/pa...SE_Tumbleweed/ and
    > do a vendor switch.
    >
    > However those packages as of yesterday and today (2017-09-01) are no
    > longer present in the Packman repository.
    >
    > (Out of curiosity, I've just looked at Packman for 42.3 and the packages
    > are still present there.)
    >
    > ... hmm


    Just checked Packman and k3b is not available so (yet). I had k3b from
    Packman which got switched to the main TW repo yesterday and mp3 was
    never available in that version. Joys of the bleeding wedge. Should be
    available from packman w/ the mp3 codec in the future (shortly, I
    hope...).

  3. #3

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    You are not the only one with problems with k3b from packman repo.
    If I'm trying an zypper dup on Tumbleweed ,this is what I get:
    Code:
    Reading installed packages...
    Computing distribution upgrade...
    5 Problems:
    Problem: problem with installed package k3b-17.04.3-12.1.x86_64
    Problem: problem with installed package lame-3.99.5-1016.9.x86_64
    Problem: problem with installed package libmad0-0.15.1b-1.31.x86_64
    Problem: problem with installed package libmp3lame0-3.99.5-1016.9.x86_64
    Problem: problem with installed package libtwolame0-0.3.13-3.3.x86_64
    
    Problem: problem with installed package k3b-17.04.3-12.1.x86_64
     Solution 1: install k3b-17.08.0-1.1.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
    
    Choose the above solution using '1' or skip, retry or cancel [1/s/r/c] (c):
    Cheers

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,033

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    Quote Originally Posted by alessandros View Post
    You are not the only one with problems with k3b from packman repo.
    If I'm trying an zypper dup on Tumbleweed ,this is what I get:
    If you don't want to lose the "MP3 Audio Decoder plugin" the packman versions provide, then I'd lock those packages for the moment.

    OTOH... if you've already allowed the vendor change...
    Regards, Paul

  5. #5
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,033

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame droppedfrom packman?

    Quote Originally Posted by whonea View Post
    ... Should be available from packman w/ the mp3 codec in the future (shortly, I hope...).
    Not wishing to appear to doubt you

    ... is that wishful thinking, or a known fact? I'm not that familiar with the way in which the packman repo is maintained.
    Regards, Paul

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    the mp3 patent has ended and most mp3 based codecs and apps can be found in the OSS repo and are no longer being maintained by packman
    https://software.opensuse.org/package/lame
    as you can see a fully functioning lame is in the main TW repo so you should go with option 1 do a vendor change for k3b from packman to the openSuse repo

  7. #7
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    185

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    Quote Originally Posted by I_A View Post
    the mp3 patent has ended and most mp3 based codecs and apps can be found in the OSS repo and are no longer being maintained by packman
    https://software.opensuse.org/package/lame
    as you can see a fully functioning lame is in the main TW repo so you should go with option 1 do a vendor change for k3b from packman to the openSuse repo
    That version does not work. I just tried myself. K3B complains about the missing mp3 decoder, even than all necessary packages come from the Tumbleweed repo. The packman version (from 42.3) does work in Tumbleweed. For me this is a non-issue, I don't burn audio cds.

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    Quote Originally Posted by swannema View Post
    That version does not work. I just tried myself. K3B complains about the missing mp3 decoder, even than all necessary packages come from the Tumbleweed repo. The packman version (from 42.3) does work in Tumbleweed. For me this is a non-issue, I don't burn audio cds.
    I think that has to do with the fact that the k3b TW package version 17.04 is a kf5 app and there are some bugs to iron out while LEAP is still the kde4/Qt4 based 2.0.3


    edit it has nothing to do with kf5 it's an upstream bug related to transcode
    https://github.com/KDE/k3b/blob/master/ChangeLog
    it's fixed in 17.07 which hasn't been packaged for TW yet

  9. #9
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,033

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    Quote Originally Posted by I_A View Post
    edit it has nothing to do with kf5 it's an upstream bug related to transcode
    https://github.com/KDE/k3b/blob/master/ChangeLog
    it's fixed in 17.07 which hasn't been packaged for TW yet
    Hmm... Doesn't appear to be fixed. To quote part of my own initial post:

    If one looks at "Settings -> Configure K3b... -> Plugins" then both the "K3b MAD Decoder", and "K3b Lame MP3 Encoder" are missing.

    This is with:

    k3b 17.08.0-1.1
    libmad0 0.15.1b-1.1
    lame 3.99.5-1.1
    libmp3lame0 3.99.5-1.1

    all from http://download.opensuse.org/tumbleweed/repo/oss/
    ... that's from a TW install with snapshot 20170825
    Regards, Paul

  10. #10
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,033

    Default Re: K3b (OSS) Missing MP3 Codecs, and k3b/libmad/lame/liblame dropped from packman?

    As a brief follow up...

    To confirm the comment from "swannema"

    k3b 17.08.0-10.1 from the Leap 42.3 packman repository does indeed work with TW, providing full MP3 encode/decode.
    Regards, Paul

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •