Results 1 to 5 of 5

Thread: Cannot update 42.1; Problem connecting to a software origin

  1. #1

    Default Cannot update 42.1; Problem connecting to a software origin

    Greetings Linux gurus:

    For the last couple of weeks I've been getting a "Problem connecting to a software origin" error when I try to do an update. As per other posts, I ran zypper clean -a and then zypper ref -f, which resulted in the string of error messages below.

    If I paste the address http://download.opensuse.org/distrib.../repo/non-oss/ into my browser I get the following error:

    Resource is no longer available!

    The requested URL is no longer available on this server and there is no forwarding address. If you followed a link from a foreign page, please contact the author of this page.
    If you think this is a server error, please contact the webmaster.
    Error 404

    download.opensuse.org
    Fri Sep 1 03:24:24 2017
    Apache/2.2.34 (Linux/SUSE)

    I'm in Alberta, Canada, by the way. Is it past time for me to upgrade to 42.3? Thanks!

    Bill

    = = = = = = = = = = =

    Script started on Thu 31 Aug 2017 21:05:22 MDT
    7]2;bill@linux-qli6:~]1;linux-qli68bill@linux-qli6:~> zupp[K[K[Kypp[K[K[K[Ksudo zypper clean -a
    root's password:
    [22;27;39;49mAll repositories have been cleaned up.[0m
    7]2;bill@linux-qli6:~]1;linux-qli68bill@linux-qli6:~> zupp[K[K[Kypper ref -f
    [22;27;31;49mRoot privileges are required for refreshing system repositories.[0m
    7]2;bill@linux-qli6:~]1;linux-qli68bill@linux-qli6:~> sudo zypper ref -f
    [22;27;39;49mForcing raw metadata refresh[0m
    [2K
    Retrieving repository 'Non-oss' metadata ------------------------------------------------------------------------------------------------------------------------------------------[\]
    [22;27;31;49mFile '/media.1/media' not found on medium 'http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/'
    [0m
    [2K
    [1;39;49mAbort, retry, ignore? [1;39;49m[a[1;39;49m/r[1;39;49m/i[1;39;49m/?[1;39;49m shows all options] (a[1;39;49m)[0m[1;39;49m: [0m[0m[0m[0m[0m[0m[0mi
    [2K
    Retrieving repository 'Non-oss' metadata ......................................................................................................................................[[22;27;31;49merror[0m]
    [22;27;31;49mRepository 'Non-oss' is invalid.
    [http-download.opensuse.org-36a16bb1|http://download.opensuse.org/distrib...repo/non-oss/] Valid metadata not found at specified URL[0m
    Please check if the URIs defined for this repository are pointing to a valid repository.
    [22;27;31;49mSkipping repository 'Non-oss' because of the above error.[0m
    [22;27;39;49mForcing raw metadata refresh[0m
    [2K
    Retrieving repository 'openSUSE:13.2:NonFree' metadata ----------------------------------------------------------------------------------------------------------------------------[|][2K
    Retrieving repository 'openSUSE:13.2:NonFree' metadata ----------------------------------------------------------------------------------------------------------------------------[\][22;27;39;49m[2K
    Retrieving repository 'openSUSE:13.2:NonFree' metadata .........................................................................................................................[done]
    [22;27;39;49m[22;27;39;49mForcing building of repository cache[0m
    [2K
    Building repository 'openSUSE:13.2:NonFree' cache ---------------------------------------------------------------------------------------------------------------------------------[|][2K
    Building repository 'openSUSE:13.2:NonFree' cache ---------------------------------------------------------------------------------------------------------------------------------[/][2K
    Building repository 'openSUSE:13.2:NonFree' cache ...........................................................................................................................<100%>[/][2K
    Building repository 'openSUSE:13.2:NonFree' cache ...........................................................................................................................<100%>[-][22;27;39;49m[2K
    Building repository 'openSUSE:13.2:NonFree' cache ..............................................................................................................................[done]
    [22;27;39;49m[22;27;39;49mForcing raw metadata refresh[0m
    [2K
    Retrieving repository 'libdvdcss repository' metadata -----------------------------------------------------------------------------------------------------------------------------[-][22;27;39;49m[2K
    Retrieving repository 'libdvdcss repository' metadata ..........................................................................................................................[done]
    [22;27;39;49m[22;27;39;49mForcing building of repository cache[0m
    [2K
    Building repository 'libdvdcss repository' cache ----------------------------------------------------------------------------------------------------------------------------------[\][2K
    Building repository 'libdvdcss repository' cache ----------------------------------------------------------------------------------------------------------------------------------[\][2K
    Building repository 'libdvdcss repository' cache ............................................................................................................................<100%>[|][2K
    Building repository 'libdvdcss repository' cache ............................................................................................................................<100%>[/][22;27;39;49m[2K
    Building repository 'libdvdcss repository' cache ...............................................................................................................................[done]
    [22;27;39;49m[22;27;39;49mForcing raw metadata refresh[0m
    [2K
    Retrieving repository 'Packman Repository' metadata -------------------------------------------------------------------------------------------------------------------------------[|][2K
    Retrieving repository 'Packman Repository' metadata -------------------------------------------------------------------------------------------------------------------------------[-][2K
    Retrieving repository 'Packman Repository' metadata -------------------------------------------------------------------------------------------------------------------------------[\][2K
    Retrieving repository 'Packman Repository' metadata -------------------------------------------------------------------------------------------------------------------------------[|][22;27;39;49m[2K
    Retrieving repository 'Packman Repository' metadata ............................................................................................................................[done]
    [22;27;39;49m[22;27;39;49mForcing building of repository cache[0m
    [2K
    Building repository 'Packman Repository' cache ------------------------------------------------------------------------------------------------------------------------------------[/][2K
    Building repository 'Packman Repository' cache ------------------------------------------------------------------------------------------------------------------------------------[/][2K
    Building repository 'Packman Repository' cache ..............................................................................................................................<100%>[-][2K
    Building repository 'Packman Repository' cache ..............................................................................................................................<100%>[\][22;27;39;49m[2K
    Building repository 'Packman Repository' cache .................................................................................................................................[done]
    [22;27;39;49m[22;27;39;49mForcing raw metadata refresh[0m
    [2K
    Retrieving repository 'openSUSE-42.1-0' metadata ----------------------------------------------------------------------------------------------------------------------------------[-][22;27;39;49m[2K
    Retrieving repository 'openSUSE-42.1-0' metadata ...............................................................................................................................[done]
    [22;27;39;49m[22;27;39;49mForcing building of repository cache[0m
    [2K
    Building repository 'openSUSE-42.1-0' cache ---------------------------------------------------------------------------------------------------------------------------------------[|][2K
    Building repository 'openSUSE-42.1-0' cache ---------------------------------------------------------------------------------------------------------------------------------------[\][2K
    Building repository 'openSUSE-42.1-0' cache .................................................................................................................................<100%>[/][2K
    Building repository 'openSUSE-42.1-0' cache .................................................................................................................................<100%>[-][22;27;39;49m[2K
    Building repository 'openSUSE-42.1-0' cache ....................................................................................................................................[done]
    [22;27;39;49m[22;27;39;49mForcing raw metadata refresh[0m
    [2K
    Retrieving repository 'openSUSE-Leap-42.1-Oss' metadata ---------------------------------------------------------------------------------------------------------------------------[|]
    [22;27;31;49mFile '/media.1/media' not found on medium 'http://download.opensuse.org/distribution/leap/42.1/repo/oss/'
    [0m
    [2K
    [1;39;49mAbort, retry, ignore? [1;39;49m[a[1;39;49m/r[1;39;49m/i[1;39;49m/?[1;39;49m shows all options] (a[1;39;49m)[0m[1;39;49m: [0m[0m[0m[0m[0m[0m[0mi
    [2K
    Retrieving repository 'openSUSE-Leap-42.1-Oss' metadata .......................................................................................................................[[22;27;31;49merror[0m]
    [22;27;31;49mRepository 'openSUSE-Leap-42.1-Oss' is invalid.
    [repo-oss|http://download.opensuse.org/distrib...2.1/repo/oss/] Valid metadata not found at specified URL[0m
    Please check if the URIs defined for this repository are pointing to a valid repository.
    [22;27;31;49mSkipping repository 'openSUSE-Leap-42.1-Oss' because of the above error.[0m
    [22;27;39;49mForcing raw metadata refresh[0m
    [2K
    Retrieving repository 'openSUSE-Leap-42.1-Update' metadata ------------------------------------------------------------------------------------------------------------------------[/]
    [22;27;31;49mFile '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/update/leap/42.1/oss/'
    [0m
    [2K
    [1;39;49mAbort, retry, ignore? [1;39;49m[a[1;39;49m/r[1;39;49m/i[1;39;49m/?[1;39;49m shows all options] (a[1;39;49m)[0m[1;39;49m: [0m[0m[0m[0m[0m[0m[0mi
    [2K
    Retrieving repository 'openSUSE-Leap-42.1-Update' metadata ....................................................................................................................[[22;27;31;49merror[0m]
    [22;27;31;49mRepository 'openSUSE-Leap-42.1-Update' is invalid.
    [repo-update|http://download.opensuse.org/update/leap/42.1/oss/] Valid metadata not found at specified URL[0m
    Please check if the URIs defined for this repository are pointing to a valid repository.
    [22;27;31;49mSkipping repository 'openSUSE-Leap-42.1-Update' because of the above error.[0m
    [22;27;39;49mForcing raw metadata refresh[0m
    [2K
    Retrieving repository 'openSUSE-Leap-42.1-Update-Non-Oss' metadata ----------------------------------------------------------------------------------------------------------------[-]
    [22;27;31;49mFile '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/update/leap/42.1/non-oss/'
    [0m
    [2K
    [1;39;49mAbort, retry, ignore? [1;39;49m[a[1;39;49m/r[1;39;49m/i[1;39;49m/?[1;39;49m shows all options] (a[1;39;49m)[0m[1;39;49m: [0m[0m[0m[0m[0m[0m[0mi
    [2K
    Retrieving repository 'openSUSE-Leap-42.1-Update-Non-Oss' metadata ............................................................................................................[[22;27;31;49merror[0m]
    [22;27;31;49mRepository 'openSUSE-Leap-42.1-Update-Non-Oss' is invalid.
    [repo-update-non-oss|http://download.opensuse.org/update/leap/42.1/non-oss/] Valid metadata not found at specified URL[0m
    Please check if the URIs defined for this repository are pointing to a valid repository.
    [22;27;31;49mSkipping repository 'openSUSE-Leap-42.1-Update-Non-Oss' because of the above error.[0m
    [22;27;31;49mSome of the repositories have not been refreshed because of an error.[0m
    7]2;bill@linux-qli6:~]1;linux-qli68bill@linux-qli6:~> exit
    exit

    Script done on Thu 31 Aug 2017 21:06:42 MDT

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,151

    Default Re: Cannot update 42.1; Problem connecting to a software origin

    Leap-42.1 is out of support. Hence its repositories are no longer maintained.
    Upgrade to Leap-42.3 by downloading an iso image.
    Or (if you feel adventurous) you could try using YaST or zypper to change your repository names and source URLs from "42.1" to "42.3" and performing a "zypper dup".
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Cannot update 42.1; Problem connecting to a software origin

    Meanwhile, if you just need a package or two, the last published updates are still available at:
    https://ftp.gwdg.de/pub/opensuse/dis...ate/leap/42.1/
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  4. #4

    Default Re: Cannot update 42.1; Problem connecting to a software origin

    Well, rats.

    Thank you eng-int and OrsoBruno! I appreciate your responses; I should have thought to check for myself if 42.1 was still supported.

    I'll carve out some time to upgrade later this week.

    With gratitude,

    Bill

  5. #5

    Default Re: Cannot update 42.1; Problem connecting to a software origin

    I've upgraded to 42.3 and all is well. (It took longer to download the ISO and burn the DVD than it took to do the actual upgrade.)

    Thanks for the advice.

    Bill

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •