Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Trouble with Amarok playing music files.

  1. #1
    Join Date
    Oct 2010
    Location
    Akron/Canton Ohio
    Posts
    238

    Default Trouble with Amarok playing music files.

    After upgrading to Leap 42.2 my Amarok software does not play my mp3 files. Can anyone suggest a solution? gstream fluendo is active. Thanks for any help anyone can give me.

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Trouble with Amarok playing music files.

    have you done a full vendor change to packman?
    tell us your repo list
    Code:
    zypper lr -d
    try cleaning your old gstreamer cache
    Code:
    rm -r ~/.cache/gstreamer-1.0/

  3. #3
    Join Date
    Oct 2010
    Location
    Akron/Canton Ohio
    Posts
    238

    Default Re: Trouble with Amarok playing music files.

    Thanks for the response. Sorry for being tardy in responding. Too many things going on! Here is output.

    Code:
    linux-fxo6:~ # rm -r ~/.cache/gstreamer-1.0/
    rm: cannot remove '/root/.cache/gstreamer-1.0/': No such file or directory
    linux-fxo6:~ # zypper lr -d
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                           | Name                                    | Enabled | GPG C
    heck | Refresh | Priority | Type   | URI                                                        
                                           | Service
    ---+---------------------------------+-----------------------------------------+---------+------
    -----+---------+----------+--------+------------------------------------------------------------
    ---------------------------------------+--------
     1 | TP-Link                         | TP-Link                                 | Yes     | (r ) 
    Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Akoellh:/Ke
    rnelmodules/openSUSE_Leap_42.2/        |         
     2 | TP-Link-Update                  | TP-Link-Update                          | Yes     | (r ) 
    Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Akoellh:/Ke
    rnelmodules/openSUSE_Leap_42.2_Update/ |         
     3 | download.opensuse.org-non-oss   | Main Repository (NON-OSS)               | Yes     | (r ) 
    Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/no
    n-oss/                                 |         
     4 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss)             | Yes     | (r ) 
    Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/     
                                           |         
     5 | download.opensuse.org-oss       | Main Repository (OSS)                   | Yes     | (r ) 
    Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/os
    s/                                     |         
     6 | download.opensuse.org-oss_1     | Main Update Repository                  | Yes     | (r ) 
    Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.2/oss          
                                           |         
     7 | google-chrome                   | google-chrome                           | Yes     | ( p) 
    Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64        
                                           |         
     8 | openSUSE-42.2-0                 | openSUSE-42.2-0                         | No      | ----
         | ----    |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-PNY_USB_2.0_FD_AA00000000
    009313-0:0-part2                       |         
     9 | repo-debug                      | openSUSE-Leap-42.2-Debug                | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.2/r
    epo/oss/                               |         
    10 | repo-debug-non-oss              | openSUSE-Leap-42.2-Debug-Non-Oss        | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.2/r
    epo/non-oss/                           |         
    11 | repo-debug-update               | openSUSE-Leap-42.2-Update-Debug         | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.2/oss/   
                                           |         
    12 | repo-debug-update-non-oss       | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.2/non-oss
    /                                      |         
    13 | repo-source                     | openSUSE-Leap-42.2-Source               | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.2/
    repo/oss/                              |         
    14 | repo-source-non-oss             | openSUSE-Leap-42.2-Source-Non-Oss       | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.2/
    repo/non-oss/                          |         
    linux-fxo6:~ #
    
    

    Any ideas? Thanks

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,724

    Default AW: Trouble with Amarok playing music files.

    Second Post in this Subforum?????

    https://forums.opensuse.org/showthre...SUSE-Leap-42-2

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Trouble with Amarok playing music files.

    Quote Originally Posted by jdcart15 View Post
    Thanks for the response. Sorry for being tardy in responding. Too many things going on! Here is output.

    Code:
    linux-fxo6:~ # rm -r ~/.cache/gstreamer-1.0/
    rm: cannot remove '/root/.cache/gstreamer-1.0/': No such file or directory
    linux-fxo6:~ # zypper lr -d
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                           | Name                                    | Enabled | GPG C
    heck | Refresh | Priority | Type   | URI                                                        
                                           | Service
    ---+---------------------------------+-----------------------------------------+---------+------
    -----+---------+----------+--------+------------------------------------------------------------
    ---------------------------------------+--------
     1 | TP-Link                         | TP-Link                                 | Yes     | (r ) 
    Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Akoellh:/Ke
    rnelmodules/openSUSE_Leap_42.2/        |         
     2 | TP-Link-Update                  | TP-Link-Update                          | Yes     | (r ) 
    Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Akoellh:/Ke
    rnelmodules/openSUSE_Leap_42.2_Update/ |         
     3 | download.opensuse.org-non-oss   | Main Repository (NON-OSS)               | Yes     | (r ) 
    Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/no
    n-oss/                                 |         
     4 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss)             | Yes     | (r ) 
    Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/     
                                           |         
     5 | download.opensuse.org-oss       | Main Repository (OSS)                   | Yes     | (r ) 
    Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/os
    s/                                     |         
     6 | download.opensuse.org-oss_1     | Main Update Repository                  | Yes     | (r ) 
    Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.2/oss          
                                           |         
     7 | google-chrome                   | google-chrome                           | Yes     | ( p) 
    Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64        
                                           |         
     8 | openSUSE-42.2-0                 | openSUSE-42.2-0                         | No      | ----
         | ----    |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-PNY_USB_2.0_FD_AA00000000
    009313-0:0-part2                       |         
     9 | repo-debug                      | openSUSE-Leap-42.2-Debug                | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.2/r
    epo/oss/                               |         
    10 | repo-debug-non-oss              | openSUSE-Leap-42.2-Debug-Non-Oss        | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.2/r
    epo/non-oss/                           |         
    11 | repo-debug-update               | openSUSE-Leap-42.2-Update-Debug         | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.2/oss/   
                                           |         
    12 | repo-debug-update-non-oss       | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.2/non-oss
    /                                      |         
    13 | repo-source                     | openSUSE-Leap-42.2-Source               | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.2/
    repo/oss/                              |         
    14 | repo-source-non-oss             | openSUSE-Leap-42.2-Source-Non-Oss       | No      | ----
         | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.2/
    repo/non-oss/                          |         
    linux-fxo6:~ #
    
    

    Any ideas? Thanks
    do
    Code:
    zypper ar -f ftp://packman.inode.at/suse/openSUSE_Leap_42.2/ packman
    zypper dup --from packman
    zypper in vlc-codecs libxine2-codecs

  6. #6
    Join Date
    Oct 2010
    Location
    Akron/Canton Ohio
    Posts
    238

    Default Re: Trouble with Amarok playing music files.

    I had no success with these commands.
    MP3 files will not play.

    Should I give up on Amarok and load another player?

    Anyone know what is going on here?

    Thanks to everyone helping.

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Trouble with Amarok playing music files.

    Quote Originally Posted by jdcart15 View Post
    I had no success with these commands.
    MP3 files will not play.

    Should I give up on Amarok and load another player?

    Anyone know what is going on here?

    Thanks to everyone helping.
    amarok plays mp3 file fine for me
    what's the output of
    Code:
    zypper se -si gstreamer

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Trouble with Amarok playing music files.

    another thing to consider is that amarok is a qt4 application and phonon on LEAP is kf5 (qt5) you might need the phonon for kde4 (libphonon4) as well as a few kde4 dependency packages installed
    what does
    Code:
    zypper se -si phonon
    say?
    if you haven't deleted the gstreamer cache I'd say delete it as it might be the cause of your issues (it's safe to delete it will be recreated by gstreamer)
    Code:
    rm -r ~/.cache/gstreamer-1.0/

  9. #9
    Join Date
    Oct 2010
    Location
    Akron/Canton Ohio
    Posts
    238

    Default Re: Trouble with Amarok playing music files.

    MP3 files are now playing but how do I get the volume control in Armarok? It is stuck on 0% therefore there is no sound. But it now recognizes the mp3 files and seems to be playing them.

    Thanks.

  10. #10

    Default Re: Trouble with Amarok playing music files.

    Quote Originally Posted by jdcart15 View Post
    MP3 files are now playing but how do I get the volume control in Armarok? It is stuck on 0% therefore there is no sound.
    The volume of each application is governed by PulseAudio nowadays.

    Try to set it via the desktop's volume applet (while Amarok is playing), and/or run pavucontrol.
    (although Amarok's volume control should work too)

    If that doesn't help, maybe try to delete ~/.config/pulse/. (but this will reset *all* application's volumes)

    You could also try to disable PulseAudio completely (and use plain ALSA) in YaST->Hardware->Sound->Other->PulseAudio Configuration (logout/in or reboot for full effect).

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •