Results 1 to 3 of 3

Thread: Sane aborts with floating point error

  1. #1
    Join Date
    Aug 2008

    Default Sane aborts with floating point error

    I have a Canoscan Lide 220 on Leap 42.3 x86-64 with the Sane 1.0.27-123.1 backends from the Graphics Project repository. The scanner is found and configured by Yast but both Skanlite and Xsane abort with
    Floating point exception (core dumped)
    message when a preview is reequested (when run from a command line).

    Any help with finding the core dump and solving the problem would be appreciated.


  2. #2
    Join Date
    Feb 2010

    Cool Re: Sane aborts with floating point error

    A quick search revealed that, the Skanlite code has a segment fault issue caused by a failure to check for out-of-range floating point values.

    A quick and dirty fix seems to be: "use another USB port" -- there's also a port related USB power supply issue which provokes the segment fault.

  3. #3
    Join Date
    Oct 2008
    Glasgow, Scotland

    Default Re: Sane aborts with floating point error

    I bought one of these a year ago when the light source failed on a Lide-110
    There are several bug-reports about this model and also the current sane-backends.

    Sane does not work reliably, if at all, with USB-3. Use a USB-2 port if one is available.

    There was still no working driver for the Lide-220 last month. I had eventually bought another Lide-110.
    The alternative was to use proprietary software (there is a free trial which I tried on Leap-42.2 and Tumbleweed, both with Plasma5) which despite being based on sane seems to work even on a USB-3 port.
    slàinte mhath,

    ~ knowing the right answer is easier than knowing the right question.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts