Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

  1. #1

    Default Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

    Zypper geht aber, doch manchmal ist YAST praktischer...

    Die letzten Zeilen von sudo cat /var/log/YaST2/y2log:

    Code:
    ...
    2017-08-29 19:38:09 <1> PC(7437) [Ruby] bin/y2start:16 y2base called with ["sw_single", "qt", "-name", "YaST2", "-icon", "yast"]
    2017-08-29 19:38:09 <1> PC(7437) [ui-component] YUIComponentCreator.cc(createInternal):124 Creating UI component for ""
    2017-08-29 19:38:09 <1> PC(7437) [ui] YSettings.cc(setProgDir):61 Set progDir to "/usr/share/YaST2"
    2017-08-29 19:38:09 <1> PC(7437) [ui] YSettings.cc(setProgDir):62 progDir is now locked.
    2017-08-29 19:38:09 <1> PC(7437) [ui] YSettings.cc(setLocaleDir):147 Set localeDir to "/usr/share/YaST2/locale"
    2017-08-29 19:38:09 <1> PC(7437) [ui] YSettings.cc(setLocaleDir):148 localeDir is now locked.
    2017-08-29 19:38:09 <1> PC(7437) [ui] YPath.cc(YPath):49 Given filename: libyui-qt.so.8
    2017-08-29 19:38:09 <1> PC(7437) [ui] YSettings.cc(progDir):74 progDir: "/usr/share/YaST2"
    2017-08-29 19:38:09 <1> PC(7437) [ui] YPath.cc(YPath):65 Preferring subdir: /usr/share/YaST2
    2017-08-29 19:38:09 <1> PC(7437) [ui] YPath.cc(YPath):66 Subdir given with filename: 
    2017-08-29 19:38:09 <1> PC(7437) [ui] YPath.cc(YPath):67 Looking for: libyui-qt.so.8
    2017-08-29 19:38:09 <1> PC(7437) [ui] YPath.cc(lsDir):138 Looking in /usr/lib64/yui
    2017-08-29 19:38:09 <1> PC(7437) [ui] YPath.cc(YPath):121 Could NOT find libyui-qt.so.8 by looking recursive inside /usr/lib64/yui
    2017-08-29 19:38:09 <3> PC(7437) [ui] YUIPlugin.cc(YUIPlugin):50 Could not load UI plugin "qt": libyui-qt.so.8: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
    2017-08-29 19:38:09 <2> PC(7437) [ui] YUILoader.cc(loadPlugin):195      THROW:    Couldn't load plug-in qt
    Also habe ich nach "libyui-qt.so.8" nachgeschaut:

    Code:
    me@PC:~> zypper se libyui
    Repository 'Packman repository (openSUSE_Tumbleweed)' ist veraltet. Sie können 'zypper refresh' als root ausführen, um es zu aktualisieren.
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name                            | Zusammenfassung                                             | Typ  
    ---+---------------------------------+-------------------------------------------------------------+------
       | libyui-devel                    | Libyui header files                                         | Paket
       | libyui-doc                      | Libyui documentation                                        | Paket
       | libyui-ncurses-devel            | Libyui-ncurses header files                                 | Paket
       | libyui-ncurses-doc              | Libyui-ncurses documentation                                | Paket
       | libyui-ncurses-pkg-devel        | Libyui-ncurses-pkg header files                             | Paket
       | libyui-ncurses-pkg-doc          | Libyui-ncurses-pkg documentation                            | Paket
    i+ | libyui-ncurses-pkg7             | Libyui - yast2 package selector widget for the ncurses UI   | Paket
    i  | libyui-ncurses-pkg8             | Libyui - yast2 package selector widget for the ncurses UI   | Paket
    i+ | libyui-ncurses7                 | Libyui - Character Based User Interface                     | Paket
    i  | libyui-ncurses8                 | Libyui - Character Based User Interface                     | Paket
       | libyui-qt-devel                 | Libyui-qt header files                                      | Paket
       | libyui-qt-doc                   | Libyui-qt documentation                                     | Paket
       | libyui-qt-graph-devel           | Libyui-qt-graph header files                                | Paket
       | libyui-qt-graph-doc             | Libyui-qt-graph documentation                               | Paket
    i+ | libyui-qt-graph7                | Libyui - Qt Graph Widget                                    | Paket
       | libyui-qt-graph8                | Libyui - Qt Graph Widget                                    | Paket
       | libyui-qt-pkg-devel             | Libyui-qt-pkg header files                                  | Paket
       | libyui-qt-pkg-doc               | Libyui-qt-pkg documentation                                 | Paket
    i+ | libyui-qt-pkg7                  | Libyui - Qt Package Selector                                | Paket
       | libyui-qt-pkg8                  | Libyui - Qt Package Selector                                | Paket
    i+ | libyui-qt7                      | Libyui - Qt User Interface                                  | Paket
       | libyui-qt8                      | Libyui - Qt User Interface                                  | Paket
    i+ | libyui7                         | Libyui - GUI-abstraction library                            | Paket
    i  | libyui8                         | Libyui - GUI-abstraction library                            | Paket
       | ruby2.4-rubygem-libyui-rake     | Rake tasks providing basic work-flow for libyui development | Paket
       | ruby2.4-rubygem-libyui-rake-doc | RDoc documentation for libyui-rake                          | Paket
    Installationsversuch von libyui-qt.so.8:

    Code:
    me@PC:~> sudo zypper in libyui*  
    [sudo] Passwort für root: 
    Metadaten von Repository 'Packman repository (openSUSE_Tumbleweed)' abrufen ..................................................................[fertig]
    Cache für Repository 'Packman repository (openSUSE_Tumbleweed)' erzeugen .....................................................................[fertig]
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    'libyui-qt-pkg7', welches 'libyui*' bietet, ist bereits installiert.
    Paket 'libyui-qt-pkg7' ist in Ihren Repositorys nicht vorhanden. Erneute Installation, Upgrade oder Downgrade nicht möglich.
    Paketabhängigkeiten werden aufgelöst...
    Keine auszuführenden Aktionen.
    Hm. Und nun? Was mache ich flasch?

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,721

    Default AW: Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

    Hm. Und nun? Was mache ich flasch?
    Benutze wie früher zum Updaten unter Tumbleweed:
    Code:
    zypper dup --no-allow-vendor-change

  3. #3

    Default Re: Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

    Quote Originally Posted by wodenhof View Post
    Hm. Und nun? Was mache ich flasch?
    Du rufst "sudo zypper in libyui*" auf, probier mal:
    Code:
    sudo zypper in libyui-qt8
    Last edited by wolfi323; 30-Aug-2017 at 12:05.

  4. #4

    Default Re: Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

    Quote Originally Posted by wolfi323 View Post
    ...probier mal:
    Code:
    sudo zypper in libyui-qt8
    Yup. Treffer, versenkt. Das war's. Danke .

  5. #5

    Default Re: AW: Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

    Quote Originally Posted by Sauerland View Post
    Benutze wie früher zum Updaten unter Tumbleweed:
    Code:
    zypper dup --no-allow-vendor-change
    Hallo Sauerland, danke für den Tipp, aber der ist nun nicht mehr nötig. Und ich habe den Verdacht, dass er nicht wirklich geholfen hätte. Schau mal:

    Code:
    me@PC:~> sudo zypper dup --no-allow-vendor-change
    Warnung: Sie sind im Begriff, eine Distributionsaktualisierung mit allen aktivierten Repositorys durchzuführen. Vergewissern Sie sich, dass diese Repositorys kompatibel sind, bevor Sie fortfahren. Weitere Informationen zu diesem Kommando finden Sie unter 'man zypper'.
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Distributions-Aktualisierungen werden verarbeitet...
    7 Probleme:
    Problem: Problem mit installiertem Paket k3b-17.08.0-10.1.x86_64
    Problem: Problem mit installiertem Paket lame-3.99.5-1016.9.x86_64
    Problem: Problem mit installiertem Paket libmad0-0.15.1b-1.31.x86_64
    Problem: Problem mit installiertem Paket libmp3lame0-3.99.5-1016.9.x86_64
    Problem: Problem mit installiertem Paket libtwolame0-0.3.13-3.3.x86_64
    Problem: Problem mit installiertem Paket twolame-0.3.13-3.3.x86_64
    Problem: conky-1.10.6-13.2.x86_64 benötigt liblua.so.5.1()(64bit), kann jedoch nicht zur Verfügung gestellt werden
    
    Problem: Problem mit installiertem Paket k3b-17.08.0-10.1.x86_64
     Lösung 1: k3b-17.08.0-1.1.x86_64 installieren (mit Anbieterwechsel)                                                                                  
      http://packman.links2linux.de --> openSUSE                                                                                                          
                                                                                                                                                          
    Wählen Sie die obige Lösung mittels '1' oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/u/w/a] (a):
    K3b und die Codecs sind ja nicht das Problem. Ausserdem weiß ich nicht, was ich da genau mache, eigentlich wollte ich vlc und die Codecs von Packman schon behalten...

    Aber vielen Dank für Deinen Post .

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,721

    Default AW: Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

    Ich habs erst hinterher gesehen, der
    Code:
    zypper dup --no-allow-vendor-change
    hätte dein Yast2 Problem nicht gelöst, da ja dort unterschiedliche Namen im Spiel waren....
    Code:
    i+ | libyui-qt7                      | Libyui - Qt User Interface                                  | Paket
       | libyui-qt8                      | Libyui - Qt User Interface                                  | Paket
    Da ist wahrscheinlich irgendeine Abhängigkeit beim Paketbau vergessen worden. wolfi323 kann da bestimmt mehr zu sagen.
    Ich hatte den Verdacht, das das neu eingebaute --no-allow-vendor-change bei zypper up nicht funktioniert.

    Aber eigentlich sollte es keine Probleme beim Aufruf von zypper dup --no-allow-vendor-change geben
    Was da bei dir falsch läuft, kann ich jetzt so nicht sagen, da ich Tumbleweed meide.

  7. #7

    Default Re: Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

    Danke für die Ergänzung.

    Anmerkung: Ich bin mit Tumbleweed sehr zufrieden. Ursprünglich habe ich es genommen, um immer die neuesten Treiber fürs Stromsparen auf dem Notebook zu haben (mittlerweile habe ich gelernt, dass ich den neuesten Kernel auch anders bekommen kann). Aber da es gut läuft, nutze ich es seit 2 Jahren praktisch problemlos (naja, von dem hier abgesehen ).

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,721

    Default AW: Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

    Hier die Erklärung zu deinem zypper dup Problem:
    https://forums.opensuse.org/showthre...e-to-zypper-up

  9. #9

    Default Re: Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

    Ahh, okay, danke. Dann ist es ab jetzt zypper dup, wenn ich update. Und Yast funktioniert auch wieder: Nochmals Dank an alle .

  10. #10

    Default Re: Yast2 lädt keine weiteren Programme (wie Install / Delete Software etc.)

    Quote Originally Posted by Sauerland View Post
    Da ist wahrscheinlich irgendeine Abhängigkeit beim Paketbau vergessen worden. wolfi323 kann da bestimmt mehr zu sagen.
    Ja.
    https://bugzilla.opensuse.org/show_bug.cgi?id=1052217

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •