Results 1 to 5 of 5

Thread: Can only install and boot with nomodeset in kernel

  1. #1

    Default Can only install and boot with nomodeset in kernel

    Hi guys,

    I am having trouble finding a way out of the nomodeset parameter in kernel. The only way to boot and to install Leap 42.3 in my notebook (Asus UX 305UA) is by adding nomodeset to boot parameters or i915.modeset=0. But I believe this has implications in the suspension mode of the notebook. When the computer sleeps, I just can't wake it up as the screen remains black. I believe this has something to do with the OS loading with nomodeset. Strangely, one year ago I never had to add nomodeset to kernel, but it know seems as being the only way to boot linux, no matter it being opensuse, manjaro, or most others.

    Here is the output from the command: /sbin/lspci -nnk |grep -A3 VGA
    Code:
    00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake Integrated Graphics [8086:1916] (rev 07)
            Subsystem: ASUSTeK Computer Inc. Device [1043:1000]
            Kernel modules: i915
    00:04.0 Signal processing controller [1180]: Intel Corporation Skylake Processor Thermal Subsystem [8086:1903] (rev 08)
    It seems strange not having a line Kernel driver: i915. The notebook is equipped with a Skylake Intel processor and has ONLY integrated graphics (Intel HD 520).

    Any idea on what can be done to solve the suspension mode problem?

    Thanks!

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,734

    Default AW: Can only install and boot with nomodeset in kernel

    Try the Kernel from kernel:stable Repo?

    Code:
    zypper ar -f http://download.opensuse.org/repositories/Kernel:/stable/standard/ kernel_stable
    Code:
    zypper dup --from kernel_stable

  3. #3

    Default Re: AW: Can only install and boot with nomodeset in kernel

    Quote Originally Posted by Sauerland View Post
    Try the Kernel from kernel:stable Repo?

    Code:
    zypper ar -f http://download.opensuse.org/repositories/Kernel:/stable/standard/ kernel_stable
    Code:
    zypper dup --from kernel_stable
    You're right! The problem is that kernel packed with Leap 42.3 doesn't work out of the box for my Skylake with Intel graphics.

    Following your clue and directions found at https://forums.opensuse.org/showthre...ondary-Display I have added two new repositories:
    Code:
    zypper ar http://download.opensuse.org/repositories/Kernel:/stable/standard/ kernel:stable
    zypper ar http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_Leap_42.3/ XOrg
    After adding repositories, I have done this:
    Code:
    zypper dup --from kernel:stable
    zypper dup --from XOrg
    Then, just followed the steps to install a new kernel 4.12.xx and replace the standard installed 4.4.xx
    I removed nomodeset from kernel boot parameters and rebooted the notebook. Voila! There is support for the i985 chipset and brightness control. Now I can suspend session and wake it up without problems.

    Here is the new output from /sbin/lspci -nnk |grep -A3 VGA
    Code:
    00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake Integrated Graphics [8086:1916] (rev 07)
            Subsystem: ASUSTeK Computer Inc. Device [1043:1000]
            Kernel driver in use: i915
            Kernel modules: i915
    Thanks!

  4. #4
    Join Date
    Aug 2008
    Location
    Maryland
    Posts
    208

    Default Re: Can only install and boot with nomodeset in kernel

    Had the same problem this past Friday on a Gigabyte GA-X99 Phoenix SLI with a Gigabyte GTX 970 and Intel i7 5930K (Hashell). No Skylake or Intel graphics.

    Install of 42.3 required nomodeset. After install and boot XFCE desktop had to much lag to use.

    Install of 42.2 work with out any problems. Upgrade to 42.3 had the same problem. Needed nomodeset to boot, and desktop was laggy until I install NVIDIA Drivers.

  5. #5
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    487

    Default Re: Can only install and boot with nomodeset in kernel

    After an almost problem-free install of 42.3, I experienced (almost) the same blank (NOT black) screen problem. The usual "Login" screen appeared, was totally unusable, then screen "blanked", showing only a working cursor..

    After booting with "Nomodeset", and adding the current kernel from the "Stable" repo, all works as it should.
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.2 x64 + Ubuntu 18.04 LTS, Windows 7

    Test:: openSUSE 15.3, KDE Plasma, Windows/XP/SP3 guest.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •