Results 1 to 2 of 2

Thread: Permissions problem with NVIDIA

  1. #1

    Post Permissions problem with NVIDIA

    Hello! i recently i installed the NVIDIA drivers on a fresh install on opensuse Tumbleweed but i have a problem
    i cant open any 3D application or almost anything unless i do on root, after searching a lot i noticed that the problem relies on the permissions
    Code:
    /etc/modprobe.d/50-nvidia-default.conf
    but when i do a
    Code:
    chmod 777 /dev/nvidia*
    everything works normal

    This is the content of my 50-nvidia-default

    options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=33 NVreg_DeviceFileMode=0666 NVreg_ModifyDeviceFiles=1
    install nvidia PATH=$PATH:/bin:/usr/bin; if /sbin/modprobe --ignore-install nvidia; then if /sbin/modprobe nvidia_uvm; then if [ ! -c /dev/nvidia-uvm ]; then mknod -m 666 /dev/nvidia-uvm c $(cat /proc/devices | while read major device; do if [ "$device" == "nvidia-uvm" ]; then echo $major; break; fi ; done) 0; chown :video /dev/nvidia-uvm; fi; fi; if [ ! -c /dev/nvidiactl ]; then mknod -m 666 /dev/nvidiactl c 195 255; chown :video /dev/nvidiactl; fi; devid=-1; for dev in $(ls -d /sys/bus/pci/devices/*); do vendorid=$(cat $dev/vendor); if [ "$vendorid" == "0x10de" ]; then class=$(cat $dev/class); classid=${class%%00}; if [ "$classid" == "0x0300" -o "$classid" == "0x0302" ]; then devid=$((devid+1)); if [ ! -c /dev/nvidia${devid} ]; then mknod -m 666 /dev/nvidia${devid} c 195 ${devid}; chown :video /dev/nvidia${devid}; fi; fi; fi; done; /sbin/modprobe nvidia_drm; if [ ! -c /dev/nvidia-modeset ]; then mknod -m 666 /dev/nvidia-modeset c 195 254; fi; chown root:root /dev/nvidia-modeset; chmod 666 /dev/nvidia-modeset; fi
    When i do a
    Code:
    getfacl /dev/nvidia*
    
    # file: dev/nvidia-modeset
    # owner: root
    # group: root
    user::rw-
    group::rw-
    other::rw-
    
    # file: dev/nvidia-uvm
    # owner: root
    # group: video
    user::rwx
    group::rwx
    other::rwx
    
    # file: dev/nvidia0
    # owner: root
    # group: 33
    # flags: --t
    user::r--
    group::--x
    other::--x
    
    # file: dev/nvidiactl
    # owner: root
    # group: 33
    # flags: --t
    user::r--
    group::--x
    other::--x
    I tried many workarounds but none of them work, yes im on the video group, and i change the 0660 to 0666 but nothing of that works, i have to manually do a chmod 777 /dev/nvidia* to make it work

    Im using a NVIDIA GT 730 2GB
    some help?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,357
    Blog Entries
    15

    Default Re: Permissions problem with NVIDIA

    On Wed 30 Aug 2017 04:06:01 PM CDT, Azur Lighting wrote:

    Hello! i recently i installed the NVIDIA drivers on a fresh install on
    opensuse Tumbleweed but i have a problem
    i cant open any 3D application or almost anything unless i do on root,
    after searching a lot i noticed that the problem relies on the
    permissions
    Code:
    --------------------
    /etc/modprobe.d/50-nvidia-default.conf
    --------------------

    but when i do a
    Code:
    --------------------
    chmod 777 /dev/nvidia*
    --------------------

    everything works normal

    This is the content of my 50-nvidia-default

    > options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=33
    > NVreg_DeviceFileMode=0666 NVreg_ModifyDeviceFiles=1
    > install nvidia PATH=$PATH:/bin:/usr/bin; if /sbin/modprobe
    > --ignore-install nvidia; then if /sbin/modprobe nvidia_uvm; then
    > if [ ! -c /dev/nvidia-uvm ]; then mknod -m 666 /dev/nvidia-uvm c
    > $(cat /proc/devices | while read major device; do if [ "$device" ==
    > "nvidia-uvm" ]; then echo $major; break; fi ; done) 0; chown
    > :video /dev/nvidia-uvm; fi; fi; if [ ! -c /dev/nvidiactl ];
    > then mknod -m 666 /dev/nvidiactl c 195 255; chown :video
    > /dev/nvidiactl; fi; devid=-1; for dev in $(ls -d
    > /sys/bus/pci/devices/*); do vendorid=$(cat $dev/vendor); if [
    > "$vendorid" == "0x10de" ]; then class=$(cat $dev/class);
    > classid=${class%%00}; if [ "$classid" == "0x0300" -o "$classid"
    > == "0x0302" ]; then devid=$((devid+1)); if [ ! -c
    > /dev/nvidia${devid} ]; then mknod -m
    > 666 /dev/nvidia${devid} c 195 ${devid};
    > chown :video /dev/nvidia${devid}; fi; fi; fi;
    > done; /sbin/modprobe nvidia_drm; if [ ! -c /dev/nvidia-modeset ];
    > then mknod -m 666 /dev/nvidia-modeset c 195 254; fi; chown
    > root:root /dev/nvidia-modeset; chmod 666 /dev/nvidia-modeset; fi


    When i do a

    Code:
    --------------------
    getfacl /dev/nvidia*

    # file: dev/nvidia-modeset
    # owner: root
    # group: root
    user::rw-
    group::rw-
    other::rw-

    # file: dev/nvidia-uvm
    # owner: root
    # group: video
    user::rwx
    group::rwx
    other::rwx

    # file: dev/nvidia0
    # owner: root
    # group: 33
    # flags: --t
    user::r--
    group::--x
    other::--x

    # file: dev/nvidiactl
    # owner: root
    # group: 33
    # flags: --t
    user::r--
    group::--x
    other::--x
    --------------------


    I tried many workarounds but none of them work, yes im on the video
    group, and i change the 0660 to 0666 but nothing of that works, i have
    to manually do a chmod 777 /dev/nvidia* to make it work

    Im using a NVIDIA GT 730 2GB
    some help?


    Hi
    Have a read of this Mailing List thread;
    https://lists.opensuse.org/opensuse-.../msg00281.html

    I would then look at adding your issue to the bug referenced (same
    username/login for the forum);
    https://bugzilla.suse.com/show_bug.cgi?id=1053115

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.79-18.26-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •