Results 1 to 6 of 6

Thread: Does anyone have problem running `at`?

  1. #1
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Does anyone have problem running `at`?

    Hello everyone,

    I am using Tumbleweed snapshot 20170825 (the latest at current). When I run `at` through Konsole, it prompts an error, like below,
    Code:
    cnzhx@ostp:~> at --help
    at: error while loading shared libraries: libfl.so.2: cannot open shared object file: No such file or directory
    And here is the information of `at`,
    Code:
    cnzhx@ostp:~> ls -l /usr/bin/at
    -rwsr-xr-x 1 root trusted 52264 Aug  6 10:46 /usr/bin/at
    cnzhx@ostp:~> rpm -qf /usr/bin/at
    at-3.1.20-1.1.x86_64
    Does anyone know what is the problem here?

    Actually, this is the first time I use `at`.
    Last edited by cnzhx; 30-Aug-2017 at 06:16. Reason: minor change
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: Does anyone have problem running `at`?

    Judging by the error, your libfl2 library is missing.

    How about;
    Code:
    sudo zypper in -f libfl2
    Sidenote:
    In order for at to work, you'll also need the atd daemon running ( systemctl enable atd ; systemctl start atd )
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Does anyone have problem running `at`?

    Ok, I found out that that package `libfl2-2.6.4-2.1.x86_64` was not installed. I do not know why but I try to install it and the problem is solved now.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  4. #4
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Does anyone have problem running `at`?

    Hi, thank you, Miuku,

    Quote Originally Posted by Miuku View Post
    Judging by the error, your libfl2 library is missing.

    How about;
    Code:
    sudo zypper in -f libfl2
    Yes, this solves the problem. Should this be installed with `at` by default?

    Quote Originally Posted by Miuku View Post
    Sidenote:
    In order for at to work, you'll also need the atd daemon running ( systemctl enable atd ; systemctl start atd )
    I am very pleased to know this :-)
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  5. #5
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: Does anyone have problem running `at`?

    Quote Originally Posted by cnzhx View Post
    Ok, I found out that that package `libfl2-2.6.4-2.1.x86_64` was not installed. I do not know why but I try to install it and the problem is solved now.
    It's a bug in the packaging, at does not have a "Requires:" for libfl2 even though it's required.

    I opened a bug report vs Tumbleweed for the at package, here; https://bugzilla.opensuse.org/show_bug.cgi?id=1056428
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  6. #6
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Does anyone have problem running `at`?

    Quote Originally Posted by Miuku View Post
    It's a bug in the packaging, at does not have a "Requires:" for libfl2 even though it's required.

    I opened a bug report vs Tumbleweed for the at package, here; https://bugzilla.opensuse.org/show_bug.cgi?id=1056428
    Thank you. You saved a lot of my time. I'm just trying to find out whether this is a bug or not.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •