Results 1 to 5 of 5

Thread: Change libllvm for amdgpu

  1. #1

    Default Change libllvm for amdgpu

    Leap 42.3 comes with libllvm 3.8 for the amdgpu driver. With this version Cities Skylines have some light glitches. As described in https://bugs.freedesktop.org/show_bug.cgi?id=98984#c3 this should be solved with newer libllvm versions. Anyone knows a way to replace the libllvm version for amdgpu in Leap 42.3?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,324
    Blog Entries
    15

    Default Re: Change libllvm for amdgpu

    Quote Originally Posted by blachner View Post
    Leap 42.3 comes with libllvm 3.8 for the amdgpu driver. With this version Cities Skylines have some light glitches. As described in https://bugs.freedesktop.org/show_bug.cgi?id=98984#c3 this should be solved with newer libllvm versions. Anyone knows a way to replace the libllvm version for amdgpu in Leap 42.3?
    Hi
    A better option is to raise a bug and let the maintainers know and see if the fixes can be (or may already be) backported;

    openSUSE:Submitting bug reports - openSUSE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Change libllvm for amdgpu

    Quote Originally Posted by malcolmlewis View Post
    Hi
    A better option is to raise a bug and let the maintainers know and see if the fixes can be (or may already be) backported;

    openSUSE:Submitting bug reports - openSUSE
    Yes I know. I have already done this, even before Leap 42.3 release:
    https://bugzilla.opensuse.org/show_bug.cgi?id=1030338

    But I have not the feeling that it will be solved for 42.3 soon, if ever. AFAIK Tumbleweed uses a newer libllvm version. But I don't want to switch, because that is the only problem which I have with Leap 42.3 at the moment and otherwise I'm happy with it.

  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,187

    Default Re: Change libllvm for amdgpu

    You can install llvm4 from OBS, there are a few repositories that offer it for 42.3.

    Shouldn't break anything and some applications actually require the new lib offered by it (f.ex. discord)
    .: miuku @ #opensuse @ irc.libera.chat

  5. #5

    Default Re: Change libllvm for amdgpu

    Quote Originally Posted by Miuku View Post
    You can install llvm4 from OBS, there are a few repositories that offer it for 42.3.

    Shouldn't break anything and some applications actually require the new lib offered by it (f.ex. discord)
    Yes I can install some libllvm 4 version from OBS. But this installs in parallel to the existing 3.8 version, which is still used from Mesa. How can I tell Mesa to use the other libllvm version?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •