Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: [leap42.2]vlc can't play ANY audio content & parole can't play mp4videos

  1. #1

    Default [leap42.2]vlc can't play ANY audio content & parole can't play mp4videos


    vlc can't play ANY audio content & parole can't play mp4 videos on my
    Dell Inspiron 15 with 4 x86_64 processors

    The laptop was shipped as a win7 machine. I have a collection of downloaded
    YouTube videos. Some of which are .webm files which parole can handle. But
    a lot of them are older .mp4 videos that I would like to be able to watch
    again. I used to like the way parole managed a playlist.pls list of videos
    But I found that on leap parole can't handle mp4 playback:
    * {note vlc info below}

    parole attempting to play an mp4 file:

    Code:
    additional software is required.
    Parole needs MPEG4 AAC decoder to play this file
    it can be installed automatically
    Code:
    ** Message: PackageKit: xid = 33556106
    ** Message: PackageKit: desktop_id = (null)
    ** Message: PackageKit: Codec nice name: MPEG-4 AAC decoder
    ** Message: PackageKit: ignoring field named level
    ** Message: PackageKit: ignoring field named base-profile
    ** Message: PackageKit: ignoring field named profile
    ** Message: PackageKit: field is: mpegversion, type: gint
    ** Message: PackageKit: structure: gstreamer1(decoder-audio/mpeg)(mpegversion=4)()(64bit)
    ** Message: PackageKit: Did not install codec: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PackageKit was not provided by any .service files
    Also I attempted to search for an applicable MPEG-4 AAC decoder
    with zypper but failed to find anything that does the job.

    So I decided to go with vlc because it can handle both webm and mp4 video files.

    Unfortunately on my Dell laptop {which I use for nighttime playback because
    I can place it where I can reach the pause and other playback controls from
    the recliner I sleep in.} I can NOT get any sound with the pulseaudio device.
    It does not matter if I have my external {headphone jack} speakers connected
    or fallback on the laptop's rather tinny built in speakers...

    vlc attempting to play ANY video file {video will play but sound fails}:

    Code:
    Audio output failed:
    The audio device "default:CARD=PCH" could not be used:
    Invalid argument.
    I tried manually selecting every single audio device that vlc lists
    under audio > audio device:

    And none produced any sound output regardless of whether my external
    headphone jack speakers were plugged in or not.

    Also the choice on that list that refers to alsa always insists that it's
    current default is pulseaudio (which, of course, fails) even if I've
    already selected the non-default card that alsamixer can make work
    as explained in the folowing paragraph. I'm not sure but I think this
    problem would be solved if I could change the alsa default to something
    other than the pulseaudio device. Though I'd much rather be able to
    add a MPEG-4 AAC decoder codec to parole...

    But I don't have a clue how or if I can do either of those?????

    I note that I have little difficulty using mocp {music on console} to
    play my music. Nor is it hard to get sound when I use Google Crome to
    stream videos from hulu. Though in both cases to get decent sound from
    either I need to enable my "headphone" speakers by opening alsamixer in
    a konsole window, selecting the nondefault soundcard and usually unmuting
    the headphone channel that feeds my speakers. I also note that using the
    above methods Parole has no problem paying the audio content of my .webm
    files...

    I should probably mention that I don't actually use KDE. Though I still
    like a few kde apps such as Konsole, Yakuake and okular to name a few.
    What I do use is openbox. Started via startx from a Konsole after my
    user specific environmental variables have been set in my .bashrc.

    Can anyone offer any suggestions on how I can playback my mp4 files
    (with sound) and preferably from a playlist mixed in with my webm
    files? Thanks!

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: [leap42.2]vlc can't play ANY audio content & parole can't play mp4videos

    Are you using the packman packager packaged version of vlc ? Did you install 'vlc-codecs' ?

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: [leap42.2]vlc can't play ANY audio content & parole can't play mp4videos

    Quote Originally Posted by jtwdyp View Post
    Unfortunately on my Dell laptop ... I can NOT get any sound with the pulseaudio device. It does not matter if I have my external {headphone jack} speakers connected
    or fallback on the laptop's rather tinny built in speakers...
    I would like to challenge that conclusion if possible, to see if there IS a way to get pulse audio working. Are you willing to also investigate that possible approach ?

  4. #4

    Default Re: [leap42.2]vlc can't play ANY audio content & parole can't playmp4videos


    It would appear that on Aug 25, oldcpu did say:

    > Are you using the packman packager packaged version of vlc ? Did you
    > install 'vlc-codecs' ?


    Yup, both are the packman versions. But I note my problem with vlc
    isn't the video codecs. Those, unlike the ones available to parole,
    work fine. Even with my problematic mp4 files. That is the video does
    play, silently.
    With vlc I seem unable to get sound output regardless of whether
    the video file is .webm {which parole can handle} or .mp4 {for which
    parole has no access to the needed codec}

    That was a good point though. I was already sure about the vlc version
    but i did double check it when I checked on the 'vlc-codecs' package.
    Thanks.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: [leap42.2]vlc can't play ANY audio content & parole can't play mp4videos

    Quote Originally Posted by jtwdyp View Post
    I tried manually selecting every single audio device that vlc lists
    under audio > audio device:
    Did you try in vlc "tools" > "preferences" => "audio => audio settings => output" => 'output modules' => 'alsa' ... ie try 'alsa'. Note after selecting 'alsa' you may need to then go to "tools" > "preferences" => "audio => audio settings => output" => "Device" and select the appropriate device. Further, note you may need to restart vlc between each and every selection to see if it work. i.e. vlc may need to be restarted for the new audio selection to be applied.

    If that doesn't work, then in case 'pasuspender' is installed, try in an xterm the command to start vlc:
    Code:
    pasuspender vlc
    and then try to see if the 'alsa' option under "tools" > "preferences" => "audio => audio settings => output" => 'output modules'.
    work. Again, don't forget you may need to tune the 'device' setting after selecting alsa.

  6. #6

    Default Re: [leap42.2]vlc can't play ANY audio content & parole can't playmp4videos


    It would appear that on Aug 25, oldcpu did say:

    > jtwdyp;2835457 Wrote:
    > >
    > > Unfortunately on my Dell laptop ... I can NOT get any sound with the
    > > pulseaudio device. It does not matter if I have my external {headphone
    > > jack} speakers connected
    > > or fallback on the laptop's rather tinny built in speakers...

    >
    > I would like to challenge that conclusion if possible, to see if there
    > IS a way to get pulse audio working. Are you willing to also
    > investigate that possible approach ?


    Depending on what I'd need to change on my system to do so, yes!

    To illustrate what I perceive as part of the problem I attempted to
    play an .mp4 with vlc from the bash command line {in a Konsole session}:

    Code:
    JtWdyP -> ~/videos/RescueSpecOpps
    > vlc 'Rescue Special Ops - S02E11 Off The Rails.mp4'
    VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
    [000055a2566220c8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    ALSA lib conf.c:4974:(snd_config_expand) Unknown parameters CARD=PCH
    ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM default:CARD=PCH
    [000055a2566f7618] alsa audio output error: cannot open ALSA device "default:CARD=PCH": Invalid argument
    [000055a2566f7618] core audio output error: module not functional
    [00007f5f450aa7c8] core decoder error: failed to create audio output
    libva info: VA-API version 0.39.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
    libva info: Found init function __vaDriverInit_0_39
    libva info: va_openDriver() returns 0
    [00007f5f44f31418] avcodec decoder: Using OpenGL/VAAPI backend for VDPAU for hardware decoding.
    QObject::~QObject: Timers cannot be stopped from another thread
    JtWdyP -> ~/videos/RescueSpecOpps
    >
    I note that by default it does make use of the alsa lib(s) I also
    notice that the ALSA lib error messages say "CARD=PCH"
    Yet if I open alsamixer to select the card that generally works
    it calls it "HDA Intel PCH"

    And that vlc's pop-up sound error {which I was amazed could actually
    be copied to the clipboard} said:

    Code:
    Audio output failed:
    The audio device "default:CARD=PCH" could not be used:
    Invalid argument.
    This looks to me like vlc actually wants to use the same card that I
    usually manually select in alsamixer but that there may be a mismatch
    in the actual name of the card???

    If so, solving that would be much better than being able to change the
    Default ALSA Output... Except that the list of audio devices that were
    available to manually select had included:
    HDA Intel PCH ALC3234 Analog Default Audio Device
    and several choices for routing the output of that device to the front
    speakers and various surround sound options. NONE OF WHICH WORKED!

    I also note that I have a vague memory of having bumped into this
    problem with sound on vlc once before. It might have been with Leap 42.1
    In which case it wouldn't have been enough of an issue for me to
    pursue it at the time, because back then my primary Linux was Mageia 5
    where parole could still play .mp4 files. AND though I can't remember
    how, There was something I could do that at least temporarily changed
    the Default ALSA Output choice in vlc's audio device list to something
    that worked. What ever it was it didn't involve modifying any
    configurations per se but some sequence that may have involved the
    timing of when I selected the working card in an alsamixer dialog.
    All I can remember is that if I "tricked" the vlc audio device menu
    into saying something in the alsa output choice other than that the
    default was currently pulseaudio, I was able to get the sound working
    for the remainder of the vlc session.

    Now however Leap IS my primary OS and I'd usually have to close too many
    open projects to reboot into Mageia to be worth it just to watch a
    video. And I've learned that I need to upgrade my mageia to mageia 6
    while the upgrade path still exists and I don't know if their version
    of parole can still play the mp4 files...

    So what do you think I'd need to do to get pulseaudio working on my
    laptop??

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,917
    Blog Entries
    2

    Default Re: [leap42.2]vlc can't play ANY audio content & parole can't play mp4videos

    The AAC codec is one of the most commonly used, and should be included in the vlc codecs.
    Also, you should know that the file extensions like .mp4 and .webm are merely "containers" that among things allow you to associate those files with a particular playback application so the file can play "automatically" so have nothing to do with whether you can hear audio or not. <Within> the "container" the content is encoded and this is where a codec like AAC is required.

    So, don't rely on file extensions to troubleshoot your problem.
    Instead, if necessary use a tool like MediaInfo (should be in the OSS) to analyze your file and determine the codecs you need.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: [leap42.2]vlc can't play ANY audio content & parole can't play mp4videos

    your vlc config looks strange did you play with the options
    maybe try removing the vlc config folder (or try it out on a fresh test user account)
    about the audio I'd recommend using yast->hardware->sound and see if your audio hardware is detected and properly configured
    try
    https://en.opensuse.org/SDB:Audio_troubleshooting
    also a full vendor change to packman is a must just installing vlc-codecs is not enough what's your repo list
    Code:
    zypper lr -d

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: [leap42.2]vlc can't play ANY audio content & parole can't play mp4videos

    I concur with I_A, the first and prominent question should always be: did you do the vendor switch to Packman.
    Henk van Velden

  10. #10

    Default Re: [leap42.2]vlc can't play ANY audio content & parole can't playmp4videos


    Thank you oldcpu for the description of how to set the audio settings
    in tools > preferences. And for the info on pasuspender {which is
    installed though I didn't know it existed.} I will try these things
    sometime when I'm more awake.

    I will reply in more detail when I've tried these things.

    But possibly because my brain is tired, I'm not quite sure what you
    meant when you said:
    > Again, don't forget you may need to tune the 'device' setting
    > after selecting alsa.

    Would you mind expanding on that a little?

    --
    jtwdyp


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •