Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Kingsoft WPS Office SegFault with v10.1.0.5707-1.

  1. #1
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Kingsoft WPS Office SegFault with v10.1.0.5707-1.

    Hi

    Older version "wps-office-10.1.0.5672-1.a21.x86_64.rpm" installs & runs [all three modules] in TW [20170822].

    Current version "wps-office-10.1.0.5707-1.a21.x86_64.rpm" installs ok but aborts on launch with SegFault [the following shows attempted launch of Presentation, then Spreadsheet, then Writer]:
    Code:
    gooeygirl@linux-sun7:~> /usr/bin/wpp
    /usr/bin/wpp: line 38:  5413 Segmentation fault      (core dumped) ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"
    
    gooeygirl@linux-sun7:~> /usr/bin/et
    /usr/bin/et: line 38:  5426 Segmentation fault      (core dumped) ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"
    
    gooeygirl@linux-sun7:~> /usr/bin/wps
    /usr/bin/wps: line 38:  5436 Segmentation fault      (core dumped) ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"
    gooeygirl@linux-sun7:~>
    I repeated the tests with older TW snapshots too; 20170821 & 20170725... same results.

    I'm not knowledgeable about SegFaults; are they exclusively caused by badly written 3rd-party pgms [ie, it's Kingsoft's fault], or can it be OS-related [if so, is there anything i can do to avert the problem] pls?

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Kingsoft WPS Office SegFault with v10.1.0.5707-1.

    wps office is in alpha state you should report this with them
    a segfault basically means a dependency issue it could be bad dynamic linking by wps, TW uses gcc7 wps should build their office with gcc 7 but that would break systems using older version of gcc the default on LEAP is 4.8

  3. #3
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Kingsoft WPS Office SegFault with v10.1.0.5707-1.

    Ah, ok, thank you.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,524
    Blog Entries
    15

    Default Re: Kingsoft WPS Office SegFault with v10.1.0.5707-1.

    On Thu 24 Aug 2017 07:36:02 AM CDT, GooeyGirl wrote:

    Ah, ok, thank you.


    Hi
    Create a test user, does it duplicate?

    Run with gdb, eg;
    Code:
    gdb /usr/bin/wpp
    ....
    ....
    (gdb) run <press enter>
    Just tried it here on Tumbleweed, just used the tarball version...works
    fine.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.79-18.26-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Kingsoft WPS Office SegFault with v10.1.0.5707-1.

    Thanks Malcolm. Firstly, i'm sure you'll laugh & roll your eyes when you read this, as clearly i don't have a clue [& "help" left me still clueless]:
    Code:
    gooeygirl@linux-sun7:~> gdb /usr/bin/wpp
    GNU gdb (GDB; openSUSE Tumbleweed) 8.0
    Copyright (C) 2017 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "x86_64-suse-linux".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    <http://bugs.opensuse.org/>.
    Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.
    For help, type "help".
    Type "apropos word" to search for commands related to "word"...
    "/usr/bin/wpp": not in executable format: File format not recognized
    (gdb) run
    Starting program:  
    No executable file specified.
    Use the "file" or "exec-file" command.
    (gdb)
    Yes the same SegFaults occur with a separate User account.

    Wrt your:
    Just tried it here on Tumbleweed, just used the tarball version...works fine.
    ...my initial reaction was "oh golly!". I've now downloaded "wps-office_10.1.0.5707-a21_x86_64.tar.xz", verified its SHA1SUM, & copied it to one of my TW VMs for me to safely experiment with it before [maybe] unleashing it in Tower for-real. Can i pls check first with you though; you did not mention it, but when you "just used the tarball version", is that short-hand for in fact you compiled & built it from source? If so, then i'll start researching now how to do that.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,524
    Blog Entries
    15

    Default Re: Kingsoft WPS Office SegFault with v10.1.0.5707-1.

    On Fri 25 Aug 2017 02:36:02 AM CDT, GooeyGirl wrote:

    Thanks Malcolm. Firstly, i'm sure you'll laugh & roll your eyes when you
    read this, as clearly i don't have a clue [& "-help-" left me still
    clueless]:

    Code:
    --------------------
    gooeygirl@linux-sun7:~> gdb /usr/bin/wpp
    GNU gdb (GDB; openSUSE Tumbleweed) 8.0
    Copyright (C) 2017 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later
    <http://gnu.org/licenses/gpl.html> This is free software: you are free
    to change and redistribute it. There is NO WARRANTY, to the extent
    permitted by law. Type "show copying" and "show warranty" for details.
    This GDB was configured as "x86_64-suse-linux".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    <http://bugs.opensuse.org/>.
    Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.
    For help, type "help".
    Type "apropos word" to search for commands related to "word"...
    "/usr/bin/wpp": not in executable format: File format not recognized
    (gdb) run
    Starting program:
    No executable file specified.
    Use the "file" or "exec-file" command.
    (gdb)



    --------------------


    Yes the same SegFaults occur with a separate User account.

    Wrt your:
    > Just tried it here on Tumbleweed, just used the tarball
    > version...works fine.

    ....my initial reaction was "oh golly!". I've now downloaded
    "-wps-office_10.1.0.5707-a21_x86_64.tar.xz-", verified its SHA1SUM, &
    copied it to one of my TW VMs for me to safely experiment with it before
    [maybe] unleashing it in Tower for-real. Can i pls check first with you
    though; you did not mention it, but when you "-_just_used_ the tarball
    version-", is that short-hand for in fact you compiled & built it from
    source? If so, then i'll start researching now how to do that.


    Hi
    OK, you need to use the binary, I see it's a script... so I think it's
    in /opt/....
    Code:
    gdb /opt/kingsoft/wps-office/wps

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.79-18.26-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  7. #7
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Kingsoft WPS Office SegFault with v10.1.0.5707-1.

    Oh, sigh, i should have extracted the tarball before posting above, not afterwards. Obviously i see now that my assumptions about needing to compile were wrong. From the Readme i saw:
    You can run "WPS Office Writer" by type ./wps, "WPS Office Presentation" by type ./wpp, "WPS Office Spreadsheets" by type ./et.
    However, still no joy:
    Code:
    gooeygirl@linux-sun7:~/Documents/wps-office_10.1.0.5707~a21_x86_64> ./wps./wps: line 38:  2791 Segmentation fault      (core dumped) ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"
    
    
    gooeygirl@linux-sun7:~/Documents/wps-office_10.1.0.5707~a21_x86_64> ./wpp
    ./wpp: line 38:  2803 Segmentation fault      (core dumped) ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"
    
    gooeygirl@linux-sun7:~/Documents/wps-office_10.1.0.5707~a21_x86_64> ./et
    ./et: line 38:  2813 Segmentation fault      (core dumped) ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"
    
    gooeygirl@linux-sun7:~/Documents/wps-office_10.1.0.5707~a21_x86_64>
    Those results were with this TW VM running 20170821, so then i dup'ed it up to the current 20170822 & retried, but with identical results.

    Clearly you know much more powerful magic than i do.

  8. #8
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Kingsoft WPS Office SegFault with v10.1.0.5707-1.

    So, back to the rpm-based installation, & /opt... as per your last post. Thanks for the expanded hints. Here's the attempt for Writer:
    Code:
    gooeygirl@linux-sun7:/opt/kingsoft/wps-office/office6> gdb wps
    GNU gdb (GDB; openSUSE Tumbleweed) 8.0
    Copyright (C) 2017 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "x86_64-suse-linux".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    <http://bugs.opensuse.org/>.
    Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.
    For help, type "help".
    Type "apropos word" to search for commands related to "word"...
    Reading symbols from wps...Missing separate debuginfo for /opt/kingsoft/wps-office/office6/wps
    Try: zypper install -C "debuginfo(build-id)=5c9acb4328e17f5e771882bd60c360f27ffc5135"
    (no debugging symbols found)...done.
    (gdb) run
    Starting program: /opt/kingsoft/wps-office/office6/wps 
    Missing separate debuginfo for /lib64/ld-linux-x86-64.so.2
    Try: zypper install -C "debuginfo(build-id)=af22f9eb22f1aa6798fd75349ca87b5369f1a787"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libspelldllv3.so
    Try: zypper install -C "debuginfo(build-id)=380257614c37f999f1c2dd970a7a354671cbedd9"
    Missing separate debuginfo for /usr/lib64/libspeex.so.1
    Try: zypper install -C "debuginfo(build-id)=fd5a86b64dbb2a5d061ca6f39a8c3b8ef8276497"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libkrt.so
    Try: zypper install -C "debuginfo(build-id)=eee5004f97993c999bfb970c6b3c1ea18859c4cd"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libkso.so
    Try: zypper install -C "debuginfo(build-id)=f1e56111b019256a4336347d0735961fd738141f"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libgriddrawer.so
    Try: zypper install -C "debuginfo(build-id)=d2ac96b6471dacba4c9a6af51234e2e2594cb543"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libwpsio.so
    Try: zypper install -C "debuginfo(build-id)=d32362c2fab3f20d14319ab8ada08d86e9ac8616"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libQtCore.so.4
    Try: zypper install -C "debuginfo(build-id)=748a6ade7ccebbe0cc8677cae92f3d2d105a4f8d"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libxercesc3.so
    Try: zypper install -C "debuginfo(build-id)=712dd566fc4cc5f965153950f198a71521124f3a"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libQtNetwork.so.4
    Try: zypper install -C "debuginfo(build-id)=489610a64f6c2739f2871c8a5f19b43051a6bf4c"
    Missing separate debuginfo for /lib64/librt.so.1
    Try: zypper install -C "debuginfo(build-id)=f3b8741b4579d24360b80195d637530cf0e4d759"
    Missing separate debuginfo for /usr/lib64/libglib-2.0.so.0
    Try: zypper install -C "debuginfo(build-id)=a1c8ed0ddde8028dd99f6be94c1304d26c947c05"
    Missing separate debuginfo for /usr/lib64/libgobject-2.0.so.0
    Try: zypper install -C "debuginfo(build-id)=4468966662ea1fd46bb7cd93e143f7428cf1f748"
    Missing separate debuginfo for /lib64/libdl.so.2
    Try: zypper install -C "debuginfo(build-id)=cd70d8b7b511603bde497c8fbb0d74f5dc1c5659"
    Missing separate debuginfo for /lib64/libpthread.so.0
    Try: zypper install -C "debuginfo(build-id)=342dcee57b91594625557a3abc58f110b7cd24e1"
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib64/libthread_db.so.1".
    Missing separate debuginfo for /usr/lib64/libX11.so.6
    Try: zypper install -C "debuginfo(build-id)=ec9635c205154ffc9d38b2905bdaaedc52b34b17"
    Missing separate debuginfo for /lib64/libm.so.6
    Try: zypper install -C "debuginfo(build-id)=041f71728f3b41382fdea7af4acae8fed3ea2b77"
    Missing separate debuginfo for /lib64/libgcc_s.so.1
    Try: zypper install -C "debuginfo(build-id)=9000c621edfe6084680b60123739e94ac33933f6"
    Missing separate debuginfo for /lib64/libc.so.6
    Try: zypper install -C "debuginfo(build-id)=38ad6753b5ebe6ce252bf4bcbdd262839cab66ed"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libphonon.so.4
    Try: zypper install -C "debuginfo(build-id)=88a9eba9c192a32a8ca8fd6a35245c8f760becbf"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libQtDBus.so.4
    Try: zypper install -C "debuginfo(build-id)=5917ea08dc012a2edf7e1e5ade766c88a021ebab"
    Missing separate debuginfo for /usr/lib64/libfreetype.so.6
    Try: zypper install -C "debuginfo(build-id)=5f0a9868fb82e3df15e6a87b0578026cc4c56f2d"
    Missing separate debuginfo for /usr/lib64/libfontconfig.so.1
    Try: zypper install -C "debuginfo(build-id)=87cfc2711ae0e62c6d4c15bb26579503b0a67add"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libksmso.so
    Try: zypper install -C "debuginfo(build-id)=9d70195beacc0a6fb33d94cd453b451f3916bf24"
    Missing separate debuginfo for /lib64/libz.so.1
    Try: zypper install -C "debuginfo(build-id)=c9b9b18fe15ce4a43f207e73b7e05b47cb05e74b"
    Missing separate debuginfo for /usr/lib64/libgthread-2.0.so.0
    Try: zypper install -C "debuginfo(build-id)=308fb4685cec4e1fc3d218f6b968027c49175782"
    Missing separate debuginfo for /usr/lib64/libpng12.so.0
    Try: zypper install -C "debuginfo(build-id)=b2b38300b19ab21bd8e096bf05319c4dca99f260"
    Missing separate debuginfo for /usr/lib64/libSM.so.6
    Try: zypper install -C "debuginfo(build-id)=488ce271a4e9b76d429602888b6e2cd766e4d4bd"
    Missing separate debuginfo for /usr/lib64/libICE.so.6
    Try: zypper install -C "debuginfo(build-id)=d4e4bc873ed525e252822c6dd2e58e13e1056bfe"
    Missing separate debuginfo for /usr/lib64/libXrender.so.1
    Try: zypper install -C "debuginfo(build-id)=00b45cab61a8513fefdddd479b6412d527a27d13"
    Missing separate debuginfo for /usr/lib64/libXext.so.6
    Try: zypper install -C "debuginfo(build-id)=fe49a1000b33d8ad340e87ba2fb993b6f3ffe929"
    Missing separate debuginfo for /usr/lib64/libpcre.so.1
    Try: zypper install -C "debuginfo(build-id)=48b7a342e7fa717753e0df8facfde904915e2176"
    Missing separate debuginfo for /usr/lib64/libffi.so.7
    Try: zypper install -C "debuginfo(build-id)=6eb7cc94a055463edef860d0d5b2a21c5e532ec6"
    Missing separate debuginfo for /usr/lib64/libxcb.so.1
    Try: zypper install -C "debuginfo(build-id)=9b833ac4bbc09523fa018b11e7a9cc65209f9463"
    Missing separate debuginfo for /usr/lib64/libpulse-mainloop-glib.so.0
    Try: zypper install -C "debuginfo(build-id)=540dbe8461ac88fd81cf7782d77c0a3a289e8ba9"
    Missing separate debuginfo for /usr/lib64/libpulse.so.0
    Try: zypper install -C "debuginfo(build-id)=5afa6b756740eb05f6bea0673ed48f20d292a1c4"
    Missing separate debuginfo for /usr/lib64/libbz2.so.1
    Try: zypper install -C "debuginfo(build-id)=568bc40dfb14e21f57694ca1f08c24ea09da4f92"
    Missing separate debuginfo for /usr/lib64/libpng16.so.16
    Try: zypper install -C "debuginfo(build-id)=439ee4730bfaa1cbfe4f6c4531a1ec63d21105bc"
    Missing separate debuginfo for /usr/lib64/libexpat.so.1
    Try: zypper install -C "debuginfo(build-id)=47e70096ad5d36542494b18989239a32ff571226"
    Missing separate debuginfo for /usr/lib64/libuuid.so.1
    Try: zypper install -C "debuginfo(build-id)=16875d90da2408c2c618c091d95de51f98bebe28"
    Missing separate debuginfo for /usr/lib64/libXau.so.6
    Try: zypper install -C "debuginfo(build-id)=86d79656851311fd78521e28b18cf88b7f7ffec0"
    Missing separate debuginfo for /usr/lib64/pulseaudio/libpulsecommon-10.99.so
    Try: zypper install -C "debuginfo(build-id)=73a3c034a8c669bfc964a60f98f7f41ad77b229a"
    Missing separate debuginfo for /usr/lib64/libdbus-1.so.3
    Try: zypper install -C "debuginfo(build-id)=2f9faf0982e7f9200dcdb2843197c3e22bd55b87"
    Missing separate debuginfo for /usr/lib64/libsystemd.so.0
    Try: zypper install -C "debuginfo(build-id)=ac14c55ea49f2ebd8ecea11686ddf226da4ff592"
    Missing separate debuginfo for /usr/lib64/libsndfile.so.1
    Try: zypper install -C "debuginfo(build-id)=306d5f707e51bc42a4bfcff1940c4b3f8f278d1e"
    Missing separate debuginfo for /lib64/libresolv.so.2
    Try: zypper install -C "debuginfo(build-id)=4f6810cef7a36961152e542d2d184d29e70368b2"
    Missing separate debuginfo for /lib64/libselinux.so.1
    Try: zypper install -C "debuginfo(build-id)=5d73d7ad1522a6a50bf19e70719056a00651dfce"
    Missing separate debuginfo for /usr/lib64/libcap.so.2
    Try: zypper install -C "debuginfo(build-id)=3c8fcc029a82125867cdb82c86633c1a6e3ccf8f"
    Missing separate debuginfo for /usr/lib64/liblzma.so.5
    Try: zypper install -C "debuginfo(build-id)=6a872e1bd880dd2c9bba060d82756ad572d0c9a9"
    Missing separate debuginfo for /usr/lib64/liblz4.so.1
    Try: zypper install -C "debuginfo(build-id)=af18238b9b1b2fdd949c6ff35ded24fee3e0af6e"
    Missing separate debuginfo for /usr/lib64/libgcrypt.so.20
    Try: zypper install -C "debuginfo(build-id)=4d22566ed94b42445f61eb438e5cd0b7d50d4a7f"
    Missing separate debuginfo for /usr/lib64/libgpg-error.so.0
    Try: zypper install -C "debuginfo(build-id)=baa624fd09a045b4a14b2b980a68c19a6db11fbf"
    Missing separate debuginfo for /usr/lib64/libFLAC.so.8
    Try: zypper install -C "debuginfo(build-id)=2c158f29b23f6fe31553d4b9f1ba4d338a9cece8"
    Missing separate debuginfo for /usr/lib64/libogg.so.0
    Try: zypper install -C "debuginfo(build-id)=6b00a7d95e2aad562718b2db8bb7611a47a56f09"
    Missing separate debuginfo for /usr/lib64/libvorbis.so.0
    Try: zypper install -C "debuginfo(build-id)=69036cda875c230b94c24858f7fe99e2a19eaebe"
    Missing separate debuginfo for /usr/lib64/libvorbisenc.so.2
    Try: zypper install -C "debuginfo(build-id)=55c08d2ede668e8843bc141bb69b0445c54c10c5"
    Missing separate debuginfo for /usr/lib64/gconv/UTF-16.so
    Try: zypper install -C "debuginfo(build-id)=95ea14e23f6a711aeffbbb88f9e968533058e429"
    Missing separate debuginfo for /usr/lib64/libXrandr.so.2
    Try: zypper install -C "debuginfo(build-id)=e0e48716f46c49baa37a5bc1439d6ce123533431"
    Missing separate debuginfo for /usr/lib64/libXfixes.so.3
    Try: zypper install -C "debuginfo(build-id)=446be2aebf53829fe05f0257d4b94765639e218b"
    Missing separate debuginfo for /usr/lib64/libXcursor.so.1
    Try: zypper install -C "debuginfo(build-id)=1e9a065497e6f0f02aca30152b230b5ff0a5565b"
    Missing separate debuginfo for /usr/lib64/libXinerama.so.1
    Try: zypper install -C "debuginfo(build-id)=a9dd93da989813b45ffed48101f4e69f8f5f3b79"
    Missing separate debuginfo for /usr/lib64/libXi.so.6
    Try: zypper install -C "debuginfo(build-id)=04842b5af5cbfdca656d65ed3e2f69f3f078d9c5"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libauth.so
    Try: zypper install -C "debuginfo(build-id)=f25d6ba268491abb1012d67e4fde271ec8eaaf52"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/./libkhomepage.so
    Try: zypper install -C "debuginfo(build-id)=ceee8d2cbc65cbfbcb539fabcfe3e0591c743df4"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libQtWebKit.so.4
    Try: zypper install -C "debuginfo(build-id)=ed207723aca57e7d16fe3f54b363910ea9d5aee0"
    Missing separate debuginfo for /usr/lib64/libgio-2.0.so.0
    Try: zypper install -C "debuginfo(build-id)=0c8df627e6a6fb9332b3951c2a500d3462c5fc20"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/./libkglobalmenu.so
    Try: zypper install -C "debuginfo(build-id)=1ef598f8ea4a601078ecef8f478423b8d18f9118"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/./libwpstablestyle.so
    Try: zypper install -C "debuginfo(build-id)=9eb42639e5ba088b011bcc4b4139c1f610e61149"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libkhomepage.so
    Try: zypper install -C "debuginfo(build-id)=ceee8d2cbc65cbfbcb539fabcfe3e0591c743df4"
    Detaching after fork from child process 11491.
    
    Program received signal SIGSEGV, Segmentation fault.
    0x00007f09a2d60878 in _dl_relocate_object () from /lib64/ld-linux-x86-64.so.2
    (gdb)
    To be continued next post, due to character-limits...

  9. #9
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Kingsoft WPS Office SegFault with v10.1.0.5707-1.

    Ditto Spreadsheets:
    Code:
    gooeygirl@linux-sun7:/opt/kingsoft/wps-office/office6> gdb et
    GNU gdb (GDB; openSUSE Tumbleweed) 8.0
    Copyright (C) 2017 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "x86_64-suse-linux".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    <http://bugs.opensuse.org/>.
    Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.
    For help, type "help".
    Type "apropos word" to search for commands related to "word"...
    Reading symbols from et...Missing separate debuginfo for /opt/kingsoft/wps-office/office6/et
    Try: zypper install -C "debuginfo(build-id)=9fac4ff43b857880a1278bd94fe678c9272e9be3"
    (no debugging symbols found)...done.
    (gdb) run
    Starting program: /opt/kingsoft/wps-office/office6/et 
    Missing separate debuginfo for /lib64/ld-linux-x86-64.so.2
    Try: zypper install -C "debuginfo(build-id)=af22f9eb22f1aa6798fd75349ca87b5369f1a787"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libspelldllv3.so
    Try: zypper install -C "debuginfo(build-id)=380257614c37f999f1c2dd970a7a354671cbedd9"
    Missing separate debuginfo for /usr/lib64/libspeex.so.1
    Try: zypper install -C "debuginfo(build-id)=fd5a86b64dbb2a5d061ca6f39a8c3b8ef8276497"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libkrt.so
    Try: zypper install -C "debuginfo(build-id)=eee5004f97993c999bfb970c6b3c1ea18859c4cd"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libapplogic.so
    Try: zypper install -C "debuginfo(build-id)=90c29a295602432080f60461ebd18c4f37ae7315"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libkso.so
    Try: zypper install -C "debuginfo(build-id)=f1e56111b019256a4336347d0735961fd738141f"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libQtCore.so.4
    Try: zypper install -C "debuginfo(build-id)=748a6ade7ccebbe0cc8677cae92f3d2d105a4f8d"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libQtNetwork.so.4
    Try: zypper install -C "debuginfo(build-id)=489610a64f6c2739f2871c8a5f19b43051a6bf4c"
    Missing separate debuginfo for /usr/lib64/libX11.so.6
    Try: zypper install -C "debuginfo(build-id)=ec9635c205154ffc9d38b2905bdaaedc52b34b17"
    Missing separate debuginfo for /lib64/libpthread.so.0
    Try: zypper install -C "debuginfo(build-id)=342dcee57b91594625557a3abc58f110b7cd24e1"
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib64/libthread_db.so.1".
    Missing separate debuginfo for /lib64/libdl.so.2
    Try: zypper install -C "debuginfo(build-id)=cd70d8b7b511603bde497c8fbb0d74f5dc1c5659"
    Missing separate debuginfo for /lib64/libm.so.6
    Try: zypper install -C "debuginfo(build-id)=041f71728f3b41382fdea7af4acae8fed3ea2b77"
    Missing separate debuginfo for /lib64/libgcc_s.so.1
    Try: zypper install -C "debuginfo(build-id)=9000c621edfe6084680b60123739e94ac33933f6"
    Missing separate debuginfo for /lib64/libc.so.6
    Try: zypper install -C "debuginfo(build-id)=38ad6753b5ebe6ce252bf4bcbdd262839cab66ed"
    Missing separate debuginfo for /lib64/librt.so.1
    Try: zypper install -C "debuginfo(build-id)=f3b8741b4579d24360b80195d637530cf0e4d759"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libetsolver.so
    Try: zypper install -C "debuginfo(build-id)=dd6009adf3b8d806914e1815dbe99d928f6c8abe"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libphonon.so.4
    Try: zypper install -C "debuginfo(build-id)=88a9eba9c192a32a8ca8fd6a35245c8f760becbf"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libQtDBus.so.4
    Try: zypper install -C "debuginfo(build-id)=5917ea08dc012a2edf7e1e5ade766c88a021ebab"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libxercesc3.so
    Try: zypper install -C "debuginfo(build-id)=712dd566fc4cc5f965153950f198a71521124f3a"
    Missing separate debuginfo for /usr/lib64/libfreetype.so.6
    Try: zypper install -C "debuginfo(build-id)=5f0a9868fb82e3df15e6a87b0578026cc4c56f2d"
    Missing separate debuginfo for /usr/lib64/libfontconfig.so.1
    Try: zypper install -C "debuginfo(build-id)=87cfc2711ae0e62c6d4c15bb26579503b0a67add"
    Missing separate debuginfo for /usr/lib64/libglib-2.0.so.0
    Try: zypper install -C "debuginfo(build-id)=a1c8ed0ddde8028dd99f6be94c1304d26c947c05"
    Missing separate debuginfo for /usr/lib64/libgobject-2.0.so.0
    Try: zypper install -C "debuginfo(build-id)=4468966662ea1fd46bb7cd93e143f7428cf1f748"
    Missing separate debuginfo for /lib64/libz.so.1
    Try: zypper install -C "debuginfo(build-id)=c9b9b18fe15ce4a43f207e73b7e05b47cb05e74b"
    Missing separate debuginfo for /usr/lib64/libgthread-2.0.so.0
    Try: zypper install -C "debuginfo(build-id)=308fb4685cec4e1fc3d218f6b968027c49175782"
    Missing separate debuginfo for /usr/lib64/libpng12.so.0
    Try: zypper install -C "debuginfo(build-id)=b2b38300b19ab21bd8e096bf05319c4dca99f260"
    Missing separate debuginfo for /usr/lib64/libSM.so.6
    Try: zypper install -C "debuginfo(build-id)=488ce271a4e9b76d429602888b6e2cd766e4d4bd"
    Missing separate debuginfo for /usr/lib64/libICE.so.6
    Try: zypper install -C "debuginfo(build-id)=d4e4bc873ed525e252822c6dd2e58e13e1056bfe"
    Missing separate debuginfo for /usr/lib64/libXrender.so.1
    Try: zypper install -C "debuginfo(build-id)=00b45cab61a8513fefdddd479b6412d527a27d13"
    Missing separate debuginfo for /usr/lib64/libXext.so.6
    Try: zypper install -C "debuginfo(build-id)=fe49a1000b33d8ad340e87ba2fb993b6f3ffe929"
    Missing separate debuginfo for /usr/lib64/libxcb.so.1
    Try: zypper install -C "debuginfo(build-id)=9b833ac4bbc09523fa018b11e7a9cc65209f9463"
    Missing separate debuginfo for /usr/lib64/libpulse-mainloop-glib.so.0
    Try: zypper install -C "debuginfo(build-id)=540dbe8461ac88fd81cf7782d77c0a3a289e8ba9"
    Missing separate debuginfo for /usr/lib64/libpulse.so.0
    Try: zypper install -C "debuginfo(build-id)=5afa6b756740eb05f6bea0673ed48f20d292a1c4"
    Missing separate debuginfo for /usr/lib64/libbz2.so.1
    Try: zypper install -C "debuginfo(build-id)=568bc40dfb14e21f57694ca1f08c24ea09da4f92"
    Missing separate debuginfo for /usr/lib64/libpng16.so.16
    Try: zypper install -C "debuginfo(build-id)=439ee4730bfaa1cbfe4f6c4531a1ec63d21105bc"
    Missing separate debuginfo for /usr/lib64/libexpat.so.1
    Try: zypper install -C "debuginfo(build-id)=47e70096ad5d36542494b18989239a32ff571226"
    Missing separate debuginfo for /usr/lib64/libpcre.so.1
    Try: zypper install -C "debuginfo(build-id)=48b7a342e7fa717753e0df8facfde904915e2176"
    Missing separate debuginfo for /usr/lib64/libffi.so.7
    Try: zypper install -C "debuginfo(build-id)=6eb7cc94a055463edef860d0d5b2a21c5e532ec6"
    Missing separate debuginfo for /usr/lib64/libuuid.so.1
    Try: zypper install -C "debuginfo(build-id)=16875d90da2408c2c618c091d95de51f98bebe28"
    Missing separate debuginfo for /usr/lib64/libXau.so.6
    Try: zypper install -C "debuginfo(build-id)=86d79656851311fd78521e28b18cf88b7f7ffec0"
    Missing separate debuginfo for /usr/lib64/pulseaudio/libpulsecommon-10.99.so
    Try: zypper install -C "debuginfo(build-id)=73a3c034a8c669bfc964a60f98f7f41ad77b229a"
    Missing separate debuginfo for /usr/lib64/libdbus-1.so.3
    Try: zypper install -C "debuginfo(build-id)=2f9faf0982e7f9200dcdb2843197c3e22bd55b87"
    Missing separate debuginfo for /usr/lib64/libsystemd.so.0
    Try: zypper install -C "debuginfo(build-id)=ac14c55ea49f2ebd8ecea11686ddf226da4ff592"
    Missing separate debuginfo for /usr/lib64/libsndfile.so.1
    Try: zypper install -C "debuginfo(build-id)=306d5f707e51bc42a4bfcff1940c4b3f8f278d1e"
    Missing separate debuginfo for /lib64/libresolv.so.2
    Try: zypper install -C "debuginfo(build-id)=4f6810cef7a36961152e542d2d184d29e70368b2"
    Missing separate debuginfo for /lib64/libselinux.so.1
    Try: zypper install -C "debuginfo(build-id)=5d73d7ad1522a6a50bf19e70719056a00651dfce"
    Missing separate debuginfo for /usr/lib64/libcap.so.2
    Try: zypper install -C "debuginfo(build-id)=3c8fcc029a82125867cdb82c86633c1a6e3ccf8f"
    Missing separate debuginfo for /usr/lib64/liblzma.so.5
    Try: zypper install -C "debuginfo(build-id)=6a872e1bd880dd2c9bba060d82756ad572d0c9a9"
    Missing separate debuginfo for /usr/lib64/liblz4.so.1
    Try: zypper install -C "debuginfo(build-id)=af18238b9b1b2fdd949c6ff35ded24fee3e0af6e"
    Missing separate debuginfo for /usr/lib64/libgcrypt.so.20
    Try: zypper install -C "debuginfo(build-id)=4d22566ed94b42445f61eb438e5cd0b7d50d4a7f"
    Missing separate debuginfo for /usr/lib64/libgpg-error.so.0
    Try: zypper install -C "debuginfo(build-id)=baa624fd09a045b4a14b2b980a68c19a6db11fbf"
    Missing separate debuginfo for /usr/lib64/libFLAC.so.8
    Try: zypper install -C "debuginfo(build-id)=2c158f29b23f6fe31553d4b9f1ba4d338a9cece8"
    Missing separate debuginfo for /usr/lib64/libogg.so.0
    Try: zypper install -C "debuginfo(build-id)=6b00a7d95e2aad562718b2db8bb7611a47a56f09"
    Missing separate debuginfo for /usr/lib64/libvorbis.so.0
    Try: zypper install -C "debuginfo(build-id)=69036cda875c230b94c24858f7fe99e2a19eaebe"
    Missing separate debuginfo for /usr/lib64/libvorbisenc.so.2
    Try: zypper install -C "debuginfo(build-id)=55c08d2ede668e8843bc141bb69b0445c54c10c5"
    Missing separate debuginfo for /usr/lib64/gconv/UTF-16.so
    Try: zypper install -C "debuginfo(build-id)=95ea14e23f6a711aeffbbb88f9e968533058e429"
    Missing separate debuginfo for /usr/lib64/libXrandr.so.2
    Try: zypper install -C "debuginfo(build-id)=e0e48716f46c49baa37a5bc1439d6ce123533431"
    Missing separate debuginfo for /usr/lib64/libXfixes.so.3
    Try: zypper install -C "debuginfo(build-id)=446be2aebf53829fe05f0257d4b94765639e218b"
    Missing separate debuginfo for /usr/lib64/libXcursor.so.1
    Try: zypper install -C "debuginfo(build-id)=1e9a065497e6f0f02aca30152b230b5ff0a5565b"
    Missing separate debuginfo for /usr/lib64/libXinerama.so.1
    Try: zypper install -C "debuginfo(build-id)=a9dd93da989813b45ffed48101f4e69f8f5f3b79"
    Missing separate debuginfo for /usr/lib64/libXi.so.6
    Try: zypper install -C "debuginfo(build-id)=04842b5af5cbfdca656d65ed3e2f69f3f078d9c5"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libauth.so
    Try: zypper install -C "debuginfo(build-id)=f25d6ba268491abb1012d67e4fde271ec8eaaf52"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/./libkhomepage.so
    Try: zypper install -C "debuginfo(build-id)=ceee8d2cbc65cbfbcb539fabcfe3e0591c743df4"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libQtWebKit.so.4
    Try: zypper install -C "debuginfo(build-id)=ed207723aca57e7d16fe3f54b363910ea9d5aee0"
    Missing separate debuginfo for /usr/lib64/libgio-2.0.so.0
    Try: zypper install -C "debuginfo(build-id)=0c8df627e6a6fb9332b3951c2a500d3462c5fc20"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/./libkglobalmenu.so
    Try: zypper install -C "debuginfo(build-id)=1ef598f8ea4a601078ecef8f478423b8d18f9118"
    Missing separate debuginfo for /opt/kingsoft/wps-office/office6/libkhomepage.so
    Try: zypper install -C "debuginfo(build-id)=ceee8d2cbc65cbfbcb539fabcfe3e0591c743df4"
    
    Program received signal SIGSEGV, Segmentation fault.
    0x00007fe05a1e8878 in _dl_relocate_object () from /lib64/ld-linux-x86-64.so.2
    (gdb)
    In both cases the splash-screen launched, but that's when the SegFault occurred, so that was the end of the road again.

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,524
    Blog Entries
    15

    Default Re: Kingsoft WPS Office SegFault with v10.1.0.5707-1.

    On Fri 25 Aug 2017 03:26:02 AM CDT, GooeyGirl wrote:

    Oh, sigh, i should have extracted the tarball -before- posting above,
    not afterwards. Obviously i see now that my assumptions about needing to
    compile were wrong. From the Readme i saw:
    > You can run "WPS Office Writer" by type ./wps, "WPS Office
    > Presentation" by type ./wpp, "WPS Office Spreadsheets" by type ./et.

    However, still no joy:

    Code:
    --------------------
    gooeygirl@linux-sun7:~/Documents/wps-office_10.1.0.5707~a21_x86_64>
    *./wps*./wps: line 38: 2791 Segmentation fault (core dumped)
    ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"
    gooeygirl@linux-sun7:~/Documents/wps-office_10.1.0.5707~a21_x86_64>
    *./wpp* ./wpp: line 38: 2803 Segmentation fault (core dumped)
    ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"
    gooeygirl@linux-sun7:~/Documents/wps-office_10.1.0.5707~a21_x86_64>
    *./et* ./et: line 38: 2813 Segmentation fault (core dumped)
    ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"
    gooeygirl@linux-sun7:~/Documents/wps-office_10.1.0.5707~a21_x86_64>
    --------------------


    Those results were with this TW VM running 20170821, so then i -dup'ed-
    it up to the current 20170822 & retried, but with identical results.

    Clearly you know -much- more powerful magic than i do.


    Hi
    So if you check the file where you are ...it's a script (eg cat wpp)
    you need to go into the office6 directory to find the binary (eg wpp),
    then you need to use the FULL path to this file in your gdb command.

    In my case it would be;
    Code:
    gdb /data/wps/office6/wpp
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.79-18.26-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •