Results 1 to 10 of 10

Thread: Google Earth graphics problem

  1. #1

    Default Google Earth graphics problem

    I downloaded the "google-earth-pro-stable-current.x86_64.rpm" for Google Earth 7.3.0.3832-0 and installed it using YaST. I am running a 64-bit system of OpenSuSE Leap 42.2. During the installation, I got an error that the Google Earth package failed the integrity check. I ignored the error, and it finished installing. I was able to open Google Earth and search for a location, but the Google Earth splash screen stayed on the Google Earth viewing window, and I only saw a portion of the map at the top left of the window in a square area about two inches by two inches wide. I tried the online Google Earth version for Chrome, but got a message that my computer doesn't support Web GL. I'm running the open-source Radeon video driver. Any suggestions for getting Google Earth to run on Leap 42.2?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Google Earth graphics problem

    On Thu 24 Aug 2017 01:56:01 AM CDT, jasoncoxTX wrote:

    I downloaded the "google-earth-pro-stable-current.x86_64.rpm" for Google
    Earth 7.3.0.3832-0 and installed it using YaST. I am running a 64-bit
    system of OpenSuSE Leap 42.2. During the installation, I got an error
    that the Google Earth package failed the integrity check. I ignored the
    error, and it finished installing. I was able to open Google Earth and
    search for a location, but the Google Earth splash screen stayed on the
    Google Earth viewing window, and I only saw a portion of the map at the
    top left of the window in a square area about two inches by two inches
    wide. I tried the online Google Earth version for Chrome, but got a
    message that my computer doesn't support Web GL. I'm running the
    open-source Radeon video driver. Any suggestions for getting Google
    Earth to run on Leap 42.2?


    Hi
    What model is your graphics card;
    Code:
    /sbin/lspci -nnk | grep -A3 -E "VGA|3D"
    Try starting (google-earth-pro) from a terminal and see if there is
    additional output.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.79-18.26-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3

    Default Re: Google Earth graphics problem

    I ran google-earth-pro from the command line, but there was no additional output. My graphics card is a Radeon HD 8650G.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Google Earth graphics problem

    Quote Originally Posted by jasoncoxTX View Post
    I ran google-earth-pro from the command line, but there was no additional output. My graphics card is a Radeon HD 8650G.
    Hi
    A Richland device then, so only radeon driver...

    What about the output from;
    Code:
    glxinfo |grep -E "direct|OpenGL"
    I tried it here, but using amdgpu and it's working fine (I know that's no help, but an observation).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Google Earth graphics problem

    Quote Originally Posted by malcolmlewis View Post
    Hi
    A Richland device then, so only radeon driver...

    What about the output from;
    Code:
    glxinfo |grep -E "direct|OpenGL"
    I tried it here, but using amdgpu and it's working fine (I know that's no help, but an observation).
    I'll try getting output from glxinfo on the affected computer when I get home tonight. I successfully installed Google Earth Pro on a computer running Leap 42.2 at my office this morning. The Google Earth package failed the integrity check on this computer, too, but the graphics are displaying properly here. My office computer has a [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 OEM] graphics card, and it's also running the Radeon driver.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Google Earth graphics problem

    Quote Originally Posted by jasoncoxTX View Post
    I'll try getting output from glxinfo on the affected computer when I get home tonight. I successfully installed Google Earth Pro on a computer running Leap 42.2 at my office this morning. The Google Earth package failed the integrity check on this computer, too, but the graphics are displaying properly here. My office computer has a [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 OEM] graphics card, and it's also running the Radeon driver.
    Hi
    Yes, they keys for the google stuff is a sub-key (a zypper fix needed/on the way). The Oland is the next generation up from your card in the home system, that could make a difference...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Default Re: Google Earth graphics problem

    Output from glxinfo |grep -E "direct|OpenGL" is:
    Code:
    direct rendering: Yes
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD ARUBA (DRM 2.43.0, LLVM 3.8.0)
    OpenGL core profile version string: 4.1 (Core Profile) Mesa 11.2.2
    OpenGL core profile shading language version string: 4.10
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
        GL_ARB_direct_state_access, GL_ARB_draw_buffers, 
        GL_ARB_draw_indirect, GL_ARB_draw_instanced, 
        GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect, 
    OpenGL version string: 3.0 Mesa 11.2.2
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.2.2
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
    OpenGL ES profile extensions:

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Google Earth graphics problem

    Hi
    I wonder if a /etc/X11/xorg.conf.d/20-radeon.conf file will help....
    Code:
    Section "Device"
        Identifier "Radeon"
        Driver "radeon"
        Option "TearFree" "on"
        Option "DRI" "3"
        Option "AccelMethod" "glamor"
    EndSection
    Not sure about glamor, if you don't get to a desktop you would need to press ctrl+alt+F1 to a VT and edit out the bits that don't work....

    I have the same type of card in a test system run Leap 42.3 though and it works fine with google-earth-pro...
    Code:
    glxinfo |grep -E "direct|OpenGL"
    
    direct rendering: Yes
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD ARUBA (DRM 2.49.0 / 4.4.79-19-default, LLVM 3.8.0)
    OpenGL core profile version string: 4.1 (Core Profile) Mesa 17.0.5
    OpenGL core profile shading language version string: 4.10
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
        GL_ARB_direct_state_access, GL_ARB_draw_buffers, 
        GL_ARB_draw_indirect, GL_ARB_draw_instanced, 
        GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect, 
    OpenGL version string: 3.0 Mesa 17.0.5
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.0 Mesa 17.0.5
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
    OpenGL ES profile extensions:
    The only thing in 42.3 is a later Mesa version... might be time to look at upgrading to 42.3 anyway?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Default Re: Google Earth graphics problem

    I created the 20-radeon.conf file, and it fixed the problem. I didn't have any trouble getting to my desktop. I'm sure I'll upgrade to 42.3 soon, but it's good to have fixed the problem on my existing system. Thank you for all your help, Malcolmlewis.

  10. #10

    Default Re: Google Earth graphics problem

    Quote Originally Posted by jasoncoxTX View Post
    I created the 20-radeon.conf file, and it fixed the problem. I didn't have any trouble getting to my desktop. I'm sure I'll upgrade to 42.3 soon, but it's good to have fixed the problem on my existing system. Thank you for all your help, Malcolmlewis.
    This solved my problem as well, on a much older Radeon Card running the community radeon drivers.
    I used jasoncoxTX' suggestion for /etc/X11/xorg.conf.d/20-radeon.conf

    Just posting so google will find it. I've been fighting this for two days.





    -----------
    Google Earth Pro 7.3.0.3832 (64-bit)
    Build Date 8/18/2017
    Build Time 4:51:36 pm
    Renderer OpenGL
    Operating System Linux (4.4.92.36)
    Video Driver X.Org R300 Project

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •