Results 1 to 5 of 5

Thread: Upgrade from 42.2 left me with unusable grub

  1. #1

    Default Upgrade from 42.2 left me with unusable grub

    Hi. So the upgrade from 42.2 --> 42.3 seemed to go without incident. I didn't see any errors during the upgrade. However, upon rebooting, I'm left at a grub> prompt. Okay. So we'll just boot manually and repair it after it's booted. Here's the thing: none of the normal grub commands are available from the grub> command line. "ls"? Command not found. "insmod"? also gone. Pressing <TAB> at the command prompt reveals that only "." and "[" are available.

    I've mounted the drive on another Linux system and on the surface nothing seems out of place.

    Any ideas how to recover?

    System details: IBM x3100 M4. I can't tell if it's UEFI or not (there doesn't appear to be a BIOS option to enable/disable EFI) but since I don't see any "efi" stuff in /boot, I assume this is a legacy boot. Unless part of the 42.3 upgrade nuked any efi stuff in the boot partition.

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,593

    Cool Re: Upgrade from 42.2 left me with unusable grub

    The reference documentation for GRUB2 issues is in the "Startup" and "Reference" Guides:
    The exact solution, will depend on what has gone wrong during the upgrade with respect to the GRUB2 configuration.

    The Reference Guide lists all the GRUB2 configuration parameters and their meanings.

    The Startup Guide lists the trouble-shooting steps to take to analyse the GRUB2 issue being experienced.

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Upgrade from 42.2 left me with unusable grub

    Start with
    Code:
    fdisk -l
    and
    Code:
    parted -l
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Upgrade from 42.2 left me with unusable grub

    Quote Originally Posted by arcasinky View Post
    Hi. So the upgrade from 42.2 --> 42.3 seemed to go without incident. I didn't see any errors during the upgrade. However, upon rebooting, I'm left at a grub> prompt. Okay. So we'll just boot manually and repair it after it's booted. Here's the thing: none of the normal grub commands are available from the grub> command line. "ls"? Command not found. "insmod"? also gone. Pressing <TAB> at the command prompt reveals that only "." and "[" are available.

    I've mounted the drive on another Linux system and on the surface nothing seems out of place.

    Any ideas how to recover?

    System details: IBM x3100 M4. I can't tell if it's UEFI or not (there doesn't appear to be a BIOS option to enable/disable EFI) but since I don't see any "efi" stuff in /boot, I assume this is a legacy boot. Unless part of the 42.3 upgrade nuked any efi stuff in the boot partition.
    Here's two passing thoughts:

    Since I'm a big fiddler I occasionally break my bootloader. Being not too clued up about Grub2, I usually boot up my Grub2 CD and ask it to boot the Leap installation. Then I use Yast ==> Bootloader to do it's thing and all is then well again.

    But it sounds like your upgrade process broke your Grub2 installation. That happened to me once also. I used my trusty Grub2 CD on that case too and when I got in to openSUSE I uninstalled Grub completely and reinstalled it in situ. That process fixed Grub2 and fixed the boot config too.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #5
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    392

    Default Re: Upgrade from 42.2 left me with unusable grub

    If you get the grub prompt you should be able to boot from there. You need to tell it where the /boot folder is, the initrd.img and vmlinuz and then tell it to boot. Once in, fix grub as already mentioned. It looks something like this
    Code:
    grub>set root  = 'hdd0,msdos1'
    grub>linux /vmlinuz (or /boot/vmlinuz if /boot isn't on separate partition)
    grub>initrd /initrd (or /boot/initrd)
    grub>boot
    You can input more on those lines if you know it but that should suffice to just get booted.
    Pete

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •