Results 1 to 6 of 6

Thread: Is it possible to install Kmail 4.14 on Leap42.3?

  1. #1

    Default Is it possible to install Kmail 4.14 on Leap42.3?

    I have started migrating several Leap 42.2 machines to leap 42.3 but most users started complaining about kmail 17 on Leap 42.3
    The problems are:
    * Kmail icon missing when there are unread messages
    * Unable to use shift delete
    * "Weird" behavior selecting messages
    * Links inside messages opening twice - for example, a youtube link opens the video on default browser and internally (the video audio starts to play)

    I searched on Internet for solutions and discovered that theses bugs are related to QT 5.6 that was shipped with Leap 42.3, that these bugs do not occur on QT 5.8 and newer and the QT version won't be upgraded in the life cycle of Leap 42.3.

    Questions:
    *Is it true that no bugfix related to this problem are planed?
    *Are there any workaround that I haven't found yet?
    *Is it possible to use kmail 4.14 on Leap 42.3? I've found the repo below that contains kmail 4.14 for Leap 42.3. Is it working Wolfi?
    http://download.opensuse.org/reposit...p_42.3/x86_64/

    Thanks in advance

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Is it possible to install Kmail 4.14 on Leap42.3?

    that sounds more like a plasma 5 (kde applications) issue then a kernel issue
    afaik at the moment that kernel has not been build for LEAP
    https://software.opensuse.org/package/kernel-default
    you can always build it your self but...

    it's not a good idea especially if you have nvidia or amd graphic cards or any extra hardware or you are on production machines
    personally I don't use kmail and I haven't noticed anything
    maybe a better idea would be to migrate to thunderbird or open a bug report at over at kde who do the kmail development
    https://bugs.kde.org/
    even at the opensuse bugzilla (you'd get better advice there too)
    https://bugzilla.opensuse.org/

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Is it possible to install Kmail 4.14 on Leap42.3?

    if you mean this bug
    Bug 1044210 - (CVE-2017-9604) VUL-0: CVE-2017-9604: kmail: send later feature doesn't have "sign/encryption" action ensured a patch has been released just update your system
    Code:
    zypper up

  4. #4

    Default Re: Is it possible to install Kmail 4.14 on Leap42.3?

    Quote Originally Posted by I_A View Post
    that sounds more like a plasma 5 (kde applications) issue then a kernel issue
    afaik at the moment that kernel has not been build for LEAP
    https://software.opensuse.org/package/kernel-default
    you can always build it your self but...

    it's not a good idea especially if you have nvidia or amd graphic cards or any extra hardware or you are on production machines
    personally I don't use kmail and I haven't noticed anything
    maybe a better idea would be to migrate to thunderbird or open a bug report at over at kde who do the kmail development
    https://bugs.kde.org/
    even at the opensuse bugzilla (you'd get better advice there too)
    https://bugzilla.opensuse.org/
    Sorry, I can't see any relation with the kernel in this problem :-)

  5. #5

    Default Re: Is it possible to install Kmail 4.14 on Leap42.3?

    Quote Originally Posted by I_A View Post
    if you mean this bug
    Bug 1044210 - (CVE-2017-9604) VUL-0: CVE-2017-9604: kmail: send later feature doesn't have "sign/encryption" action ensured a patch has been released just update your system
    Code:
    zypper up
    No, it is not related.

    I should have posted the link's related to my problem. This is one of then, and all of them says it's Qt related:
    https://bugs.kde.org/show_bug.cgi?id=376388

    That's why I am trying to downgrade kmail on 42.3. I have stopped upgrading to Leap 42.3 on my clients meanwhile.

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Is it possible to install Kmail 4.14 on Leap42.3?

    Quote Originally Posted by marcelovborro View Post
    No, it is not related.

    I should have posted the link's related to my problem. This is one of then, and all of them says it's Qt related:
    https://bugs.kde.org/show_bug.cgi?id=376388

    That's why I am trying to downgrade kmail on 42.3. I have stopped upgrading to Leap 42.3 on my clients meanwhile.
    if a newer Qt version is required you can get it from the KDE:/Qt5 repo
    LEAP will stay on Qt 4.6 it will not get an upgrade
    you can get Qt 4.9 from here
    http://download.opensuse.org/reposit...USE_Leap_42.3/
    Code:
    zypper ar -f http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.3/KDE:Qt5.repo
    zypper dup --from http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.3/
    but moving to Qt 4.9 might (it should be backward compatible with KDE Plasma 5.8) require the KDE:/Frameworks5 and KDE:/Applications repo's
    http://download.opensuse.org/reposit...USE_Leap_42.3/
    http://download.opensuse.org/reposit...USE_Leap_42.3/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •