Results 1 to 6 of 6

Thread: Wrote MBR to wrong disk

  1. #1

    Default Wrote MBR to wrong disk

    My OpenSuse 42.3 wrote Grub to a different MBR than all the other Linux Distros, so I had to use BIOS to change the first hard drive to load it. Is there a way to specify the disk to which the bootloader is going to be written? I intend to reinstall the OS to the same partition but specify /sda rather than /sdb. I just don't know where to check that option during installation. This has never happened before all my linux installations have gone to /sda. Thanks in advance for any assistance.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: Wrote MBR to wrong disk

    Quote Originally Posted by awparsons23 View Post
    Is there a way to specify the disk to which the bootloader is going to be written?
    Yes, there is.

    I'll have to boot up another machine to get the details. I'm currently on a UEFI box, where the question does not arise.

    If you already have 42.3 installed, use

    Yast --> System --> Boot Loader

    to pull up the screen to see what you are looking for.

    During install, there is a summary page. Click on the heading for Booting and you will get about the same screen.

    When I look at that screen on a system that does MBR booting, I see (toward the bottom left):
    "Edit Disk Boot Order"

    Click on that. It should list your disks. And you can select a line and move it up or down until you get them in the right order. It will list the disks as "/dev/sda", "/dev/sdb" etc. If you install with a USB, that USB will be one of the listed disks. Use the device names as they are seen during install. Maybe take notes during the partitioning section of install, so that you can be sure you have the right names for the disks.

    If you look at this from a running system, you can click "Cancel" to not save any changes. During the install, you will need to save the changes.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: Wrote MBR to wrong disk

    Thanks for the information. In the installed Opensuse my three disks were listed in reversed alphabetical order /sdc /sdb /sda. Grub was written to sdc which is my smallest disk 320gb with the 15 linux partitions on it. All my other Linux installations wrote grub to /sda, I changed the order in the installed Opensuse so that /sda was first ank clicked ok. It errored out after the progress bar went around half way with some reference when it stopped to incoimpatibility with btrfs formattting. Do you think I am better off leaving well enough alone or do you think changing the disk order in a real installation would get me a successful addition of OpenSuse on /sda. Installing the latest version of Linux MInt today did not succeed in adding OpenSuse to the boot menu even though it scanned all the partitions during the last stage of the installation..It's a pain having to go into Bios just to load Opensuse.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: Wrote MBR to wrong disk

    Quote Originally Posted by awparsons23 View Post
    Thanks for the information. In the installed Opensuse my three disks were listed in reversed alphabetical order /sdc /sdb /sda. Grub was written to sdc which is my smallest disk 320gb with the 15 linux partitions on it.
    I think openSUSE defaults to putting the disk where installed as the first disk.

    All my other Linux installations wrote grub to /sda, I changed the order in the installed Opensuse so that /sda was first ank clicked ok. It errored out after the progress bar went around half way with some reference when it stopped to incoimpatibility with btrfs formattting.
    That should have worked. Maybe try it again. But this time, check very carefully to see that the "boot from MBR" box is checked. The error message suggests it was trying to install to boot from the root partition instead of the MBR.

    Do you think I am better off leaving well enough alone or do you think changing the disk order in a real installation would get me a successful addition of OpenSuse on /sda.
    That's a question that only you can answer. I would probably make the change.

    Installing the latest version of Linux MInt today did not succeed in adding OpenSuse to the boot menu even though it scanned all the partitions during the last stage of the installation.
    That's because it has problems scanning a "btrfs" file system. I've run into that in the past.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5

    Default Re: Wrote MBR to wrong disk

    [QUOTE=nrickert;2835010]I think openSUSE defaults to putting the disk where installed as the first disk.


    That should have worked. Maybe try it again. But this time, check very carefully to see that the "boot from MBR" box is checked. The error message suggests it was trying to install to boot from the root partition instead of the MBR.

    Please advise about all the other options and what should be checked and what should not be checked. I tried it two or three more times with the same result each time.

    Also please advise if the options checked and unchecked will be exactly the same if I reinstall from the dvd. I'm a bit vague in my mind as to when the boot loader option appears when installing from dvd.

    Thanks again.

  6. #6

    Default Re: Wrote MBR to wrong disk

    I tried from inside the installed OpenSuse on /sdc over and over but it still hung at 50% and soon have a complex error message that meant nothing to me. Today I reformatted that parrtion and tried it again hoping to force it to /sda where grub is written for all the other Linux distros. Now it's back to where it was originally where it won't allow me to write a single mount point / and now opting to format to BTRFS does not help. I don't know what I did to enable the boot to /adc It keeps wanting to format partitions 5 and 6 which are presently two versions of Ubuntu. It seems to demand a whole disk with absolutely nothing on it. Am I the only one who can't get this thing started. Would it help to delete partition 11 instead of formatting it to ext4.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •