Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Booting trouble (Really urgent!!!)

  1. #1

    Exclamation Booting trouble (Really urgent!!!)

    HI All.

    I am novice with the Booting system and topics concerning the GRUB/MBR. So please help me with as many details as possible.

    Problem: I can not boot my opensuse Leap 42.3 without using a install USB. Apparently, using the USB I can load the installation.

    Details: I installed Ubuntu first. But then I wanted to install Opensuse and after doing that I found this problem. Even now, the bootloader shows Ubuntu as the top option despite having overwritten by opensuse.

    System details:

    lspci output:


    00:00.0 Host bridge: Intel Corporation Device 5904 (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02)
    00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
    00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
    00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
    00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
    00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
    00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
    00:1d.0 PCI bridge: Intel Corporation Device 9d18 (rev f1)
    00:1d.2 PCI bridge: Intel Corporation Device 9d1a (rev f1)
    00:1d.3 PCI bridge: Intel Corporation Device 9d1b (rev f1)
    00:1f.0 ISA bridge: Intel Corporation Device 9d58 (rev 21)
    00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
    00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
    00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
    01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940MX] (rev a2)
    02:00.0 SD Host controller: O2 Micro, Inc. Device 8621 (rev 01)
    04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
    05:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
    fdisk -l output:
    Disk /dev/sdb: 238.5 GiB, 256060514304 bytes, 500118192 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: gpt
    Disk identifier: 9167B343-9286-431B-A54E-1E4C6F7AD440

    Device Start End Sectors Size Type
    /dev/sdb1 2048 49151 47104 23M BIOS boot
    /dev/sdb2 49152 83939327 83890176 40G Microsoft basic data
    /dev/sdb3 83939328 468647935 384708608 183.5G Microsoft basic data
    /dev/sdb4 468647936 500117503 31469568 15G Microsoft basic data

    As you can see this output prints the SDD as the sdb. With USB inserted the same command reads:

    Disk /dev/sdb: 238.5 GiB, 256060514304 bytes, 500118192 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: gpt
    Disk identifier: 9167B343-9286-431B-A54E-1E4C6F7AD440

    Device Start End Sectors Size Type
    /dev/sdb1 2048 49151 47104 23M BIOS boot
    /dev/sdb2 49152 83939327 83890176 40G Microsoft basic data
    /dev/sdb3 83939328 468647935 384708608 183.5G Microsoft basic data
    /dev/sdb4 468647936 500117503 31469568 15G Microsoft basic data


    Disk /dev/sda: 29.9 GiB, 32034041856 bytes, 62566488 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x1b681c50

    Device Boot Start End Sectors Size Id Type
    /dev/sda1 4220 12031 7812 3.8M ef EFI (FAT-12/16/32)
    /dev/sda2 * 12032 9062399 9050368 4.3G 17 Hidden HPFS/NTFS

    Please help!! It is quite urgent for me to get things moving as my laptop is currently the only device that I can use to do work! I would be really grateful if someone can sort the issue out!

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Booting trouble (Really urgent!!!)

    Well Assuming EFI boot just over writing does not change the the entries into the UEFI flash. You pretty much have to manually do that.

    Read the man efibootmgr pages that tool allows you to edit/change the UEFI flash settings.

  3. #3

    Default Re: Booting trouble (Really urgent!!!)

    Hi.

    Thanks for the reply! Unfortunately, I have no idea what you just said. Can you explain in detail?

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Booting trouble (Really urgent!!!)

    Read the man pages ie at a console prompt type man efibootmgr for the man (ie HELP) pages

    From the first read of your problem it seem like the problem is in the UEFI (aka BIOS). BTW are you doing any kind of dual boot?. In any case you should be able to set boot order in the UEFI. Though you may not be able to remove the Ubuntu entry from there. You can from the efibootmgr.

    The UEFI stores boot information in its built in flash

  5. #5

    Default Re: Booting trouble (Really urgent!!!)

    Quote Originally Posted by gogalthorp View Post
    Read the man pages ie at a console prompt type man efibootmgr for the man (ie HELP) pages

    From the first read of your problem it seem like the problem is in the UEFI (aka BIOS). BTW are you doing any kind of dual boot?. In any case you should be able to set boot order in the UEFI. Though you may not be able to remove the Ubuntu entry from there. You can from the efibootmgr.

    The UEFI stores boot information in its built in flash
    Thanks.

    No dual boot.

    Running efibootmgr readsL

    EFI variables are not supported on this system.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Booting trouble (Really urgent!!!)

    OK so it is an old BIOS or you installed using legacy (MBR) boot

    But I see
    Code:
    /dev/sdb1       2048     49151     47104    23M BIOS boot
    Which indicates an EFI boot

    Perhaps you installed Ubuntu in EFI and openSUSE in MBR boot mode. In any case you should be able to set boot order in the UEFI (consult the computer's manual for which key to press during boot)

  7. #7

    Default Re: Booting trouble (Really urgent!!!)

    Quote Originally Posted by gogalthorp View Post
    OK so it is an old BIOS or you installed using legacy (MBR) boot

    But I see
    Code:
    /dev/sdb1       2048     49151     47104    23M BIOS boot
    Which indicates an EFI bootng

    Perhaps you installed Ubuntu in EFI and openSUSE in MBR boot mode. In any case you should be able to set boot order in the UEFI (consult the computer's manual for which key to press during boot)
    Hmm.

    Will installing opensuse again help? if I select UEFI (speaking from memory here) during install it throws a warning that this combination is not proper (or something or that sort).

  8. #8

    Default Re: Booting trouble (Really urgent!!!)

    Ok. tried changing the boot load order from UEFI first to legacy first and sadly that did not solve the issue.

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Booting trouble (Really urgent!!!)

    Go to yast-bootloader and see if you are using grub2 or grub2-efi.

    When installing you need to boot the install media in EFI mode

    You should then default to grub2-efi boot loader and you should have the efi-boot partition set to format as FAT and mount at /boot/efi. You may want to format this partition to remove any trace of Ubuntu since you are not dual booting

    Since you have partitions now you will need to chose which to use as what. If you hae real data in /home then you may want to set the home partition NOT to format

  10. #10

    Default Re: Booting trouble (Really urgent!!!)

    Quote Originally Posted by gogalthorp View Post
    Go to yast-bootloader and see if you are using grub2 or grub2-efi.

    When installing you need to boot the install media in EFI mode

    You should then default to grub2-efi boot loader and you should have the efi-boot partition set to format as FAT and mount at /boot/efi. You may want to format this partition to remove any trace of Ubuntu since you are not dual booting

    Since you have partitions now you will need to chose which to use as what. If you hae real data in /home then you may want to set the home partition NOT to format

    Hi.

    It says no EFI partition found.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •